Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E90/E91/E92/E93 (2006 - 2013)

E90/E91/E92/E93 (2006 - 2013)
The E9X is the 4th evolution of the BMW 3 series including a highly tuned twin turbo 335i variant pushing out 300hp and 300 ft. lbs. of torque. BMW continues to show that it sets the bar for true driving performance! -- View the E9X Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 05-16-2014, 12:16 PM
maverick17036 maverick17036 is offline
Registered User
Location: Washington, DC
 
Join Date: Apr 2014
Posts: 6
Mein Auto: 2010 328i (coupe) xdrive
Engine shaking at idle

Hello all! In March I bought this 2010 328i Xdrive Coupe and now I'm having some engine issues. It seems to randomly and slightly shake when I first start it and when its at idle. I also feel it when I'm in reverse backing slowly into a parking spot.

Let's start with some history...A few weeks after I bought the car, I get a random check engine light (code P0306- cylinder 6 misfire detected) and I couldn't drive above about 30 mph. It was sputtering really bad. I replaced all spark plugs and ignition coils myself which fixed the issue (btw after I complained, the dealer gave me a check for $700 to cover the cost of all the parts). Now I notice this idling issue that wasn't happening before. Moreover, I might be losing oil. I changed the oil a month ago. After replacing it and driving it for a day my level was slightly below the max line. Now its down to the half way point between max and minimum and I smell oil burning at times. Not sure if this oil issue is related to the idling issue.

Anyway, I've done my research and the rough idling/shaking issue seems to be either HPFP, injectors, spark plugs, or coils. I've replaced the plugs and coils so I wonder if should replace the injectors now. Yesterday I bought an extended warranty at the local bmw dealer as well. I just want the problem fixed. Any suggestions?
Reply With Quote
Advertisement
  #2  
Old 05-16-2014, 12:53 PM
fdriller9 fdriller9 is offline
Officially Welcomed to the 'Fest
Location: NJ/Philly
 
Join Date: Oct 2006
Posts: 3,076
Mein Auto: '06 AW 330xi
Might be sticking vanos solenoids. Remove them and clean with compressed air. Then swap them from intake to exhaust side and vice versa.

Btw the N52 doesn't have the same HPFP issues the N54 has.
__________________

| LCI Msport Conversion | Custom Kevlar/Carbon Fiber Wind Splitter | Exotic Tuning Front Lip | H&R Coilovers | M3 Subframe Bushings | E93 M3 23.6mm Rear Sway Bar | Whiteline 27mm Front Sway Bar | Ground Control Camber Kit | L7 | Hand-Made LED Angel Eyes | Breyton GTS-R | Bridgestone Pole Position S-04 | CarPC with Centrafuse Front End | Alpine MRP-M500 | Custom LED Reverse Lights | OEM Blacklines | BMW Performance Trunk Spoiler |
Reply With Quote
  #3  
Old 05-16-2014, 01:01 PM
maverick17036 maverick17036 is offline
Registered User
Location: Washington, DC
 
Join Date: Apr 2014
Posts: 6
Mein Auto: 2010 328i (coupe) xdrive
Thanks fdriller9! Good to know about the HPFP as most of the research was on the N54, not the N52. So for the solenoids, do you recommend me using the warranty to fix this or is this something an average DIYfer can do?
Reply With Quote
  #4  
Old 05-16-2014, 01:58 PM
wilt wilt is offline
Officially Welcomed to the 'Fest
Location: SF Bay area
 
Join Date: Jan 2014
Posts: 719
Mein Auto: 2011 328i
Quote:
Originally Posted by maverick17036 View Post
Hello all! In March I bought this 2010 328i Xdrive Coupe and now I'm having some engine issues. It seems to randomly and slightly shake when I first start it and when its at idle. I also feel it when I'm in reverse backing slowly into a parking spot.
...I might be losing oil. I changed the oil a month ago. After replacing it and driving it for a day my level was slightly below the max line. Now its down to the half way point between max and minimum and I smell oil burning at times. Not sure if this oil issue is related to the idling issue.
You could also have a slight vacuum leak, which would result in some leanness of mixture during idle, and especially noticed when the cold engine needs a bit more rich mixture than when running at temperture. The oil leakage could accompany the vacuum break, as well. A cracked valve cover might permit both air leak and oil seepage.
Reply With Quote
  #5  
Old 05-16-2014, 02:35 PM
SilverX3's Avatar
SilverX3 SilverX3 is online now
Officially Welcomed to the 'Fest
Location: Australia
 
Join Date: Sep 2005
Posts: 3,097
Mein Auto: 130i & E92 325i, E90 SOLD
Vanos solenid. Very easy diy
__________________
Residence - StarTrek Enterprise
Job - Captain
Current Starship Fleet:
06 130i - ROCK SOLID Performer
MY11.5 X1 Xdrive25i
2013 VW Golf R - Rising Metallic Blue
07 320i - SOLD
08 E92 325i - Blue SOLD
Bicycles: Giant TCR Advanced Zero SOLD, Argon 18 Krypton, Argon 18E114, Trek Madone COMING
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E90/E91/E92/E93 (2006 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 07:36 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms