Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)

X5 E70 (2007 - 2013)
E70 BMW X5 produced between 2007 and 2013. Discuss the E70 X5 with other BMW owners here.

Reply
 
Thread Tools Display Modes
  #51  
Old 07-17-2014, 09:42 AM
redwood78 redwood78 is offline
Registered User
Location: Northeast
 
Join Date: Jul 2014
Posts: 23
Mein Auto: e70 lci
Quote:
Originally Posted by serge1 View Post
Sorry to hear it didn't fix the long crank. At the very least, you have eliminated one of common causes, at low cost.
yeah, i don't mind throwing parts at a problem when the parts are cheap and the labor is free. dealer parts price + dealer labor is a whole other thing.

in the meantime, i hear there is a software update that causes the fuel pump to prime longer when you open the door up. thus putting more fuel where it should be at start up and reducing crank time. i'm going to have the dealer check if it has the latest software version when it goes in for the vanos recall, which will hopefully be soon. i'm not holding my breath though, if i had a nickle for every time bmw told me "it just needs a software update," i'd be rich.
Reply With Quote
  #52  
Old 07-17-2014, 09:51 AM
serge1's Avatar
serge1 serge1 is offline
Officially Welcomed to the 'Fest
Location: seattle
 
Join Date: Jan 2012
Posts: 708
Mein Auto: 2011 BMW X5 35D
Pretty good success rate by replacing the relay, so you weren't throwing parts at it in classical meaning of that term.
Good luck with software update. Let us know how it goes
Reply With Quote
  #53  
Old 08-10-2014, 02:21 PM
redwood78 redwood78 is offline
Registered User
Location: Northeast
 
Join Date: Jul 2014
Posts: 23
Mein Auto: e70 lci
just reporting back that it turned out to be the hpfp. dealer replaced it and all seems well.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 12:27 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms