Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)

X3 E83 (2004 - 2010)
Talk about the E83 BMW X3 in this forum!

Reply
 
Thread Tools Display Modes
  #1  
Old 08-13-2014, 07:33 PM
snowball2014 snowball2014 is offline
Registered User
 
Join Date: Aug 2014
Posts: 2
Mein Auto:
X3 High Pitched Ringing Sound

The X3 (2009) developed a high pitched ringing or high frequency sound. It does not appear to be coming from the engine but rather from under the car. It comes and goes but is particularly evident at idle? Any thoughts on what could be?


Sent from BimmerApp mobile app
Reply With Quote
Advertisement
  #2  
Old 08-14-2014, 06:19 AM
tim330i's Avatar
tim330i tim330i is offline
Administrator
Location: Boston
 
Join Date: Dec 2001
Posts: 5,913
Mein Auto: Ti Silver 03 M3
Welcome to Bimmerfest! I've moved your question to the E83 X3 forum, you'll get more help in here.

Good luck,
Tim
Reply With Quote
  #3  
Old 08-16-2014, 05:44 AM
Frenchx3 Frenchx3 is online now
Officially Welcomed to the 'Fest
Location: NH
 
Join Date: May 2009
Posts: 122
Mein Auto: 2005 X3
If it's present at idle put it in park and get down on the ground and see if you can narrow down the area the noise is coming from. Maybe have somone sit in the drivers seat to rev the engine a bit. Report back what you find.

Sent from BimmerApp mobile app
Reply With Quote
  #4  
Old 08-16-2014, 07:14 AM
snowball2014 snowball2014 is offline
Registered User
 
Join Date: Aug 2014
Posts: 2
Mein Auto:
It could be the tensioner belt or may be the water pump. Previously, the water pump was showing up on the analytics as not fully functioning.




Sent from BimmerApp mobile app
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 06:17 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms