Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > F10 / F11 (2011 - Current)

F10 / F11 (2011 - Current)
The new chapter in the highly successful story of the BMW 5 Series Sedan (F10) and wagon (F11)

Reply
 
Thread Tools Display Modes
  #1  
Old 11-04-2013, 09:58 AM
Dave Smith Dave Smith is offline
Registered User
Location: Los Angeles
 
Join Date: Nov 2013
Posts: 2
Mein Auto: 528i
TPM Light on after swapping wheels

Hello,

I have a 2011 528i and swopped out my wheels and tires completely with another set that came off a 2012 535i. My original wheels were 17" and the new ones I put on are 18". The computer say tire pressure malfunction.

Question: Are my old sensors programmed to my car? Do I need to have these new sensors reprogrammed to my car. Air pressures are correct. Light came on right away after the swop.

Please help...

Thank you
Reply With Quote
Advertisement
  #2  
Old 11-04-2013, 10:03 AM
grover432 grover432 is offline
Officially Welcomed to the 'Fest
Location: Canada
 
Join Date: Jan 2007
Posts: 634
Mein Auto: 2013 535 X Drive M Sport
Quote:
Originally Posted by Dave Smith View Post
Hello,

I have a 2011 528i and swopped out my wheels and tires completely with another set that came off a 2012 535i. My original wheels were 17" and the new ones I put on are 18". The computer say tire pressure malfunction.

Question: Are my old sensors programmed to my car? Do I need to have these new sensors reprogrammed to my car. Air pressures are correct. Light came on right away after the swop.

Please help...

Thank you
I think you have to set your tire pressure correctly and then re initialize the system through iDrive. Have you looked at your owners manual?
__________________
2013 535 XDrive Arctic White/Black Dakota/Anthracite Trim/M Sport/Executive Package/BMW Apps
Reply With Quote
  #3  
Old 11-04-2013, 10:05 AM
Stu3 Stu3 is offline
Registered User
Location: Stuttgart
 
Join Date: Mar 2012
Posts: 49
Mein Auto: 2012 530d XDrive Touring
Pretty sure the answer is yes. "TPMS" or "Tires" in the manual will answer the exact steps you have to do to get the car to recognize the new sensors.
Reply With Quote
  #4  
Old 11-04-2013, 10:53 AM
Dave Smith Dave Smith is offline
Registered User
Location: Los Angeles
 
Join Date: Nov 2013
Posts: 2
Mein Auto: 528i
I have gone through the iDrive reset and got the following message after reset was complete:

Tire Pressure Monitor malfunction:
Drive moderately. System unable to detect tire pressure loss. Consult service center.
Reply With Quote
  #5  
Old 11-04-2013, 05:52 PM
romeofrosty romeofrosty is offline
Officially Welcomed to the 'Fest
Location: Cape May, NJ
 
Join Date: Apr 2011
Posts: 132
Mein Auto: 2011 BMW 528i
TPM Light on after swopping wheels

You need to swap the tpms sensors from you old wheel to the new. BMW changed the frequency of the sensors in late 2011 models. If your build date was before sept. 2010, you have the old sensor set up and your car will not recognize the sensors off the 2012 wheels.


Sent from BimmerApp mobile app
__________________
2011 BMW 528i- Black Saphire Metallic, Black Leather, Prem. Package, Prem. Package 2, Convenience Package, Cold Weather Package, Sport Package,Sport Auto Trans, Anthracite Wood & Headliner, Xenon Lights, Split Fold-down Seats.
Reply With Quote
  #6  
Old 09-01-2014, 02:12 PM
ausdude's Avatar
ausdude ausdude is offline
Officially Welcomed to the 'Fest
Location: Austin
 
Join Date: Dec 2012
Posts: 1,117
Mein Auto: 2013 BMW 550i M-Sport
I just got new wheels. I left my old ones intact for storage. My new wheels have all new TPMs. Everything was great the first week. I took my car on a 300 mike road trip and 20 or so minutes into the trip I got a TPM malfunction error. I stopped at a station and recalibrated through the I drive and when on. Everything was fine for a hour or so then it happened again. I just ignored it and a while later I hard braked around a corner and it reset itself. I get the malfunction several times per day. Any ideas?
__________________
Untitled[/url] 550i M Sport|300|LCSW|4MR|2TB|704|760|PDC|ZEC|6F2|ZDA|5AD |416|494|Dinan Stage 2|CF Spoiler,MirrorCaps&Splitter|M Performance Diffuser|Front Reflector Delete|Black Grilles|Rear Fog Lights|Euro Side Mirrors&Tail Lights|M5 Front & M550D Rear Sway Bars|20" HB04|Roof Wrapped|Coded|CCA member
Reply With Quote
  #7  
Old 09-01-2014, 03:48 PM
markl53's Avatar
markl53 markl53 is online now
bimmerfest Supporting Member
Location: Gaithersburg, MD
 
Join Date: Nov 2004
Posts: 5,431
Mein Auto: 2011 535i
"Swap" = To trade one thing for another .
__________________
BMW-CCA
Bimmerfest Supporting Member



2014 535i Individual | Azurite Black/Amaro Brown Merino | Premium | Cold | PDC | Rear Camera | Anthracite Hdr
Prior: 2011 535i AT | Black Sapphire/Cinnamon | Premium | Heated Sts | Nav | Sirius | Anthracite Hdr & Trim
Prior: 2008 335i 6MT Sedan | Black Sapphire/Terra Leather | Premium | Cold | CA | OEM Alarm
Prior: 2005 330i 6MT | Black Sapphire/Sand Leather | Premium | Cold | UGO | OEM Alarm
Reply With Quote
  #8  
Old 09-01-2014, 04:02 PM
wrickem wrickem is offline
Officially Welcomed to the 'Fest
Location: lambertville nj
 
Join Date: Nov 2005
Posts: 440
Mein Auto: '14 528xi, 07 M6
Quote:
Originally Posted by romeofrosty View Post
You need to swap the tpms sensors from you old wheel to the new. BMW changed the frequency of the sensors in late 2011 models. If your build date was before sept. 2010, you have the old sensor set up and your car will not recognize the sensors off the 2012 wheels.


Sent from BimmerApp mobile app

+1. I had this exact same problem with my Sept '10 build '11 MY 335
and that was the reason.


Sent from BimmerApp mobile app
__________________
'14 528xi Alpine White/Mocha - oddly optioned exactly the way I wanted it.
Reply With Quote
  #9  
Old 09-01-2014, 04:33 PM
jefff5 jefff5 is offline
Registered User
Location: los angeles
 
Join Date: Aug 2014
Posts: 10
Mein Auto: 2014 328d
Im getting the same problem right now, have an appointment tomorrow to swap the TPMs from the ones i just took off its what the service advisor said was the cheapest way too go.
Reply With Quote
  #10  
Old 09-01-2014, 04:44 PM
ausdude's Avatar
ausdude ausdude is offline
Officially Welcomed to the 'Fest
Location: Austin
 
Join Date: Dec 2012
Posts: 1,117
Mein Auto: 2013 BMW 550i M-Sport
I can swap them but my car is a 2013 not 2011. Is the swap necessary or just the cheapest fix?
__________________
Untitled[/url] 550i M Sport|300|LCSW|4MR|2TB|704|760|PDC|ZEC|6F2|ZDA|5AD |416|494|Dinan Stage 2|CF Spoiler,MirrorCaps&Splitter|M Performance Diffuser|Front Reflector Delete|Black Grilles|Rear Fog Lights|Euro Side Mirrors&Tail Lights|M5 Front & M550D Rear Sway Bars|20" HB04|Roof Wrapped|Coded|CCA member
Reply With Quote
  #11  
Old 09-01-2014, 08:19 PM
boston535 boston535 is offline
BMW loyalist
Location: Massachusetts
 
Join Date: Jun 2014
Posts: 201
Mein Auto: 2014 F10 535 xdrive
Sorry to derail this, but I thought the tpms system worked off the abs system in these cars, not on actual sensors on the wheels. That was how it was in my 2006 330i. If they did change back to sensors on the wheels, are there any particular reasons why?
__________________
Current Ride: 2014 535 drive Modern Line, black sapphire, dakota black, cold weather driver assistance, driver assistance plus, Sport Automatic transmission, Harmon Kardon.

Former rides:
2000 Audi A4 QMT,
2006 BMW 330i titanium silver, black, sport package, 6MT
Reply With Quote
  #12  
Old 09-02-2014, 03:16 PM
Gilgorm Gilgorm is offline
Officially Welcomed to the 'Fest
Location: Toronto, Canada
 
Join Date: Jul 2012
Posts: 380
Mein Auto: 2012 535i X-drive
Quote:
Originally Posted by boston535 View Post
I thought the tpms system worked off the abs system in these cars, not on actual sensors on the wheels. That was how it was in my 2006 330i. If they did change back to sensors on the wheels, are there any particular reasons why?
Accuracy. And, I believe, US law now for all cars.

TPMS doesn't work off ABS since the sensors do a more accurate job, especially with run-flats. In older systems that used ABS, the circumference of the tire was measured against each tire. A low pressure tire rolls differently and isn't as large as the pressure goes down. Run-flats don't distort as much as regular tires when they leak so the ABS system isn't as effective.

Here in Canada, we don't get TPMS and the tires don't have sensors. We get the cheapo version called FTM (Flat Tire Monitor) which doesn't show individual pressures and only works when the tire is extremely low or in my personal case, completely empty. To my knowledge, FTM does use the ABS system but is almost useless.
Its too bad since my retired 08 535i had TPMS so BMW is going backwards to save a few sensor bucks.
__________________
2012 BMW 535i X-drive; Space Grey/Black Dakota, Fineline; Executive (Auto trunk, NAV, HiFi Prof, Lumbar, Rear Cam, SIRIUS, Voice), Technology (Blind Spot, Hi-Beam Assist, Lane Departure, Surround View), APPS, Rear heated seats, Tint.
Retired: 78 300D, 81 300SD, 87 190E, 88 Porsche 924, 89 260E, 93 300E, 97 Volvo 850, 98 E320, 03 BMW 325iT, 02 C230 Sport Coupe, 08 BMW 535i
Reply With Quote
  #13  
Old 09-02-2014, 03:25 PM
clutchlee clutchlee is offline
Officially Welcomed to the 'Fest
Location: New York
 
Join Date: Mar 2011
Posts: 238
Mein Auto: BMW 2011 535xi
Since your car is 2011, you will need the correct TPMS for it. I believe that they built new TPMS for 2012+ models and 2011 models are not compatible with it. You can find it on ebay for around $180ish. I bought a set off a member here for $150 shipped.
__________________
_____________2011 BMW 535i xDrive_____________
Reply With Quote
  #14  
Old 09-02-2014, 04:09 PM
ausdude's Avatar
ausdude ausdude is offline
Officially Welcomed to the 'Fest
Location: Austin
 
Join Date: Dec 2012
Posts: 1,117
Mein Auto: 2013 BMW 550i M-Sport
Ok guys I found this out. I apparently have a faulty TPM in one of my tires. It takes 20 minutes of driving before the error will happen. BMW stated they have seen this before and agree the 1 of the tires has a malfunctioning monitor. Instead of trying to guess which one us faulty their solution is to change them all. They will do this at no charge since they just installed mine last week and one is obviously faulty.
__________________
Untitled[/url] 550i M Sport|300|LCSW|4MR|2TB|704|760|PDC|ZEC|6F2|ZDA|5AD |416|494|Dinan Stage 2|CF Spoiler,MirrorCaps&Splitter|M Performance Diffuser|Front Reflector Delete|Black Grilles|Rear Fog Lights|Euro Side Mirrors&Tail Lights|M5 Front & M550D Rear Sway Bars|20" HB04|Roof Wrapped|Coded|CCA member
Reply With Quote
  #15  
Old 09-03-2014, 08:06 AM
jefff5 jefff5 is offline
Registered User
Location: los angeles
 
Join Date: Aug 2014
Posts: 10
Mein Auto: 2014 328d
Quote:
Originally Posted by ausdude View Post
Ok guys I found this out. I apparently have a faulty TPM in one of my tires. It takes 20 minutes of driving before the error will happen. BMW stated they have seen this before and agree the 1 of the tires has a malfunctioning monitor. Instead of trying to guess which one us faulty their solution is to change them all. They will do this at no charge since they just installed mine last week and one is obviously faulty.
That's great that they figured that out, my swap is taking 2 days at the dealer and $160 in the end the stock wheels I took off wont have tpms on them they will be on the new ones and I will have a useless set of 4tpms from those wheels.
Reply With Quote
  #16  
Old 10-25-2014, 11:19 AM
ausdude's Avatar
ausdude ausdude is offline
Officially Welcomed to the 'Fest
Location: Austin
 
Join Date: Dec 2012
Posts: 1,117
Mein Auto: 2013 BMW 550i M-Sport
[QUOTE=jefff5;8567042]That's great that they figured that out, my swap is taking 2 days at the dealer and $160 in the end the stock wheels I took off wont have tpms on them they will be on the new ones and I will have a useless set of 4tpms from those wheels.[/QUOTE

Im still having major TPMS malfunction issues. After driving 30 - 40 miles the TPMS Malfunction would come on. I took the car in to the dealership and they said that the main board in the car needed replacing. They did this and put the OLD wheels back on the car and asked me to drive it for the weekend. I did with no issues. They then said that they took the old senors out of the tires and swapped them with the new sensors. Mounted the new wheels with the old sensors and the malfunction occurred immediately. They said that the new wheels have metal valve stems and caps and that the caps were magnetic causeing interference with the senor's radio waves. They placed plastic caps on the valve stems and drove it a few times without a malfunction. I took the car for the weekend and drove it a lot and the malfunction returned. They then said that the metal valve stems were causing the interference so they tried attaching the TPMS, with adhesive, to the opposite side of the wheels from the valve stems. This did not hold up and fell apart.... I wondering if they ever even swapped the sensors.... they swear they did

Can some one help me so that I do not have to turn the entire monitoring system off? Had anyone ever heard of this? I called Discount Tire and they said that they will need special management approval to mess with $1000 wheels because they cannot guarantee they would not damage them. I called Tire Rack and they were of no assistance either.
__________________
Untitled[/url] 550i M Sport|300|LCSW|4MR|2TB|704|760|PDC|ZEC|6F2|ZDA|5AD |416|494|Dinan Stage 2|CF Spoiler,MirrorCaps&Splitter|M Performance Diffuser|Front Reflector Delete|Black Grilles|Rear Fog Lights|Euro Side Mirrors&Tail Lights|M5 Front & M550D Rear Sway Bars|20" HB04|Roof Wrapped|Coded|CCA member
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > F10 / F11 (2011 - Current)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 07:48 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms