Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 10-07-2004, 02:30 PM
King's Avatar
King King is offline
Officially Welcomed to the 'Fest
Location: Canada
 
Join Date: Sep 2004
Posts: 596
Mein Auto: X5 4.4i
Navigation retrofit 95% complete...

Everything is working as far as the onboard computer functions, radio reception, DSP sound settings etc. All I need is a cable for the CD changer. However I notice that the computer is not giving me accurate directions when inputting an address. Not sure if it's the GPS antenna or an issue with the MKIV NAV computer?? Every so often it tells me to take a wrong turn or make a legal U turn! I had to get it coded today, and my DSP settings didn't work until it was coded. I will have to try another NAV computer and see if it makes a difference!
Reply With Quote
Advertisement
  #2  
Old 10-07-2004, 02:41 PM
TripleX5 TripleX5  is offline
Member of the club
Location: NYC
 
Join Date: Sep 2003
Posts: 273
Mein Auto: Imola RedII 4.8iS - 733i
Heeeeeeeeeeeeeey....

Where das pictures?

btw. Did the mount the nav antenna in the factory location, under the plastic molding thats under the reap spoiler? Jus a thought. Lets us know how things work out.
__________________

Ed (TripleX5)
02 4.4 retired
Reply With Quote
  #3  
Old 10-07-2004, 02:48 PM
X5M5 X5M5 is offline
Official Bangle Hater
Location: Massachusetts
 
Join Date: Nov 2002
Posts: 396
Mein Auto: '01 X5 4.4i, '00 M5
Congrats! WHAT FIXED THE PROBLEM??? Did coding solve all the issues that you were having?
__________________
'01 X5 4.4i Topaz Blue/Black, '00 M5 Anthracite/Red, '06 Z4M Red/Black, '05 Acura RL White/Tan.
Reply With Quote
  #4  
Old 10-07-2004, 04:36 PM
King's Avatar
King King is offline
Officially Welcomed to the 'Fest
Location: Canada
 
Join Date: Sep 2004
Posts: 596
Mein Auto: X5 4.4i
Quote:
Originally Posted by X5M5
Congrats! WHAT FIXED THE PROBLEM??? Did coding solve all the issues that you were having?
Turns out that I had a totally unrelated problem at the same time as my retrofit. The ECM (Error control module) thinks the key is in the ignition even when it's not. Therefore it won't let you lock/unlock the vehicle via remote and continiously drains the battery. All along I thought I messed up the retrofit wiring somewhere! A new module is on order for me. Hopefully that will fix the problem.

As for the CD changer not working, I looked at another X5 with NAV to see how it was wired. It has the 6 pin cable (which my vehicle does not have.) So I will have to install this cable from the changer to the radio module.
Reply With Quote
  #5  
Old 10-07-2004, 04:38 PM
King's Avatar
King King is offline
Officially Welcomed to the 'Fest
Location: Canada
 
Join Date: Sep 2004
Posts: 596
Mein Auto: X5 4.4i
Cool

Quote:
Originally Posted by X5M5
Congrats! WHAT FIXED THE PROBLEM??? Did coding solve all the issues that you were having?
Oh and coding certainly helped. My DSP was not working until it was coded and I now have the BMW logo when opening the door...as well as the accept screen, but what the heck!
Reply With Quote
  #6  
Old 10-07-2004, 04:43 PM
UCrewX5's Avatar
UCrewX5 UCrewX5 is offline
Member of the club
Location: Grosse Ile, MI
 
Join Date: Sep 2004
Posts: 1,280
Mein Auto: BMW X5
Arvi, thanks for the update. Glad to hear that things are progressing
__________________
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Nav Software Update (3-1/60) Particulars SONET General BMW 1 02-17-2006 11:34 AM
Can anyone verify if these Bluetooth Retrofit Kit Part numbers are available? m3evolution General BMW 25 06-22-2005 08:21 PM
Wanted - Complete Navigation System for E39 tyler-lowe Classifieds 0 08-20-2004 02:42 PM
Mk4 navigation computer retrofit alee Do-It-Yourself H.Q. 4 07-01-2004 10:20 PM
FS: BMW MK III Navigation Computer in perfect condition DZeckhausen Classifieds 1 04-02-2004 10:02 PM


All times are GMT -7. The time now is 03:46 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms