Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > BMW Coding and Programming

BMW Coding and Programming
Discuss coding options and features on your BMW here.

Reply
 
Thread Tools
  #1701  
Old 07-23-2015, 06:53 AM
The.King The.King is offline
Registered User
Location: Dark side of the moon
 
Join Date: Jul 2015
Posts: 15
Mein Auto: Bmw F10
Quote:
Originally Posted by shawnsheridan View Post
Set it to DRL_S_ohne_SL.
Ok, really need help now. Just followed all instructions and tried to input the above. Get to 'step 19', but FA will not activate or go green?

Please help...
Reply With Quote
  #1702  
Old 07-23-2015, 06:59 AM
The.King The.King is offline
Registered User
Location: Dark side of the moon
 
Join Date: Jul 2015
Posts: 15
Mein Auto: Bmw F10
Quote:
Originally Posted by shawnsheridan View Post
Set it to DRL_S_ohne_SL.
Ok, really need help now. Just followed all instructions and tried to input the above. Get to 'step 19', but FA will not activate or go green?

Please help...
Reply With Quote
  #1703  
Old 07-23-2015, 07:13 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 17,621
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by neodergrosse View Post
Hi Shawn.

Can you please PM me the download link for the latest PSdZData? Thank You
PM sent.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Reply With Quote
  #1704  
Old 07-23-2015, 07:14 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 17,621
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by The.King View Post
Ok, really need help now. Just followed all instructions and tried to input the above. Get to 'step 19', but FA will not activate or go green?

Please help...
Did you Save your FA first, then try to Activate it?
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Reply With Quote
  #1705  
Old 07-23-2015, 07:35 AM
The.King The.King is offline
Registered User
Location: Dark side of the moon
 
Join Date: Jul 2015
Posts: 15
Mein Auto: Bmw F10
Yeah, I saved everything first as per the token ring youtube video - FA, SVT and I backed them up to a new location too - just to have an original copy in case I screwed anything up.

Anyway, I don't know what happened? I just killed the connection and then reconnected, tried again and it became "active"? All is good.

Final Q for now as I start to code a few things, the token master video said never to change the werte values. Yet for the likes of enabling DVD in motion, it says to change value of SPEEDLOCK_X_KMH_MIN/MAX to FF??

Same for increasing the brightness of the halo's >>change 'wert_01_100% / Werte=64', to just 'wert_0_100% /'

Is it safe to change Werte to either FF or to delete the value completely?

Thanks for quick reply - sweating bullets was an understatement
Reply With Quote
  #1706  
Old 07-23-2015, 08:57 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 17,621
Mein Auto: 2011 535i M-Sport
Yes, if you save FA, you must then hit the Edit button to bring FA into FA Editor, then go back to the Coding Module before FA can be Activated. It is a quirk in E-Sys.

You can change Werte Values. You must in many cases. But for any FDL, you only change either the predefined drop-down box value, or the Werte value, but never both.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Reply With Quote
  #1707  
Old 07-23-2015, 09:28 AM
The.King The.King is offline
Registered User
Location: Dark side of the moon
 
Join Date: Jul 2015
Posts: 15
Mein Auto: Bmw F10
Quote:
Originally Posted by shawnsheridan View Post
Yes, if you save FA, you must then hit the Edit button to bring FA into FA Editor, then go back to the Coding Module before FA can be Activated. It is a quirk in E-Sys.
Good to know now. Pity I didn't know that before I sweated a few hundred bullets.

Quote:
You can change Werte Values. You must in many cases. But for any FDL, you only change either the predefined drop-down box value, or the Werte value, but never both.
Hmmmm, I found this out by trying it for myself for the Halo's, then had nothing working. Still don't know about this. i.e. The original settings for Halo brightness was '1 (100%) Werte = 64'. When I just tried to change the Werte value to FF/zero (as per the cheat sheet said) and applied the code, my Halo's died completely. Went back into 'edit fdl', checked the predefind value (which I never touched) and it was "unknown"??? Changed it back to the default 1 (100%) and the Werte value automatically changed to = 64 with it, and my halo's came back again, but they're still really, really dull?

If it's already at the predefind 1 (100%) setting, how do I get the halo's brighter like other people say is possible? Is there another module to edit somewhere? (I did see lots of options for DRL's as I went through different modules.) I assume there has to be a way, as the halo's at the moment (on 100%) resemble two 1700's lanterns about a mile away. Any ideas?

Thanks BTW for your help, now just my halo's run as DRL's (even though very dull) & I've cleared the passenger restraint fault thanks to your tip about 'external applications'. Much appreciated.
Reply With Quote
  #1708  
Old 07-23-2015, 02:04 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 17,621
Mein Auto: 2011 535i M-Sport
I am not aware of Halo brightness FDL setting that specifies Werte = FF. I only know FRM => HELLIGKEIT_DRL = wert_01__100%, and if that is set, I do not know how to increase brightness anymore.

The predefined Dropdown box settings and the Werte values are a matched set. So when you change the Dropdown box setting, the Werte value automatically changes with it.

So for example, if you change a Dropdown box settings from nicht_aktiv to aktiv, the Werte value automatically changes from Werte=00 to Werte=01.

That said, it's the Werte value only that matters. However, since hexadecimal values are hardly descriptive, the Dropdown box settings serve to provide a more descriptive way of representing what the Werte value's mean, and to ease changing them.

So, when you change a Werte Value directly to a custom value, the predefined Dropdown box setting, which does not have a match for the custom value, displays "Unknown". The custom Werte value though is most certainly active so long as it is a valid value.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Reply With Quote
  #1709  
Old 07-25-2015, 06:39 PM
The.King The.King is offline
Registered User
Location: Dark side of the moon
 
Join Date: Jul 2015
Posts: 15
Mein Auto: Bmw F10
Hmmmm, came across a funny one after coding quite a few things successfully...

I applied this coding to enable the digital speed display in the main instrument cluster
KOMBI => 3000 => BC_DIGITAL_V => aktiv

However - there has been no change & there is no sign of any digital speed info? Is there another part to this coding (another module) that requires a change in order to activate it?

I also applied this coding - Subtle orange lines at the bottom of Extended (6WA) or Multifunction (6WB) display during the day (2013 Default is grey)
KOMBI => 3000 => HINTERGRUND_FARBE_TAG => orange

Again, I see the word used is 'subtle', but i haven't noticed any changes???

All other codings applied have worked a treat (except for needing to upgrade the physical halo ring LEDs to 2014+ in order to achieve the brightness I want. The 2013 halo's suck. They're not even 1/4 as bright, even at 100%.
Reply With Quote
  #1710  
Old 07-25-2015, 06:39 PM
The.King The.King is offline
Registered User
Location: Dark side of the moon
 
Join Date: Jul 2015
Posts: 15
Mein Auto: Bmw F10
Hmmmm, came across a funny one after coding quite a few things successfully...

I applied this coding to enable the digital speed display in the main instrument cluster
KOMBI => 3000 => BC_DIGITAL_V => aktiv

However - there has been no change & there is no sign of any digital speed info? Is there another part to this coding (another module) that requires a change in order to activate it?

I also applied this coding - Subtle orange lines at the bottom of Extended (6WA) or Multifunction (6WB) display during the day (2013 Default is grey)
KOMBI => 3000 => HINTERGRUND_FARBE_TAG => orange

Again, I see the word used is 'subtle', but i haven't noticed any changes???

All other codings applied have worked a treat (except for needing to upgrade the physical halo ring LEDs to 2014+ in order to achieve the brightness I want. The 2013 halo's suck. They're not even 1/4 as bright, even at 100%.
Reply With Quote
  #1711  
Old 07-25-2015, 06:42 PM
The.King The.King is offline
Registered User
Location: Dark side of the moon
 
Join Date: Jul 2015
Posts: 15
Mein Auto: Bmw F10
Sorry, don't know how last entry posted twice - I only posted 'quick reply' once ??
Reply With Quote
  #1712  
Old 07-25-2015, 06:47 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 17,621
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by The.King View Post
Hmmmm, came across a funny one after coding quite a few things successfully...

I applied this coding to enable the digital speed display in the main instrument cluster
KOMBI => 3000 => BC_DIGITAL_V => aktiv

However - there has been no change & there is no sign of any digital speed info? Is there another part to this coding (another module) that requires a change in order to activate it?
...
Digital Speed is added to the last Setting inside the BC Cluster (the display inside MPH Gauge). You have the press the button at end of BC Stalk to cycle though to the Digital Speed Setting.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Reply With Quote
  #1713  
Old 07-26-2015, 05:58 PM
The.King The.King is offline
Registered User
Location: Dark side of the moon
 
Join Date: Jul 2015
Posts: 15
Mein Auto: Bmw F10
Quote:
Originally Posted by shawnsheridan View Post
Stalk to cycle though to the Digital Speed Setting.
Of course - thanks. Clearly had a 'senior moment' & couldn't figure that out. Next I'll be asking where the steering wheel is
Reply With Quote
  #1714  
Old Yesterday, 12:14 AM
11AW535i 11AW535i is offline
Registered User
Location: California
 
Join Date: Jul 2015
Posts: 1
Mein Auto: 535I f10
I've read through all posts about coding my f10. Now I'm ready and Im going for it. Please Shawn, help me with lasteat link to the e-sys and any other files needed for coding. Thanks!
Reply With Quote
  #1715  
Old Yesterday, 04:02 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 17,621
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by 11AW535i View Post
I've read through all posts about coding my f10. Now I'm ready and Im going for it. Please Shawn, help me with lasteat link to the e-sys and any other files needed for coding. Thanks!
PM sent.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Reply With Quote
  #1716  
Old Today, 02:40 AM
alsayyad alsayyad is offline
Registered User
Location: Irvine, CA
 
Join Date: Feb 2015
Posts: 3
Mein Auto: BMW i3
Hello,

Kindly requesting links for softwares. Thank you. Shawn, you are the master.
Reply With Quote
  #1717  
Old Today, 02:59 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 17,621
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by alsayyad View Post
Hello,

Kindly requesting links for softwares. Thank you. Shawn, you are the master.
PM sent.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > BMW Coding and Programming
Today's Posts Search
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 04:29 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
© 2001-2015 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms