Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)

7 Series - E65 / E66 (2002 - 2008)
Discussion pertaining to the flagship BMW here.

Reply
 
Thread Tools Display Modes
  #151  
Old 08-30-2014, 06:34 PM
fratan fratan is offline
Officially Welcomed to the 'Fest
Location: MA
 
Join Date: Jan 2012
Posts: 256
Mein Auto: 2006 750i
If you are trying to get the car inspected because of the p04910492 code SAS low air then you need to do the sea foam in the SAS ports fix. Changing the gl63 to gl 61 doesn't fix this issue. You would have to flash the dme which is for experts only. I wouldn't try it and I'm experieced


Sent from BimmerApp mobile app
__________________

2006 750 I
Reply With Quote
  #152  
Old 08-30-2014, 08:23 PM
mlmotorsport mlmotorsport is offline
Registered User
Location: Midwest
 
Join Date: Apr 2014
Posts: 15
Mein Auto: 2006 750Li 2005 645Ci
After doing some gaskets and seals I got a secondary air code. The car was fine up to that point so I'm assuming I either just missed or split an associated hose and don't really want to go back through to find it. We don't have inspections here so I'm not worried about passing but I would like to eliminate the cel. Also it's been 5 years since this car has had any updates and I think it could benefit from one in a couple areas.
Reply With Quote
  #153  
Old 08-31-2014, 05:23 AM
fratan fratan is offline
Officially Welcomed to the 'Fest
Location: MA
 
Join Date: Jan 2012
Posts: 256
Mein Auto: 2006 750i
If it was me I would try and find the leak. I wouldn't update if the car is running smooth. I would change the tranny fluid and reset the adaptations in inpa though. The SAS doesn't effect the performance so why update?


Sent from BimmerApp mobile app
__________________

2006 750 I
Reply With Quote
  #154  
Old 09-07-2014, 11:36 AM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,313
Mein Auto: 2004 545i
Quote:
Originally Posted by mlmotorsport View Post
Sorry to drag back an old thread but I am looking for somebody who can hook up remotely to do some updates on the 645. I have the DIS software and the cable so I'm able to diagnose and erase codes etc but don't have the know-how to go much further. I know this type of thing can be done, I'm just looking for someone who can do it. If you know of anyone let me know. Much appreciate any help!
DIS isn't going to let you change something like that. Need to use NCS Expert/INPA

Quote:
Originally Posted by mlmotorsport View Post
After doing some gaskets and seals I got a secondary air code. The car was fine up to that point so I'm assuming I either just missed or split an associated hose and don't really want to go back through to find it. We don't have inspections here so I'm not worried about passing but I would like to eliminate the cel. Also it's been 5 years since this car has had any updates and I think it could benefit from one in a couple areas.
Which gaskets/seals did you change? There is a hose that runs from the air pump that splits into two parts and runs under the intake, back to the valves at the back of the engine. That is the most likely thing to crack in my opinion. If you have INPA you can force the air pump to come on while the engine is off. That should make it easier to find the leak.. but that hose would be my guess

Intake has to come off to replace it
Reply With Quote
  #155  
Old 09-07-2014, 12:01 PM
fratan fratan is offline
Officially Welcomed to the 'Fest
Location: MA
 
Join Date: Jan 2012
Posts: 256
Mein Auto: 2006 750i
Are you referring to the p0491 0492 code? I use inpa to clear my codes or you can get a cheap code reader for 20 bucks on amazon.


Sent from BimmerApp mobile app
__________________

2006 750 I
Reply With Quote
  #156  
Old 09-07-2014, 02:01 PM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,313
Mein Auto: 2004 545i
Quote:
Originally Posted by fratan View Post
Are you referring to the p0491 0492 code? I use inpa to clear my codes or you can get a cheap code reader for 20 bucks on amazon.


Sent from BimmerApp mobile app
Resetting the code isn't going to fix the problem
Reply With Quote
  #157  
Old 09-07-2014, 03:42 PM
flash_n flash_n is online now
Registered User
Location: Connecticut
 
Join Date: May 2012
Posts: 91
Mein Auto: 745Li
Quote:
Originally Posted by schpenxel View Post
Resetting the code isn't going to fix the problem
I'm guessing the question was if you could set the DME such that it does not show the error, although it remains. Essentially the P0491 is not that bad, if you don't have to pass an OBD test.

On my car the emissions are tested via a probe (Germany) - I just have to make sure the MIL is not on.
So getting the engine hot and resetting the code should do - or changing the DME, so it does not react to P0491.

On what I gather for the ME 9.2 DME, there is a firmware that allows you to code the MIL to off. It is not possible to mask single errors as with firmware changes on previous DMEs (e.g. E39).

My thought was to push out an engine pull as far as possible. One of these days the stem seals, rod bearings, etc will drive me there and then I can also drill out the SAS ports through the valve opening.
__________________
Silver 2004 BMW E66 / 745Li (DIYs):
ASK, Logic 7, blower, battery, guibo joint, active stabilizer bar bushings, diff oil, tranny sw update, vacuum pump gasket, window lift, a/c compressor, washer fluid reservoir, belt tensioner and deflector, crankcase vacuum hoses, crankcase vents, solenoid gaskets, headlight overhaul, ISM, hood lifts, driver mirror, sway bar end links, rear fog lamps, headlight washer, headlight vertical aim, VCGs
next up: P0492
Reply With Quote
  #158  
Old 09-07-2014, 05:59 PM
fratan fratan is offline
Officially Welcomed to the 'Fest
Location: MA
 
Join Date: Jan 2012
Posts: 256
Mein Auto: 2006 750i
Has the code posed a problem yet like getting an inspection sticker? If not, I would just clear it and monitor it. It sounds like carbon build up on bank 2 drivers side. You can soak the Tube going into the head for a few days and them use a wire brush to clean the heads and then blow air down there. It may take a few attempts.


Sent from BimmerApp mobile app
__________________

2006 750 I
Reply With Quote
  #159  
Old 09-08-2014, 05:37 AM
fratan fratan is offline
Officially Welcomed to the 'Fest
Location: MA
 
Join Date: Jan 2012
Posts: 256
Mein Auto: 2006 750i
The fuel injection cleaner will not get rid of the p0491 code because the cleaner doesn't touch the heads. If the code is caused by carbon build up on the heads then you'll have to soak the drivers side SAS port for a few days to a week with Seafoam and then use a wire brush to get down to the heads and then use a compressor to blow the cleaner down to the exhaust manifold as specified in this thread.


Sent from BimmerApp mobile app
__________________

2006 750 I
Reply With Quote
  #160  
Old 09-11-2014, 03:38 PM
fratan fratan is offline
Officially Welcomed to the 'Fest
Location: MA
 
Join Date: Jan 2012
Posts: 256
Mein Auto: 2006 750i
Hey, that is a fluke because I changed the string from gl63 to gl 61 on my wife's 745i. I ended up losing the weather channel but it didn't fix the p0491 or p0492. I went to another forum and they told me you would have to flash the dme with winkfp. I decided to do the seaport soak and clean instead.


Sent from BimmerApp mobile app
__________________

2006 750 I
Reply With Quote
  #161  
Old 09-11-2014, 03:48 PM
fratan fratan is offline
Officially Welcomed to the 'Fest
Location: MA
 
Join Date: Jan 2012
Posts: 256
Mein Auto: 2006 750i
Just so everybody knows the p0491 and p0492 is usually a broken hose,a broken SAS pump or carbon build up on the heads caused by bad valve stem seals. You should use a fuel injection cleaner like Techton 2 times a year right before an oil change 300 miles before but this has nothing to do with carbon build up on the heads. In order to fix this go to you tube and watch the video by German enginering or something like that.


Sent from BimmerApp mobile app
__________________

2006 750 I
Reply With Quote
  #162  
Old 10-12-2014, 06:19 PM
tony745li tony745li is offline
Registered User
Location: Wisconsin
 
Join Date: Oct 2014
Posts: 43
Mein Auto: 2003 bmw 745li
I just finished my air ports for the secendary air low flow and it took me 4 days to clean the had the sit for 3 days in B12 hand used the AGA tool to clean them free . Sea fome didn't do nothing in my case.

IF YOU ARE LOOKING FOR THE AGA TOOL AND WOULD LIKE TO RENT IT PM ME . AGA AIR TOOL FOR REANT
Reply With Quote
  #163  
Old 12-03-2014, 07:15 PM
fratan fratan is offline
Officially Welcomed to the 'Fest
Location: MA
 
Join Date: Jan 2012
Posts: 256
Mein Auto: 2006 750i
Just an update on the SAS fix. It has been over 2 1/2 years and the SAS fix is still working.
Got an inspection sticker today. The key is to have a cheap obd reader that tells the status of each readiness monitor. In the 2004 745i, the last monitor not to be ready is the SAS. I'm allowed 1 monitor not to be ready to pass inspection. Before the fix, the SAS light would come back on right away but now it takes a while. Robz how is your fix holding up?
__________________

2006 750 I
Reply With Quote
  #164  
Old 12-03-2014, 08:37 PM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,313
Mein Auto: 2004 545i
Quote:
Originally Posted by fratan View Post
Just an update on the SAS fix. It has been over 2 1/2 years and the SAS fix is still working.
Got an inspection sticker today. The key is to have a cheap obd reader that tells the status of each readiness monitor. In the 2004 745i, the last monitor not to be ready is the SAS. I'm allowed 1 monitor not to be ready to pass inspection. Before the fix, the SAS light would come back on right away but now it takes a while. Robz how is your fix holding up?
My understanding is some states do NOT allow you to have 1 system not ready.. meaning you'd fail regardless of how you timed it

I did the same thing though the last time I got mine inspected. Light came back on before I even got home after getting it inspected
Reply With Quote
  #165  
Old 12-13-2014, 05:35 PM
ogreman ogreman is offline
Registered User
Location: Seattle
 
Join Date: Dec 2014
Posts: 1
Mein Auto: BMW 745Li 2004
US to Euro reset

Quote:
Originally Posted by adboles View Post
makavelifaison, please reply with a link to the DIY you mentioned, I can't seem to find it!
Adboles, did you end up finding DIY for the reset? I also have p0491 code.
Reply With Quote
  #166  
Old 12-13-2014, 06:03 PM
fratan fratan is offline
Officially Welcomed to the 'Fest
Location: MA
 
Join Date: Jan 2012
Posts: 256
Mein Auto: 2006 750i
Her you go http://www.bimmerfest.com/forums/sho...=543798&page=3
__________________

2006 750 I
Reply With Quote
  #167  
Old 12-14-2014, 04:55 PM
srm51475 srm51475 is offline
Registered User
Location: Michigan
 
Join Date: Feb 2014
Posts: 35
Mein Auto: 745i
Quote:
Originally Posted by fratan View Post
This link is not working.
Reply With Quote
  #168  
Old 12-14-2014, 05:21 PM
Rick in Yuma's Avatar
Rick in Yuma Rick in Yuma is offline
bimmerfest Supporting Member
Location: Arizona
 
Join Date: Dec 2006
Posts: 212
Mein Auto: 05' 760li,94' H1,08'Smart
Quote:
Originally Posted by srm51475 View Post
This link is not working.
Try this..

http://www.bimmerfest.com/forums/sho...=543798&page=3
Reply With Quote
  #169  
Old 12-14-2014, 07:22 PM
fratan fratan is offline
Officially Welcomed to the 'Fest
Location: MA
 
Join Date: Jan 2012
Posts: 256
Mein Auto: 2006 750i
You have to copy the link in the search bar and it comes up.
__________________

2006 750 I
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 12:32 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms