Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E46 (1999 - 2006)

E46 (1999 - 2006)
The fourth generation 3 Series (E46 chassis) was introduced in 1999 and set the standard for engineering and performance during it's years of production including being named to Car & Driver's 10 best list every one of those years! ! -- View the E46 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 06-10-2005, 02:59 PM
Ace Ace is offline
Officially Welcomed to the 'Fest
Location: Toronto
 
Join Date: Apr 2004
Posts: 341
Mein Auto: '01 325Ci
Funny Door Lock Problem...

so here's the situation...i came home from work today no problems, had to run out for some errands about an hour later...go down to the car, use the key to unlock remotely (like usual), i heard the noise but the button didn't pop up...i pushed the unlock on the key again, passenger side unlocks....use the key to lock both doors again, no problem, both lock...try it remotely one more time, same thing...but using the key to manually unlock the door works...once inside i try the lock button, passenger side locks but driver's doesn't...what gives? any ideas?
Reply With Quote
Ads by Google
  #2  
Old 06-10-2005, 07:00 PM
markl53's Avatar
markl53 markl53 is online now
bimmerfest Supporting Member
Location: Gaithersburg, MD
 
Join Date: Nov 2004
Posts: 4,802
Mein Auto: 2011 535i
Sounds like whatever linkage is setup from the lock actuator to the pin in the door is loose. I haven't seen the parts myself, but I'm assuming there's a device that push/pulls an arm or something which operates the lock pin.
__________________
BMW-CCA
Bimmerfest Supporting Member



2014 535i Individual | Azurite Black/Amaro Brown Merino | Premium | Cold | PDC | Rear Camera | Anthracite Hdr
Prior: 2011 535i AT | Black Sapphire/Cinnamon | Premium | Heated Sts | Nav | Sirius | Anthracite Hdr & Trim
Prior: 2008 335i 6MT Sedan | Black Sapphire/Terra Leather | Premium | Cold | CA | OEM Alarm
Prior: 2005 330i 6MT | Black Sapphire/Sand Leather | Premium | Cold | UGO | OEM Alarm
Reply With Quote
  #3  
Old 06-10-2005, 07:45 PM
Ace Ace is offline
Officially Welcomed to the 'Fest
Location: Toronto
 
Join Date: Apr 2004
Posts: 341
Mein Auto: '01 325Ci
Quote:
Originally Posted by markl53
Sounds like whatever linkage is setup from the lock actuator to the pin in the door is loose. I haven't seen the parts myself, but I'm assuming there's a device that push/pulls an arm or something which operates the lock pin.
that's what i thought, but that doesn't make sense because it unlocks if you use the key manually or if you use the handle from the inside. also it locks itself remotely but not with the button from the inside? so i'm not sure that it's a mechanical linkage...
Reply With Quote
  #4  
Old 06-10-2005, 08:26 PM
markl53's Avatar
markl53 markl53 is online now
bimmerfest Supporting Member
Location: Gaithersburg, MD
 
Join Date: Nov 2004
Posts: 4,802
Mein Auto: 2011 535i
Unlocking with the key probably goes through a different linkage, more direct I would think. About the console lock button vs. the remote though, is that consistent? Does locking with the console button never work or was it random, like the linkage or actuator works some of the time?
__________________
BMW-CCA
Bimmerfest Supporting Member



2014 535i Individual | Azurite Black/Amaro Brown Merino | Premium | Cold | PDC | Rear Camera | Anthracite Hdr
Prior: 2011 535i AT | Black Sapphire/Cinnamon | Premium | Heated Sts | Nav | Sirius | Anthracite Hdr & Trim
Prior: 2008 335i 6MT Sedan | Black Sapphire/Terra Leather | Premium | Cold | CA | OEM Alarm
Prior: 2005 330i 6MT | Black Sapphire/Sand Leather | Premium | Cold | UGO | OEM Alarm
Reply With Quote
  #5  
Old 06-11-2005, 12:31 PM
Ace Ace is offline
Officially Welcomed to the 'Fest
Location: Toronto
 
Join Date: Apr 2004
Posts: 341
Mein Auto: '01 325Ci
Quote:
Originally Posted by markl53
Unlocking with the key probably goes through a different linkage, more direct I would think. About the console lock button vs. the remote though, is that consistent? Does locking with the console button never work or was it random, like the linkage or actuator works some of the time?
yup it's consistent...locking with the console button won't lock the driver's door, but the key will lock both.

i guess i'll have to take it in to the dealer?
Reply With Quote
  #6  
Old 06-16-2005, 01:41 PM
byunts byunts is offline
Registered User
Location: Northbrook, IL
 
Join Date: Jun 2005
Posts: 14
Mein Auto: '01 330Ci
I have the same exact problem, only for the passenger side. Reading up on this in the Bentley manual, it says there's 2 locking methods our cars use. 1. is using the console button (same as if your car is programmed to lock after 5+ mph) 2. is using the remote key and/or manually locking with the key. This explains why locking with the console button doesn't work while your key might.

This still doesn't explain what's wrong. Is it a motor malfunctioning, has it something to do with the programming, etc.

Anyone else have any insight?
Reply With Quote
  #7  
Old 06-16-2005, 02:24 PM
brkf's Avatar
brkf brkf is offline
Not Wearing Pants
Location: Earth
 
Join Date: May 2003
Posts: 13,222
Mein Auto: Moped
My 03 330i does this all the time. I have no desire to have the dealer fiddle with the electronics (don't trust dealers and german cars with electrical problems) on the car and thus just live with it. Sometimes I approach the car, click unlock and maybe the driver's door will unlock. Sometimes no door will unlock. I an still get in with a key. When this happens, even if I press the door lock button on the console, the doors will remain locked.

Life with a German car. It's still a far sight better than my old Jetta which would lock down, shut off and sound the alarm with me in the car.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E46 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ZHP "shudders" - not an idle problem (long) kiteboy 3 Series / 4 Series 27 08-25-2004 02:30 AM
Back from dealer; still have idle problem toddkageals 3 Series / 4 Series 9 05-04-2004 11:00 AM
Idle Problem Update and Some Warranty Issues toddkageals 3 Series / 4 Series 9 12-29-2003 07:45 AM
Tuesday funny ... Sabrina Off-Topic 4 05-13-2003 09:39 AM
interesting ethical problem.. Cliff330i 3 Series / 4 Series 10 03-31-2003 06:33 PM


All times are GMT -7. The time now is 01:37 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms