Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)

E60 (2004 - 2010)
BMW 5-Series (E60 chassis) was first seen in the Unites States in the fall of 2003 with a 2004 Model Year designation. The E60 is now available as a 528i, 528xi, 535i, 535xi, 550i and a 535xi sports wagon! -- View the E60 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 07-11-2005, 10:50 AM
BC530i BC530i is offline
Registered User
Location: Gig Harbor, Washinton
 
Join Date: Jul 2005
Posts: 2
Mein Auto: 2004 530i
Electrical Help!

I am having electrical issues with my 2004 530i that the dealer says they have not encountered before. Out of the blue, the Idrive indicates an electrical issue and to "stop the car immediately"; all four guages (tach, speed, MGP and gas guage) needles start flipping back and forth, wipers come on intermittently on thier own, sun roof is stuck open, many different messages begin flashing on both the dash display and the Idrive including various bells, etc.

The issue happend again at the dealer, and they agree there is an issue! Only thing they have found to date is the battery was putting out low amps, so they replaced it. Did not cure the issue as it has happened again.

Any thoughts, experience, direction I can point the dealer to?! Thanks.
Reply With Quote
Ads by Google
  #2  
Old 07-11-2005, 01:30 PM
Ågent99's Avatar
Ågent99 Ågent99 is offline
Moderator, 5-Series
Location: Bay Area, CA
 
Join Date: Jan 2002
Posts: 5,931
Mein Auto: Trek 6500 MTB
I'd go for a new software upload. Maybe some code got whacked??
__________________
2001 530i/5 (E39), Topaz Blue/Stone Green/Black (118k miles) *very rare interior/exterior color combo*
2005 545i/SMG (E60), ED Order, Titanium Grey/Grey (lease over)
2015 335i, ED Order Summer 2015
Reply With Quote
  #3  
Old 07-11-2005, 06:42 PM
BillP BillP is offline
Officially Welcomed to the 'Fest
Location: Northern California
 
Join Date: Jan 2002
Posts: 1,564
Mein Auto: Cars
Quote:
Originally Posted by BC530i
I am having electrical issues with my 2004 530i that the dealer says they have not encountered before. Out of the blue, the Idrive indicates an electrical issue and to "stop the car immediately"; all four guages (tach, speed, MGP and gas guage) needles start flipping back and forth, wipers come on intermittently on thier own, sun roof is stuck open, many different messages begin flashing on both the dash display and the Idrive including various bells, etc.

The issue happend again at the dealer, and they agree there is an issue! Only thing they have found to date is the battery was putting out low amps, so they replaced it. Did not cure the issue as it has happened again.

Any thoughts, experience, direction I can point the dealer to?! Thanks.
You are quite fortunate in that the dealer saw it. You basically can tell them to just replace everything until the problem goes away.

Perhaps the bad battery caused a problem with some sort of general control module.? There must be a common component somewhere in there causeing the problem. Agent's suggestion of a software update is a good one.


Bill
__________________
'00 540iA/Sport, Anthracite/Black - Euro Delivery in Spring 2000
'06 Honda S2000, Black/Black (my go-kart) - GONE
'03 Z4 3.0 6-speed/Sport, Sterling Gray/Black - GONE
'71 2002 Green/Black - GONE
Reply With Quote
  #4  
Old 07-11-2005, 07:47 PM
crash8168's Avatar
crash8168 crash8168 is offline
Officially Welcomed to the 'Fest
Location: fay.nc
 
Join Date: May 2004
Posts: 400
Mein Auto: e30
So you have an intermittent power supply to the modules, the first place to look would be back at the battery and at the connectors on that large junction block by the battery. Some of the connectors tend to corrode causing strange behavior. Also and intermittent problem with the airbag module will affect the wipers, windows and sunroof. SGM/SIM module.
Reply With Quote
  #5  
Old 07-20-2005, 02:29 PM
BC530i BC530i is offline
Registered User
Location: Gig Harbor, Washinton
 
Join Date: Jul 2005
Posts: 2
Mein Auto: 2004 530i
Thought I would give all an update for future use. The dealer found a spkie in the amps being drawn by the sunroof. They replaced that motor and it seems to have fixed the issue. This is the third sunroof motor I have had in a year.

BillP - you are right, I was lucky that the problems occured at the delaership for them to see, otherwise it could have been difficult to get them to spend as much time as they did. FYI - no complaints about the service group at all - very helpful and attentive.
Reply With Quote
  #6  
Old 07-20-2005, 03:35 PM
Ågent99's Avatar
Ågent99 Ågent99 is offline
Moderator, 5-Series
Location: Bay Area, CA
 
Join Date: Jan 2002
Posts: 5,931
Mein Auto: Trek 6500 MTB
Excellent! You got lucky that the problem happend at the dealer. That is such a rare occurance! Thanks for reporting back...I will mentally file that one away!
__________________
2001 530i/5 (E39), Topaz Blue/Stone Green/Black (118k miles) *very rare interior/exterior color combo*
2005 545i/SMG (E60), ED Order, Titanium Grey/Grey (lease over)
2015 335i, ED Order Summer 2015
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine bay electrical connector clips? avalys E46 (1999 - 2006) 1 07-05-2005 12:12 PM
Electrical Gremlins claine206 E39 (1997 - 2003) 7 06-15-2005 02:56 PM
E39 98 540i sport auto, ELECTRICAL PROBLEMS please "HELP" bk540sport 5 Series 18 02-01-2005 04:56 PM
electrical reliability mwette General BMW 1 04-15-2003 12:28 AM


All times are GMT -7. The time now is 12:14 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms