Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 07-13-2005, 03:16 PM
RJ27Duke RJ27Duke is offline
Registered User
Location: LA
 
Join Date: Jul 2005
Posts: 1
Mein Auto: 540i
Oxygen Sensor

1998 540i
Peake Research R5/FCX-II

I recently brought my car to a BMW dealer to replace the driveshaft. Soon after the check engine light came one. After some back-and-forth with the dealer I bought the Peake code reader tool to find out what the problem is. The code reader reports errors on all 4 oxygen sensors. I looked underneath the car and they seem to be plugs in ok. Could all 4 break at the same time? Any suggestion or insight would be appreciated.
RJ
Reply With Quote
Ads by Google
  #2  
Old 07-13-2005, 05:15 PM
CJsCar CJsCar is offline
Officially Welcomed to the 'Fest
Location: Central Florida
 
Join Date: May 2005
Posts: 191
Mein Auto: 540i, Dakar, 328i
Is it an error code or a replace code? At 100,000 miles they are a scheduled replacement.
Reply With Quote
  #3  
Old 07-18-2005, 02:17 PM
em-dash em-dash is offline
Registered Poseur
Location: Silicon Valley
 
Join Date: Mar 2005
Posts: 34
Mein Auto: 2002 540i6
Maybe the wiring harness was damaged during the driveshaft replacement? I just had a new clutch installed, and the Service Engine light was on when I picked it up from the dealer on Friday. Today the service advisor called to say that the error code indicated a problem with an oxygen sensor.

It seems odd to me that both of us had work done on our drive trains, and we both now have failed oxygen sensors. My dealer is fixing mine, and your dealer should be fixing yours.

Greg
Reply With Quote
  #4  
Old 07-20-2005, 09:17 AM
em-dash em-dash is offline
Registered Poseur
Location: Silicon Valley
 
Join Date: Mar 2005
Posts: 34
Mein Auto: 2002 540i6
Quote:
Originally Posted by em-dash
Maybe the wiring harness was damaged during the driveshaft replacement? I just had a new clutch installed, and the Service Engine light was on when I picked it up from the dealer on Friday. Today the service advisor called to say that the error code indicated a problem with an oxygen sensor.

It seems odd to me that both of us had work done on our drive trains, and we both now have failed oxygen sensors. My dealer is fixing mine, and your dealer should be fixing yours.

Greg
Just to provide an update for posterity, the wiring harness for the O2 sensor was severed when they replaced the clutch. Rather than going over the bell housing, the harness (or what was left of it) ended up inside the bell housing.

Greg
Reply With Quote
  #5  
Old 07-23-2005, 05:08 AM
chgolatin2's Avatar
chgolatin2 chgolatin2 is offline
82nd Airborne!
Location: Chicago, Illinois
 
Join Date: May 2005
Posts: 380
Mein Auto: BMW 540I & Porsche
So, did the repair shop resolve the issue free of charge???
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
The same old code again!!!! kenkorsak E36 (1991 - 1999) 6 01-21-2014 04:58 PM
check engine light on even after replacing oxygen sensor srikspace E36 (1991 - 1999) 23 10-16-2009 01:47 AM
oxygen sensor adaptation limit bbensten E46 (1999 - 2006) 3 02-08-2008 07:02 PM
Oxygen Sensor 1999 E39 Mobado 5 Series DIY 1 01-27-2005 08:32 PM
Oxygen sensor replacement question Mike S E36/7 Z3 (1996-2002) 4 08-02-2003 07:28 AM


All times are GMT -7. The time now is 02:03 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms