Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 10-01-2005, 11:32 AM
johnbb6 johnbb6 is offline
Registered User
Location: in my garage
 
Join Date: Sep 2005
Posts: 2
Mein Auto: none
2004 X5 4.4 won't start

I have a big problem. My 2004 X5 4.4 won't start. When I try to start the X it just make this big click click noise and the head light just flash with the click click sound. Then it stop and the X won't start. Any idea? I installed the Aux input last night and followed the instruction on X5World.com. HELP Please.......
Reply With Quote
Advertisement
  #2  
Old 10-01-2005, 01:32 PM
Daniel B Daniel B is offline
Officially Welcomed to the 'Fest
Location: Sweden
 
Join Date: Jan 2005
Posts: 363
Mein Auto: X6 3.5d
Quote:
Originally Posted by johnbb6
I have a big problem. My 2004 X5 4.4 won't start. When I try to start the X it just make this big click click noise and the head light just flash with the click click sound. Then it stop and the X won't start. Any idea? I installed the Aux input last night and followed the instruction on X5World.com. HELP Please.......
Sounds like a drained battery.
Try to start it with help from another cars battery.
Had the same issue on my 05 it was drained battery.
Some help and some driving to reload the battery did fix it and no more prob.

BTW
are you sure you did connect the cables to the battery good enough again?

Last edited by Daniel B; 10-01-2005 at 01:38 PM.
Reply With Quote
  #3  
Old 10-01-2005, 01:32 PM
Quicksilver's Avatar
Quicksilver Quicksilver is offline
ggcbmwcca.org Member
Location: Northern California
 
Join Date: Dec 2004
Posts: 205
Mein Auto: 2005 X5 4.4
Quote:
Originally Posted by johnbb6
I have a big problem. My 2004 X5 4.4 won't start. When I try to start the X it just make this big click click noise and the head light just flash with the click click sound. Then it stop and the X won't start. Any idea? I installed the Aux input last night and followed the instruction on X5World.com. HELP Please.......
Cars under warranty. Call BMW Roadside service. Even for a battery. Anything. Just call it's easy.
__________________
2005 X5 4.4 - Saphire Black on Black. light Poplar wood,
CD, Nav, Rear climate, Premium Sound. 1989 Mercedes 300E. Previous BMW, 1987 735i.
Reply With Quote
  #4  
Old 10-01-2005, 08:03 PM
DT04R DT04R is offline
Registered User
Location: Vilano Beach, FL
 
Join Date: Nov 2004
Posts: 21
Mein Auto: X5 4.4i
Howdy!

Not sure what you Aux'ed in, but we had the same problem right after an Aux install - in our case, we installed an aftermarket Siruis receiver, and I didn't realize the power under the passenger side wasn't switched. So it sat there running for like 3 days (we work out of the house so don't drive all that much).
__________________
DT
----------------------------------------------------------------
X5 4.4i Sterling Grey Metallic
315HP | 6-Speed Auto | Sport Package | Premium Package
Reply With Quote
  #5  
Old 10-01-2005, 10:19 PM
johnbb6 johnbb6 is offline
Registered User
Location: in my garage
 
Join Date: Sep 2005
Posts: 2
Mein Auto: none
Thanks for the reply. Yes, it was the battery. Not used to the sound of a dead battery from a BMW before. Freaked me out when I came out to start the X and it made the click noise and head light flashed.
Reply With Quote
  #6  
Old 10-02-2005, 01:33 AM
Daniel B Daniel B is offline
Officially Welcomed to the 'Fest
Location: Sweden
 
Join Date: Jan 2005
Posts: 363
Mein Auto: X6 3.5d
Quote:
Originally Posted by johnbb6
Thanks for the reply. Yes, it was the battery. Not used to the sound of a dead battery from a BMW before. Freaked me out when I came out to start the X and it made the click noise and head light flashed.
Guess you had a big smile on your face when you found out it was the battery and the X did start again

Found out what drained the battery yet?
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
x5 4.4 2004 in New Jersey Snow bensto X5 E53 (1999 - 2006) 2 01-24-2005 06:04 AM
2001 X5 4.4 Snow Handling? SoCalX5 X5 E53 (1999 - 2006) 4 01-23-2005 06:51 AM
2004 X5 4.4 sport package 19" wheels... TSAGG X5 E53 (1999 - 2006) 6 01-17-2005 06:56 AM
WTB: 2004 - '05 X5 4.4 Sport Pkg. 19" wheels TSAGG Classifieds 0 01-14-2005 12:36 PM
Pics of 2007 X5 chefwong X5 E70 (2007 - 2013) 4 01-11-2005 10:39 AM


All times are GMT -7. The time now is 09:05 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms