128i misfiring even after tunning up - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 1 Series & 2 Series > E82 / E87 / E88 / F20 1 Series (2008 - 2014)

E82 / E87 / E88 / F20 1 Series (2008 - 2014)
BMWs throw back to the iconic 2002, with a renewed form and function. The smallest car in BMW's line up but still packs a punch. Available in coupe or convertible, powered by a naturaly aspirated inline 6 in the 128 or the turbo twin power inline 6 rocket sled 135.

Reply
 
Thread Tools Display Modes
  #1  
Old 11-14-2017, 06:53 PM
Megaromania Megaromania is offline
Registered User
Location: United States
 
Join Date: Nov 2017
Posts: 1
Mein Auto: 128i
128i misfiring even after tunning up

Hello everyone I am new here
I have a 2008 128i that keeps throwing a cylinder 1 misfire.
I changed the coil and the spark plug still keeps on coming back
Did a compression test and no issues
It looks like it happens only when I turn on the car.
Its not really a bad misfiring you don't even feel it the car drives smooth.

Any ideas what it might be?
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 11-15-2017, 12:33 PM
jsenne jsenne is offline
Registered User
Location: Los Angeles
 
Join Date: Jan 2016
Posts: 3
Mein Auto: 2012 BMW 128i Coupe
Check for Pending Codes

I recently had to fix a few things on my 2012 128i.

- The car misfired at a cold start pretty badly but then went to normal after about 5-10 seconds.
- Misfired at idle when at a stoplight or accelerating from idle.

BMW Dealer Analysis:

- Eccentric Valvetronic Shaft Sensor (Causing rough idle at cold starts)
- Needed a new battery.

Total repair cost = 2224.00

Now, they fixed these two things, but I still had the damn misfire or "hiccup" at idle when at a light or stop sign after warming up. Instead of bringing it back in. I just changed the coils myself and the problem was fixed. Runs like a dream now. It sounds like your valvetronic shaft sensor could be bad. If you have an OBDII you can check for a P1017 code that might be pending and hasn't triggered the engine light.

Joshua S.
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 1 Series & 2 Series > E82 / E87 / E88 / F20 1 Series (2008 - 2014)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 03:31 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
© 2001- VerticalScope Inc. All rights reserved.