Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)

X3 E83 (2004 - 2010)
Talk about the E83 BMW X3 in this forum!

Reply
 
Thread Tools Display Modes
  #1  
Old 10-21-2005, 03:47 PM
wingrove wingrove is offline
Jas
Location: Sydney Australia
 
Join Date: Apr 2005
Posts: 104
Mein Auto: -
Woah X3's gone nuts!

Ok 3 month old X3 3L. just driving along listening to the iPod and it drops out...shifts to radio. Ok thats wierd. So im travelling on the freeway and change lanes..no indicators but my indictors change the radio stations and my steering wheel controls do nothing. ok thats really wierd. On my way to the nearest dealer the car starts fogging up despite the aircon being on, i try to change the temp or any AC controls and theyre frozen. get to the dealer where the car will only lock one door and needs the key to open it the remote wont work. We discover that the indicators are on but the dash lights that tell me so arent working. so i can drive home safely at least till i can spare the time to get it booked in.
I was later told to try disconnecting the battery for a few minutes to see if that fixed it which it did but it all problems returned a couple of days later. indicators on but they stay on, theres no off just left ot right you choose - very funny. seatbelt reminders warning you when your not yet in the car, auto headlights on all day, lock the car and the hazards stay on till you get baqck into the car and press the hazard button five times etc etc. its been kind funny and interesting seeing what it will do today.

So i can finally spare the time to get to the dealer tomorrow and ill get back to you when I know what the problem was. Obviously one of the computers no doubt having so many obscure failures across multiple systems and no doubt i'll have to wait three weeks for the part to come from europe yawn. ah well the parts that let me have a fantastic drive are still working.
cheers
jas
Reply With Quote
Advertisement
  #2  
Old 10-21-2005, 05:24 PM
Ishniknork's Avatar
Ishniknork Ishniknork is offline
I hate doing dishes
Location: Ft. Worth, TX
 
Join Date: Aug 2005
Posts: 2,957
Mein Auto: '05 X3 3.0i
Sorry to hear that...

Mine's about 3-1/2 months old. 3K miles and no problems yet (knock on wood ) Keep us posted and GL!
__________________
'05 X3 3.0i Alpine White/Gray Leather/Alum. Trim
Sport/Steptronic/Servotronic/Panoramic
Premium Sound/Staggered Style 114 18"ers
Reply With Quote
  #3  
Old 10-21-2005, 05:45 PM
x3Bruin x3Bruin is offline
Dog fight anyone?
Location: Fairfax, VA
 
Join Date: Oct 2005
Posts: 1,066
Mein Auto: '05 X3 3.0i & '06 330i
Weird electrical problems seem to plague the X3. My door locks seem to have a mind of their own some time...
Reply With Quote
  #4  
Old 10-21-2005, 06:04 PM
wingrove wingrove is offline
Jas
Location: Sydney Australia
 
Join Date: Apr 2005
Posts: 104
Mein Auto: -
Oh i also forgot another wierd thing. I heard a wierd grinding noise in reverse like id grinded the alloys on the kerb. luckily i hadnt and the noise goes away if i hit the HDC button (ie hill descent light off). that is odd i will definately bring that one up!
j
Reply With Quote
  #5  
Old 10-21-2005, 08:31 PM
jliu34740 jliu34740 is offline
Registered User
Location: Milpitas, CA
 
Join Date: Nov 2004
Posts: 191
Mein Auto: 2008 328xi sportwagen
Dude, you need to reboot your car :-)
Reply With Quote
  #6  
Old 10-21-2005, 09:01 PM
wingrove wingrove is offline
Jas
Location: Sydney Australia
 
Join Date: Apr 2005
Posts: 104
Mein Auto: -
yeah as per the first post i did the old reboot on it and it was back to normal for a couple of days then just went nuts again. maybe its a virus it caught from sitting at the lights next to a merc? our last Merc spent a lot of time in intesive care due to electrical desease.
Reply With Quote
  #7  
Old 10-22-2005, 09:26 AM
Godot Godot is offline
Registered User
Location: Mississauga, Ontario
 
Join Date: Aug 2005
Posts: 64
Mein Auto: 2005 BMW X3 3.0i
Quote:
Originally Posted by wingrove
yeah as per the first post i did the old reboot on it and it was back to normal for a couple of days then just went nuts again. maybe its a virus it caught from sitting at the lights next to a merc? our last Merc spent a lot of time in intesive care due to electrical desease.

Perhaps it's a user problem then??? heheheh
__________________
Godot
Still Waiting?

05 BMW X3 3.0
04 Acura EL Aero
Reply With Quote
  #8  
Old 10-22-2005, 12:58 PM
Tayrum Tayrum is offline
Registered User
Location: Toronto
 
Join Date: Mar 2005
Posts: 49
Mein Auto: X3
Quote:
Originally Posted by jliu34740
Dude, you need to reboot your car :-)
I don't think a reboot is in order but rather a priest to perform an exorcism. Sounds like this car is possessed!
Reply With Quote
  #9  
Old 10-23-2005, 03:55 PM
SilverX3's Avatar
SilverX3 SilverX3 is online now
Officially Welcomed to the 'Fest
Location: Australia
 
Join Date: Sep 2005
Posts: 3,297
Mein Auto: 130i & E92 325i, E90 SOLD
You need to install anti virus and firewire.... sounds like you got some virus and spyware problems... have you been driving without condom ????? he he
Reply With Quote
  #10  
Old 10-24-2005, 05:17 PM
x3man's Avatar
x3man x3man is offline
Officially Welcomed to the 'Fest
Location: USA
 
Join Date: Sep 2004
Posts: 381
Mein Auto: M3/X3
Quote:
Originally Posted by jliu34740
Dude, you need to reboot your car :-)
Oh no, that means they are running Windows on the X3 computer...
__________________
2010 328xi Space Gray/Black, Premium, Navigation, V1 and more.
2005 X3 3.0i Metallic Silver/Black, Premium+Cold packages, Xenon, Navigation, Premium Sound, Steptronic, Servotronic, PDC, Heated Seats/Wheel, Bluetooth, V1.
Reply With Quote
  #11  
Old 11-02-2005, 04:54 PM
wingrove wingrove is offline
Jas
Location: Sydney Australia
 
Join Date: Apr 2005
Posts: 104
Mein Auto: -
X3 Gone nuts big heads up!

OK tuns out ALL yes ALL the problems with my car are due to a short in the wiring harness of the Ice link plus i bought, but my dealer installed. they removed that after FIVE YES FIVE full days in the shop and replacing numerous parts. My dealer is BLOODY AWESOME as they could well charge me for 5 full days of labour and freight / restocking of parts but are not and are also installing me a new BMW adapter for free. Im sure my dealer did a great job of installing it in the first place and they assure me the fault is with the ice link not the car or the install. what a pain and waste of time and energy for all concerned. Now i have an ice link that not worth crap and a BMW adapter that doesnt display id3 tags. Big thanks to my dealer, No thanks to dension.
jas
Reply With Quote
  #12  
Old 11-02-2005, 05:00 PM
adventurelarry adventurelarry is offline
Officially Welcomed to the 'Fest
Location: Brookline, NH
 
Join Date: Apr 2005
Posts: 145
Mein Auto: 2005 X3
Quote:
Originally Posted by x3Bruin
Weird electrical problems seem to plague the X3. My door locks seem to have a mind of their own some time...
This is a known issue http://www.bimmerfest.com/forums/sho...d.php?t=112341
__________________
2005 X3 2.5
Premium Package
Cold Weather Package
Flamenco Red
XM Roady2
Reply With Quote
  #13  
Old 11-02-2005, 05:10 PM
wingrove wingrove is offline
Jas
Location: Sydney Australia
 
Join Date: Apr 2005
Posts: 104
Mein Auto: -
no mention of ice link in that one. much more severe lock problems there!
j
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
A little cautionary note on locking wheel lug nuts JonW General BMW 9 01-21-2005 12:10 PM
Nuts Ron Stygar E36/7 Z3 (1996-2002) 6 11-01-2004 08:35 AM
Over torqued nuts rte6six Off-Topic 12 10-01-2004 12:28 PM
Rusty Lug Nuts billybimmer Tire Rack's Tires, Wheels, Brakes & Suspension 4 07-23-2004 12:23 PM
Check your nuts Stuka General BMW 12 11-10-2003 04:24 PM


All times are GMT -7. The time now is 04:38 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms