Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E46 (1999 - 2006)

E46 (1999 - 2006)
The fourth generation 3 Series (E46 chassis) was introduced in 1999 and set the standard for engineering and performance during it's years of production including being named to Car & Driver's 10 best list every one of those years! ! -- View the E46 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 05-02-2006, 12:37 PM
gthoman gthoman is offline
Registered User
Location: NC
 
Join Date: Apr 2006
Posts: 18
Mein Auto: 323I
Car starts, then dies immediatly..HELP!!

I have a 1999 BMW 323i. While I was out of town my wife drove my car and forgot to turn off the lights.....It seemed the next day the battery was dead, so she had the battery replaced...Now, the car will start(turnover), but cuts off immediatlely...sometimes it will stay on for a couple of seconds then cut off. I can keep the car on by pushing the gas pedal and holding it at like 3k rpm...........I have a Peake OBDII reader and the code showed Air mass sensor....Is there anything else this could be, or a way to verify it?? I have checked and a new air mass meter is around $350..... Thanks for any advice....
Reply With Quote
Advertisement
  #2  
Old 05-02-2006, 01:51 PM
KrisL's Avatar
KrisL KrisL is offline
Ubergeek
Location: San Jose, CA
 
Join Date: Dec 2001
Posts: 15,643
Send a message via AIM to KrisL Send a message via Yahoo to KrisL
Mein Auto: 330i ZHP
Did you replace it with the correct battery? The E46 requires a pretty specialized battery.


If so, I'd go to an auto parts store that can test your alternator for free (most Kragens around me will). Sometimes a bad battery can kill the alternator...
__________________
Reply With Quote
  #3  
Old 05-02-2006, 02:44 PM
ahspao ahspao is offline
Officially Welcomed to the 'Fest
Location: Dallas
 
Join Date: Aug 2005
Posts: 118
Mein Auto: 2003 530i
My bet would be either on the MAF Mass Airflow Sensor or the ICV Idle Control Valve. Sometimes the valve gets stuck (hence the car staying on while you push the accelerator). I think you can try unplugging the MAF and see if anything changes.
Reply With Quote
  #4  
Old 05-02-2006, 05:42 PM
gthoman gthoman is offline
Registered User
Location: NC
 
Join Date: Apr 2006
Posts: 18
Mein Auto: 323I
I did unplug the MAF and the same thing happened....Would this tell me anything??
Reply With Quote
  #5  
Old 05-03-2006, 07:14 AM
gthoman gthoman is offline
Registered User
Location: NC
 
Join Date: Apr 2006
Posts: 18
Mein Auto: 323I
Also...I did check the battery and it was a vented battery that is suppose to be used for a E46. I haven't been able to get a volt meter to check the alternator, but I would supose this code would have been thrown if that is the problem...but who knows.....I guess I need to go with the OBDII reader..........Hopefully its right.....
Reply With Quote
  #6  
Old 05-04-2006, 09:56 AM
gthoman gthoman is offline
Registered User
Location: NC
 
Join Date: Apr 2006
Posts: 18
Mein Auto: 323I
Well, unfortunately that was not the problem....or at least not the ONLY problem...I replaced the MAF and the same problem....I drove it around the neighborhood just to make sure I could take it to the mechanic if needed and check the codes again.....It added another code, Ignition Control Valve mechanically stuck.......So, I've removed that and am ordering the part.......Hopefully the computer is right this time....There was alot of build up, so hopefully that will fix it.....I might also try to clean it with some WD-40 or carb cleaner, I've seen some other posts that people just cleaned it.......
Reply With Quote
  #7  
Old 05-04-2006, 09:57 AM
gthoman gthoman is offline
Registered User
Location: NC
 
Join Date: Apr 2006
Posts: 18
Mein Auto: 323I
Oooopss....I meant Idle Control Valve....
Reply With Quote
  #8  
Old 05-04-2006, 10:29 AM
gil4saturn gil4saturn is offline
Registered User
Location: chicago il.
 
Join Date: May 2006
Posts: 2
Mein Auto: 323 i
let a pro look at it i have the same car
Reply With Quote
  #9  
Old 05-09-2006, 07:48 AM
gthoman gthoman is offline
Registered User
Location: NC
 
Join Date: Apr 2006
Posts: 18
Mein Auto: 323I
Well, the problem was the Idle Control Valve....replaced it and now its fine....
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E46 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to Save Money Doing Euro Delivery Nat Brown Ask-A-Dealer 138 02-19-2014 01:38 PM
Would you keep your E65/E66 once the maint/warranty expires (really long) klm187 7 Series - E65 / E66 (2002 - 2008) 10 10-26-2013 11:28 PM
VOB BMW of Maryland has the worst service cynicalwry Dealer Feedback / Vehicle Problems 68 09-29-2010 01:25 AM
The $95k E46 M3 BlackChrome General Automotive Forum 19 06-01-2006 05:32 PM
Car starts but won't stay running!! rb25ds14 Do-It-Yourself H.Q. 4 11-01-2003 03:52 AM


All times are GMT -7. The time now is 11:31 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms