Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E46 (1999 - 2006)

E46 (1999 - 2006)
The fourth generation 3 Series (E46 chassis) was introduced in 1999 and set the standard for engineering and performance during it's years of production including being named to Car & Driver's 10 best list every one of those years! ! -- View the E46 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 02-02-2007, 05:01 PM
dood's Avatar
dood dood is offline
Officially Welcomed to the 'Fest
Location: New Jersey
 
Join Date: Jun 2006
Posts: 176
Mein Auto: 2004 330xi
DSC, BRAKE, and ABS lights (and DICE)

I just installed a DICE HD and before I got busy installing, I disconencted a couple fuses that were mentioned in the DICE manual (then reinstalled when done).

I've been having problems with the text display and iPod audio cutting out on the DICE. I spoke with Tom from EAS and he told me to try disconnecting and shorting the battery cables for 10 minutes, then hook it all back up to reset the system.

It seemed to help the text on my nav screen from the DICE unit, but the audio cut out was still there. Plus the rewind function didn't work from the car radio/steering wheel, but fast forward did.

The other thing that happened (and I'm more concerned with this) was that when I started up the car, the DSC, BRAKE, and ABS lights are all on - yellow. I did a search and it mentioned that this went away after they drove a bit? I didn't go for a spin yet since it's snowing here. Hopefully they'll disappear tomorrow when I go for a spin.

Anyone have this same issue? How long did it take for those lights to go out?

Thanks.
__________________
2004 330xi, Step, ZPP, ZCW, NAV, Bi-Xenon, Black Sapphire Metallic, Sand Montana Leather, DICE HD, V1
Reply With Quote
Advertisement
  #2  
Old 02-02-2007, 05:06 PM
KrisL's Avatar
KrisL KrisL is offline
Ubergeek
Location: San Jose, CA
 
Join Date: Dec 2001
Posts: 15,643
Send a message via AIM to KrisL Send a message via Yahoo to KrisL
Mein Auto: 330i ZHP
Do you get the audio cutting out when listening to the ipod? Seem to be related to the text "starting over" at the beginning of each artist-title-album sequence? I'm experiencing the same...


Yeah, the DSC/BRAKE/ABS should go out after a drive.
__________________
Reply With Quote
  #3  
Old 02-02-2007, 05:07 PM
AzNMpower32's Avatar
AzNMpower32 AzNMpower32 is offline
Tar Heel Faithful
Location: WNC
 
Join Date: Oct 2005
Posts: 13,988
Send a message via AIM to AzNMpower32
Mein Auto: 2014 Mazda3 GT
Funny coincidence, there's the exact same thread going on in the X3 forum. Problem solved with a drive.

http://www.bimmerfest.com/forums/sho...d.php?t=184175
Reply With Quote
  #4  
Old 02-02-2007, 05:12 PM
dood's Avatar
dood dood is offline
Officially Welcomed to the 'Fest
Location: New Jersey
 
Join Date: Jun 2006
Posts: 176
Mein Auto: 2004 330xi
Quote:
Originally Posted by KrisL View Post
Do you get the audio cutting out when listening to the ipod? Seem to be related to the text "starting over" at the beginning of each artist-title-album sequence? I'm experiencing the same...


Yeah, the DSC/BRAKE/ABS should go out after a drive.

YES YES YES.

Same cut-out/cut-in issue.

I've heard it while the text seems to glitch and go back to the beginning of the text line. I've also heard it when the text doesn't glitch.

The cut-out/cut-in will drive me bananas.
__________________
2004 330xi, Step, ZPP, ZCW, NAV, Bi-Xenon, Black Sapphire Metallic, Sand Montana Leather, DICE HD, V1
Reply With Quote
  #5  
Old 02-02-2007, 05:13 PM
dood's Avatar
dood dood is offline
Officially Welcomed to the 'Fest
Location: New Jersey
 
Join Date: Jun 2006
Posts: 176
Mein Auto: 2004 330xi
Quote:
Originally Posted by AzNMpower32 View Post
Funny coincidence, there's the exact same thread going on in the X3 forum. Problem solved with a drive.

http://www.bimmerfest.com/forums/sho...d.php?t=184175

I saw that in the search. I posted there. But thought I might get some better feedback from other 3-series guys.
__________________
2004 330xi, Step, ZPP, ZCW, NAV, Bi-Xenon, Black Sapphire Metallic, Sand Montana Leather, DICE HD, V1
Reply With Quote
  #6  
Old 02-02-2007, 05:15 PM
KrisL's Avatar
KrisL KrisL is offline
Ubergeek
Location: San Jose, CA
 
Join Date: Dec 2001
Posts: 15,643
Send a message via AIM to KrisL Send a message via Yahoo to KrisL
Mein Auto: 330i ZHP
Quote:
Originally Posted by dood View Post
YES YES YES.

Same cut-out/cut-in issue.

I've heard it while the text seems to glitch and go back to the beginning of the text line. I've also heard it when the text doesn't glitch.

The cut-out/cut-in will drive me bananas.


Likewise .
__________________
Reply With Quote
  #7  
Old 02-02-2007, 05:17 PM
dood's Avatar
dood dood is offline
Officially Welcomed to the 'Fest
Location: New Jersey
 
Join Date: Jun 2006
Posts: 176
Mein Auto: 2004 330xi
Have you also noticed the non-rewind from the steering wheel/radio, but it will fast forward?

Also if I unhook the iPod, the playlist will list as blank until I hit menu, then forward again into the playlist. Then the song names are back. That seems odd too.


Maybe I'm not crazy afterall if others are seeing the same behavior.
__________________
2004 330xi, Step, ZPP, ZCW, NAV, Bi-Xenon, Black Sapphire Metallic, Sand Montana Leather, DICE HD, V1
Reply With Quote
  #8  
Old 02-02-2007, 06:45 PM
tom @ eas's Avatar
tom @ eas tom @ eas is offline
european auto source
Location: SoCal, CA
 
Join Date: May 2004
Posts: 5,852
Mein Auto: BMW
Quote:
Originally Posted by dood View Post
Have you also noticed the non-rewind from the steering wheel/radio, but it will fast forward?

Also if I unhook the iPod, the playlist will list as blank until I hit menu, then forward again into the playlist. Then the song names are back. That seems odd too.


Maybe I'm not crazy afterall if others are seeing the same behavior.
Answered in DICE Q/A Thread: http://www.bimmerfest.com/forums/sho...=1#post2155404
__________________
Tom G. | european auto source (eas)
email: tom@europeanautosource.com web: www.europeanautosource.com tel 866.669.0705 ca: 714.369.8524 x22

GET DAILY UPDATES ON OUR BLOG FACEBOOK YOUTUBE FLICKR INSTAGRAM
Reply With Quote
  #9  
Old 02-04-2007, 05:30 PM
dood's Avatar
dood dood is offline
Officially Welcomed to the 'Fest
Location: New Jersey
 
Join Date: Jun 2006
Posts: 176
Mein Auto: 2004 330xi
Went for a nice long drive today with the wife. We tried to listen to the iPod on the HD DICE, but the audio kept cutting in and out quite frequently. She turned to me and said, "this sucks, lets listen to the regular radio instead".

Needless to say I'm not happy.

Soed anyone just have the regular DICE without the HD? Does the audio constantly cut in and out on that too? If not, I'm returning this one and buying that one. If so, I'm returning it and forgetting about it.
__________________
2004 330xi, Step, ZPP, ZCW, NAV, Bi-Xenon, Black Sapphire Metallic, Sand Montana Leather, DICE HD, V1
Reply With Quote
  #10  
Old 02-04-2007, 06:40 PM
tom @ eas's Avatar
tom @ eas tom @ eas is offline
european auto source
Location: SoCal, CA
 
Join Date: May 2004
Posts: 5,852
Mein Auto: BMW
Quote:
Originally Posted by dood View Post
Went for a nice long drive today with the wife. We tried to listen to the iPod on the HD DICE, but the audio kept cutting in and out quite frequently. She turned to me and said, "this sucks, lets listen to the regular radio instead".

Needless to say I'm not happy.

Soed anyone just have the regular DICE without the HD? Does the audio constantly cut in and out on that too? If not, I'm returning this one and buying that one. If so, I'm returning it and forgetting about it.
Give me a call from your vehicle tomorrow and we can go over some troubleshooting steps in real-time.
__________________
Tom G. | european auto source (eas)
email: tom@europeanautosource.com web: www.europeanautosource.com tel 866.669.0705 ca: 714.369.8524 x22

GET DAILY UPDATES ON OUR BLOG FACEBOOK YOUTUBE FLICKR INSTAGRAM
Reply With Quote
  #11  
Old 01-06-2013, 12:30 PM
bluebee's Avatar
bluebee bluebee is offline
Seek to understand,^Value
Location: San Jose, California
 
Join Date: Mar 2008
Posts: 21,274
Mein Auto: 02 BMW 525i M54 auto 130K
I'm looking up all the ABS BRAKE DSC or ASC E46 threads to see if anyone reported the ABS harness connector wheel speed sensor pinout for the E46 yet.

This thread, unfortunately doesn't have that pinout listed, so, if you need it, refer to this new thread opened today expressly to find the answer for E46 owners:
> E46 (1999 - 2006) > E46 ABS control module harness wheel sensor pinout for the ABS/BRAKE/DSC bi trifecta
__________________
Each repair should invariably add to our knowledge base by the process of inexorable incrementalism.
Your job, in return, is to read the suggested threads, where the best people will always add value to those threads, either by pictures or by descriptions, so the next person with the same problem stands on your shoulders.
See also: E39 Bestlinks & How to easily find what you need
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E46 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 05:20 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms