Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)

E60 (2004 - 2010)
BMW 5-Series (E60 chassis) was first seen in the Unites States in the fall of 2003 with a 2004 Model Year designation. The E60 is now available as a 528i, 528xi, 535i, 535xi, 550i and a 535xi sports wagon! -- View the E60 Wiki

Reply
 
Thread Tools Display Modes
  #26  
Old 04-02-2007, 03:05 PM
stevepow's Avatar
stevepow stevepow is offline
Officially Welcomed to the 'Fest
Location: ATL
 
Join Date: Mar 2006
Posts: 860
Mein Auto: 2009 911 PDK/Sport
Keep us posted - my "eye-brows" don't light up, but I don't want to mess with anything that will cause other worse problems.
__________________
Steve Powell

2009 911 PDK / Sport Chrono
Black / Sand

Nav/XM/Bose/Vent Seats/...
Purchased: May 30, 2009

2007 550i Sport SMG
Jet Black / Black Nasca Leather / Anthracite Maple Trim / Anthracite Head Liner

All Options
Ordered: April 10 2006
Leased: June 10 2006
Returned: May 30, 2009
Reply With Quote
  #27  
Old 04-02-2007, 07:03 PM
Bart001's Avatar
Bart001 Bart001 is offline
Hofmeister kink ftw!1!!1!
Location: Massachusetts
 
Join Date: Apr 2005
Posts: 1,477
Mein Auto: 2012 X5 35i Premium
Quote:
Originally Posted by GolferEngineer View Post
All,
I'm scheduled to have my car upgraded tomorrow to fix the blank iDrive display problem. A PUMA software fix a few weeks ago didn't help and BMW NA contacted me and said the new software will be available 4/1/2007 to fix the iDrive blanking problem. Hopefully, this isn't an April Fool's joke! Even though BMW NA said only a software upgrade was required, the delaer is also replacing the control unit.

Please contact your dealer and BMW NA if necessary. In a way I'm glad to hear that a few more folks have this problem - please don't dismiss it since it should never happen.
On another note, I hope this "fix" also corrects the low Aux audio problem I've had ever since they did the software upgrade to fix the O2 sensitivity - this is when my iDrive problems started.

I realy hope to have good news for all of you in a few days.
That's great! Please follow up post as much info as you can, including the identification of any specific TSB that covers this. Thanks!!
Reply With Quote
  #28  
Old 04-03-2007, 04:48 AM
Bassesq Bassesq is offline
Registered User
Location: Long Island, NY
 
Join Date: Feb 2007
Posts: 19
Mein Auto: 2013 535 xi
I picked up my car on Saturday. On Monday, I made a brief coffee stop. When I came out there was no audio output even though all cd, sat systems displayed properly. Even the BMW chimes were silent. Turning the car off and restarting didn't work.

I arrived at my next stop where the car was parked for about 1 1/2 hours. When I came out and restarted then all systems were fine. My sales associate said that it takes the car a full 15 minutes for all computers in the car to shut down after the car is turned off.

I hope this doesn't happen again.....especially after just reading the above posts.
__________________
2013 535xi Dark Saphire Grey/Oyster/Black
Premium, Cold Weather with rear heated, Nav, Comfort Access, Rear Camera, Park Distance, Tint 50% (Leased)

2010 530xi Saphire Black/Navajo
Premium, Premium Sound, Nav, Cold Weather, Comfort Seats, Rear Shade and Side Shades, Tint (Retired Lease)

2007 530i Monaco Blue/Beige Leather,
Steptronic, Premium Package, Cold Weather, Satellite (Retired Lease)
Reply With Quote
  #29  
Old 04-03-2007, 03:45 PM
demaximis demaximis is offline
Registered User
Location: Atlanta, GA
 
Join Date: Mar 2007
Posts: 2
Mein Auto: 2005 530i
I had my software updated yesterday, and was told they just received the fix for this issue, which seems consistent with what GolferEngineer was told. So far so good, but I will keep an eye on the issue.
Reply With Quote
  #30  
Old 04-04-2007, 06:11 AM
hhassing hhassing is offline
Registered User
Location: arkansas
 
Join Date: Apr 2007
Posts: 11
Mein Auto: x5
Alas, although BMW NA told me they had never heard of what was happening to my iDrive, I now realize that there are many with the same problem. I've had my 2007 x5 for 3 days, and the iDrive screen is completely blank. I took it to a local service provider and they were stumped, started swapping out parts in my trunk with an x5 on their lot. Idiots! Anyway, I now have to drive 2 hours to where I bought it (the other place told me I had to wait 22 days for them to get me in b/c I didn't buy it from them) where I'm sure they'll tell me they don't know what's going on. This is driving me crazy! BMW ride is great, but anything else is terrible. I bought a 3 series in 1999 and the window regulator design was messed up and it sounded like it was metal crunching glass, they kept replacing it but what good is that when the flaw is in the design of the regulator.
By the way, how do you reboot with the 3 finger salute if you can't get the screen on?
Thanks!
Reply With Quote
  #31  
Old 04-04-2007, 06:17 AM
hhassing hhassing is offline
Registered User
Location: arkansas
 
Join Date: Apr 2007
Posts: 11
Mein Auto: x5
Question

Quote:
Originally Posted by stream View Post
Try rebooting iDrive. Press mute, CD eject & DVD eject simultaneously, and hold until iDrive shuts off and reboots.
How do I press the mute button if my screen is blank? is this a button on the dash?
Reply With Quote
  #32  
Old 04-04-2007, 06:22 AM
jcatral14's Avatar
jcatral14 jcatral14 is offline
Running around in circles
Location: Northern NJ
 
Join Date: Aug 2003
Posts: 3,600
Mein Auto: E46 ZHP
Quote:
Originally Posted by hhassing View Post
How do I press the mute button if my screen is blank? is this a button on the dash?
Mute is the volume knob.
__________________
2005 Imola Red 330i 6MT, ZHP, ZCW, Xenons
2014 Blue Water X3 xDrive28i ZCW, ZLP, LUCZ



Previous Bimmers ( All sorely missed ):
2007 Mystic Blue 530i - ED 12-15-06
2003 Grey Green 330i
2003 Electric Red 325iTa

Angular velocity is where it's at



-Jay
Reply With Quote
  #33  
Old 04-04-2007, 06:29 AM
hhassing hhassing is offline
Registered User
Location: arkansas
 
Join Date: Apr 2007
Posts: 11
Mein Auto: x5
Angry

Quote:
Originally Posted by jcatral14 View Post
Mute is the volume knob.

Thank you, I tried that based on intuition and nothing. I'm off to make a 2 hour drive to see my service guy. I'm betting that they tell me they don't know what's wrong and send me home with a loaner. I could pull all my hair out right now.
Reply With Quote
  #34  
Old 04-04-2007, 06:35 AM
Bart001's Avatar
Bart001 Bart001 is offline
Hofmeister kink ftw!1!!1!
Location: Massachusetts
 
Join Date: Apr 2005
Posts: 1,477
Mein Auto: 2012 X5 35i Premium
Quote:
Originally Posted by hhassing View Post
By the way, how do you reboot with the 3 finger salute if you can't get the screen on?
Thanks!
The "reboot" key combo does not cure this issue. It works if the iDrive should happen to freeze, but the particular issue that this thread is about does not respond to the 'soft reboot' key combo.

The computers take 15 minutes to reset?? I never heard THAT ONE before!
Reply With Quote
  #35  
Old 04-04-2007, 06:36 AM
Bart001's Avatar
Bart001 Bart001 is offline
Hofmeister kink ftw!1!!1!
Location: Massachusetts
 
Join Date: Apr 2005
Posts: 1,477
Mein Auto: 2012 X5 35i Premium
Oh and I've been emailing my Service Advisor and he'll keep looking for a TSB on this. I've not had this issue for a week now, and I'd rather just keep the car until a proper fix is identified, rather than having the dealership try to just shotgun it.

Any specific info that others may find out really would be appreciated!
Reply With Quote
  #36  
Old 04-04-2007, 06:43 AM
jcatral14's Avatar
jcatral14 jcatral14 is offline
Running around in circles
Location: Northern NJ
 
Join Date: Aug 2003
Posts: 3,600
Mein Auto: E46 ZHP
Quote:
Originally Posted by hhassing View Post
Thank you, I tried that based on intuition and nothing. I'm off to make a 2 hour drive to see my service guy. I'm betting that they tell me they don't know what's wrong and send me home with a loaner. I could pull all my hair out right now.
2 hours??!? Damn. Drive safe
__________________
2005 Imola Red 330i 6MT, ZHP, ZCW, Xenons
2014 Blue Water X3 xDrive28i ZCW, ZLP, LUCZ



Previous Bimmers ( All sorely missed ):
2007 Mystic Blue 530i - ED 12-15-06
2003 Grey Green 330i
2003 Electric Red 325iTa

Angular velocity is where it's at



-Jay
Reply With Quote
  #37  
Old 04-04-2007, 02:16 PM
GolferEngineer GolferEngineer is offline
Officially Welcomed to the 'Fest
Location: Central New Jersey
 
Join Date: Feb 2006
Posts: 673
Mein Auto: MY07 530xi
Go the car back after an upgrade

Just returned with the car from the dealer.

FYI there was a PUMA case #8619842 for the new software re-prgramming.
In addition, the CCC module was replaced and OKed by BMW
The CIP is 25.00.04

So far so good but it usually takes a week or more for the iDrive to quit. I'll be on a business trip next week so any updates from me may take a couple weeks or more.

Something very interesting is that after I've complained about the bad Sirius radio reception every service call for a year, the repair may have also fixed it! I'll keep my fingers crossed.

Hope this helps others with the same problem.
__________________
MY07 530xi Monaco Blue, Beige Interior, Steptronic, Premium Package, Cold Weather Package, Premium Sound Package, Sirius Radio, HD Radio, Navigation, Rear Sun Shades, Park Distance Control, Comfort Seats and Fold Down Rear Seats.
Reply With Quote
  #38  
Old 04-04-2007, 04:59 PM
hhassing hhassing is offline
Registered User
Location: arkansas
 
Join Date: Apr 2007
Posts: 11
Mein Auto: x5
Hello All, I am finally back home. Talk about frustrating. I drove 2 hours there and 2 hours back, with a loaner car. It took hours for them to tell me that my whole "computer" was completely crashed. They tried swapping out my cd and dvd console (apparently that is where the main hub is) with another one on their lot but the other one was wired for sirius so no audio on output. Anyway, BMW technical authorized my service dealer to order and release a new one. In my case, this was not something I could reset and reboot, the whole system was down, nothing would respond, can't even take my CD out. This is so frustrating, which I think I already said. I'll keep you all posted on what they tell me, although I highly doubt they will tell me much besides, "here's your car".
Reply With Quote
  #39  
Old 04-04-2007, 05:01 PM
hhassing hhassing is offline
Registered User
Location: arkansas
 
Join Date: Apr 2007
Posts: 11
Mein Auto: x5
Quote:
Originally Posted by GolferEngineer View Post
Just returned with the car from the dealer.

FYI there was a PUMA case #8619842 for the new software re-prgramming.
In addition, the CCC module was replaced and OKed by BMW
The CIP is 25.00.04

So far so good but it usually takes a week or more for the iDrive to quit. I'll be on a business trip next week so any updates from me may take a couple weeks or more.

Something very interesting is that after I've complained about the bad Sirius radio reception every service call for a year, the repair may have also fixed it! I'll keep my fingers crossed.

Hope this helps others with the same problem.
What exactly is "PUMA case #" and "CCC module"? My iDrive quit 3 days after I bought my car. They are swapping out my cd/dvd console b/c they said that was the root cause, completely inoperable.
Reply With Quote
  #40  
Old 04-04-2007, 05:15 PM
GolferEngineer GolferEngineer is offline
Officially Welcomed to the 'Fest
Location: Central New Jersey
 
Join Date: Feb 2006
Posts: 673
Mein Auto: MY07 530xi
Quote:
Originally Posted by hhassing View Post
What exactly is "PUMA case #" and "CCC module"? My iDrive quit 3 days after I bought my car. They are swapping out my cd/dvd console b/c they said that was the root cause, completely inoperable.
PUMA is an acronym for something and the CCC is the controller behind the CD/Nav unit.

BTW when my iDrive went out I couldn't eject the CD either. But, it usually came to life after being off for several hours or over night.

I'm glad your dealer got the approval for a new unit. You can call them and reference my PUMA number - that may help them not have to reinvent the wheel!

Good Luck!

Let's keep our fingers crossed.
__________________
MY07 530xi Monaco Blue, Beige Interior, Steptronic, Premium Package, Cold Weather Package, Premium Sound Package, Sirius Radio, HD Radio, Navigation, Rear Sun Shades, Park Distance Control, Comfort Seats and Fold Down Rear Seats.
Reply With Quote
  #41  
Old 04-04-2007, 09:56 PM
hhassing hhassing is offline
Registered User
Location: arkansas
 
Join Date: Apr 2007
Posts: 11
Mein Auto: x5
Quote:
Originally Posted by GolferEngineer View Post
PUMA is an acronym for something and the CCC is the controller behind the CD/Nav unit.

BTW when my iDrive went out I couldn't eject the CD either. But, it usually came to life after being off for several hours or over night.

I'm glad your dealer got the approval for a new unit. You can call them and reference my PUMA number - that may help them not have to reinvent the wheel!

Good Luck!

Let's keep our fingers crossed.
Thanks alot! I appreciate the help on this forum and your thread. I should be getting my car Friday, I'm a bit nervous about it b/c the dealer is going to have someone drive my car the 2 hours and take back the loaner, don't know how I feel about that! But I'm really nervous about whether this will happen again. Less than 500 miles and already getting grief.
Reply With Quote
  #42  
Old 06-29-2007, 01:46 PM
rama_e rama_e is offline
Officially Welcomed to the 'Fest
Location: VA
 
Join Date: Apr 2007
Posts: 142
Mein Auto: 09 E92 335i/'09 VW Routan
Angry

This issue is really annoying.
I have a 2007 525 and had this problem happened to me twice already. I finally took my car in for service at BMW Fairfax VA, this includes everything on the first service for 15K miles and I also told him about the idrive going black, no sound, rotating by itself and brake squeaking sound... Gosh!!! I am really tired of this.
They give a Dodge Stratus from Enterprise while the car is serviced there. I really hate that car, I told the customer service person; this why I am paying a lot of money on my BMW because I don't like those kind of cars... They could not even afford a BMW?? I told him that even Acura, Audi, Mercedes... they offer their customer the same brand of car. I hate seeing myslef driving that car.
Anyway, the guy told me that he could not finish the upgrade in 2 days. I told him I will take my car back and will come back in another time for this friggin' upgrade. Another trip to the service shop. One of hundredth time.
Come on people, this is a BMW?
Reply With Quote
  #43  
Old 06-30-2007, 12:12 PM
SEEG SEEG is offline
Registered User
Location: Central Washington
 
Join Date: Jun 2007
Posts: 3
Mein Auto: various
Hmm, you folks are scaring me!!
Reply With Quote
  #44  
Old 07-15-2007, 03:01 PM
GolferEngineer GolferEngineer is offline
Officially Welcomed to the 'Fest
Location: Central New Jersey
 
Join Date: Feb 2006
Posts: 673
Mein Auto: MY07 530xi
I happened again!!


My iDrive went blank again this weekend! This is three months after a controller replacement and software upgrade and just 4 weeks after another software upgrade!

The car goes back in the shop tomorrow. Same symptoms as before - a quick dash into a store, come out and no iDrive (or stereo or navigation, etc.). The car has to sit for a few hours to get it back.

BUT, I need the car Wednesday morning to drive 350 + miles to my daughter's wedding - the timing stinks!
__________________
MY07 530xi Monaco Blue, Beige Interior, Steptronic, Premium Package, Cold Weather Package, Premium Sound Package, Sirius Radio, HD Radio, Navigation, Rear Sun Shades, Park Distance Control, Comfort Seats and Fold Down Rear Seats.
Reply With Quote
  #45  
Old 07-15-2007, 07:29 PM
hunterz4's Avatar
hunterz4 hunterz4 is offline
Officially Welcomed to the 'Fest
Location: SF Bay Area
 
Join Date: Nov 2005
Posts: 367
Mein Auto: 2007 X5, 2006 530i
Man, this is a tough one. They should just replace the entire unit. Your patience is truly a virtue. Is this problem occuring only in cars with NAV units?
__________________
Now:
2006 530i Amythest Grey, MT, Sport, comfort seats & access.
2006 330cic, E46 Rag top, Titanium/Black, Auto, Sport, Premium.

Then:
'07 X5 3.0 Alpine, Tobacco, Dark Burl, Sport, Tech, Premium, Rear climate, 3d row seat, ipod & running boards.
'07 X3, Silver Gray, Gray, Gray Poplar, Auto (gone and forgotten)
'03 Z4, 2.5, M. Blue, Black, MT, Sport, Premium. (RIP)
'95 325i, E36, Blk, Blk, auto, premium
'89 325i, E30, 1st one, Platinum Bronze, Black leatherette, MT.
Reply With Quote
  #46  
Old 07-16-2007, 06:36 AM
stevepow's Avatar
stevepow stevepow is offline
Officially Welcomed to the 'Fest
Location: ATL
 
Join Date: Mar 2006
Posts: 860
Mein Auto: 2009 911 PDK/Sport
This has got to be a defect and not a software issue - otherwise all of us would have this problem and this topic would be much longer as a result.

Why has BMW not been able to get their heads around this?

Don't they get 3 tries to fix it and then it's a lemon, right?
__________________
Steve Powell

2009 911 PDK / Sport Chrono
Black / Sand

Nav/XM/Bose/Vent Seats/...
Purchased: May 30, 2009

2007 550i Sport SMG
Jet Black / Black Nasca Leather / Anthracite Maple Trim / Anthracite Head Liner

All Options
Ordered: April 10 2006
Leased: June 10 2006
Returned: May 30, 2009
Reply With Quote
  #47  
Old 07-17-2007, 04:53 PM
GolferEngineer GolferEngineer is offline
Officially Welcomed to the 'Fest
Location: Central New Jersey
 
Join Date: Feb 2006
Posts: 673
Mein Auto: MY07 530xi
Update!

Got the car back. According to the repair invoice there were trouble codes and they were resolved after re-programming software. It is my assumption that this is probably a correct "fix" since the new Controller/software worked for almost three months but I had the latest failure a month after the software was upgraded again.

If I have any more problems I'll post them. Meanwhile, we're off to Western PA (350 + mile drive) for our youngest daughter's wedding this weekend. I'll have plenty of chances to check out the fix with all the errands, etc. we'll be doing.
__________________
MY07 530xi Monaco Blue, Beige Interior, Steptronic, Premium Package, Cold Weather Package, Premium Sound Package, Sirius Radio, HD Radio, Navigation, Rear Sun Shades, Park Distance Control, Comfort Seats and Fold Down Rear Seats.
Reply With Quote
  #48  
Old 07-17-2007, 05:45 PM
jcatral14's Avatar
jcatral14 jcatral14 is offline
Running around in circles
Location: Northern NJ
 
Join Date: Aug 2003
Posts: 3,600
Mein Auto: E46 ZHP
Quote:
Originally Posted by GolferEngineer View Post
Got the car back. According to the repair invoice there were trouble codes and they were resolved after re-programming software. It is my assumption that this is probably a correct "fix" since the new Controller/software worked for almost three months but I had the latest failure a month after the software was upgraded again.

If I have any more problems I'll post them. Meanwhile, we're off to Western PA (350 + mile drive) for our youngest daughter's wedding this weekend. I'll have plenty of chances to check out the fix with all the errands, etc. we'll be doing.
Good to hear that they corrected/fixed it right away. Drive safe
__________________
2005 Imola Red 330i 6MT, ZHP, ZCW, Xenons
2014 Blue Water X3 xDrive28i ZCW, ZLP, LUCZ



Previous Bimmers ( All sorely missed ):
2007 Mystic Blue 530i - ED 12-15-06
2003 Grey Green 330i
2003 Electric Red 325iTa

Angular velocity is where it's at



-Jay
Reply With Quote
  #49  
Old 10-17-2007, 01:10 PM
Spyder's Avatar
Spyder Spyder is offline
Officially Welcomed to the 'Fest
Location: Southern California
 
Join Date: Feb 2006
Posts: 1,072
Mein Auto: 650i Coupe (soon)
Similar problem...

The iDrive on my wife's '08 ED 535 froze this morning in the default setting, ie, not a blank screen as the OP described, but the 4-spoke initial screen. Others have mentioned that letting the car sit overnight can reset the s/w and solve the immediate problem. My SA told me that, in fact, the reboot occurs after just 28 min. At that point systems have been selectively shut down so that only 70 ma is being drawn from the battery as the car enters sleep mode. The reboot process can be hastened by the "three-finger" exercise described above.

Anyway, my SA believes that the frozen-screen problem will be fixed by the latest iDrive upgrade so the car goes in next Tuesday.

Spyder
Reply With Quote
  #50  
Old 10-19-2007, 03:27 AM
obi.wan obi.wan is offline
Officially Welcomed to the 'Fest
Location: St Pete
 
Join Date: Feb 2007
Posts: 295
Mein Auto: 06 XC90x2(me) , 07 530xiT
i drive is freezing more and more, completerly random.
Freeze: black screen
turn car off, random amount of time, resets

I had this replaced when we had less than 100 miles on the car.

have to take it in one of these days
__________________
2007 530XiT Monaco Blue/Beige
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Polarized sunglass washout of stereo display twodachs E90/E91/E92/E93 (2006 - 2013) 48 09-22-2010 08:13 AM
Advantages of iDrive and CCC rrandyy E90/E91/E92/E93 (2006 - 2013) 9 09-10-2006 02:46 PM
Where is my stereo sirkendoo E39 (1997 - 2003) 3 10-05-2005 02:52 PM
Do you like Nav extra bubble? bm_chief E90/E91/E92/E93 (2006 - 2013) 83 09-25-2005 06:56 PM


All times are GMT -7. The time now is 05:18 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms