Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E38 (1995 - 2001)

7 Series - E38 (1995 - 2001)

Reply
 
Thread Tools Display Modes
  #1  
Old 05-24-2007, 07:13 AM
Wader2 Wader2 is offline
Registered User
Location: Simpsonville, SC
 
Join Date: May 2007
Posts: 2
Mein Auto: 2000 740il
2000 740IL Radio Problem

I'm new to the forum and I've recently purchased a 2000 740il w/nav. My first BMW and an incredible car. However, from time to time the radio/CD will just cut off. In addition the display will freeze. You can manually turn the radio/CD back on but it will cut back off in about 1-2 min.. The display will stay frozen. Everything will reset when you shut the car off and back on. Any thoughts will be greatly appreciated. Thanks
Reply With Quote
Ads by Google
  #2  
Old 05-30-2007, 07:05 PM
bimmernav bimmernav is offline
Past Sponsor
Location: Austin, Tx
 
Join Date: May 2007
Posts: 48
Mein Auto: BMW
a low battery can cause this issue. If your battery is low the car will start, but the audio system needs more voltage so it shuts off. Look at the battery. If lower than 12.6 volts after having a load on the battery for 5 minutes it is time to replace.

Martin
Reply With Quote
  #3  
Old 05-31-2007, 07:47 AM
crewdog843's Avatar
crewdog843 crewdog843 is offline
Officially Welcomed to the 'Fest
Location: Las Vegas, NV
 
Join Date: Mar 2006
Posts: 672
Mein Auto: '08 Z4 3.0si Roadie
You can unlock your OBD and view various readings, one of them battery voltage. I believe you can find the procedure on www.e38.org. There have been extensive write-ups on other BMW forums about this anomaly....lots of information out there.

Good luck.

jake
__________________
Reply With Quote
  #4  
Old 06-01-2007, 11:41 AM
scorpo scorpo is offline
Registered User
Location: Europe
 
Join Date: Jun 2007
Posts: 8
Mein Auto: E39 530D '02
Quote:
Originally Posted by Wader2 View Post
I'm new to the forum and I've recently purchased a 2000 740il w/nav. My first BMW and an incredible car. However, from time to time the radio/CD will just cut off. In addition the display will freeze. You can manually turn the radio/CD back on but it will cut back off in about 1-2 min.. The display will stay frozen. Everything will reset when you shut the car off and back on. Any thoughts will be greatly appreciated. Thanks
I have exactly the same story on my E39 '02, have you solved the problem? What was it?
Reply With Quote
  #5  
Old 06-01-2007, 05:16 PM
bimmernav bimmernav is offline
Past Sponsor
Location: Austin, Tx
 
Join Date: May 2007
Posts: 48
Mein Auto: BMW
actually here is the correct process

you must leave the car off without it running with the high beams on for 5 minutes to remove the surface charge. then test the battery. If lower than 12V then that is your issue for sure.

Here is a link to the training documents from BMW AG to BMW dealer techs on teaching them about the BMW battery and BMW electrical system

BMW Battery Training docs

Martin
Reply With Quote
  #6  
Old 06-02-2007, 12:37 AM
scorpo scorpo is offline
Registered User
Location: Europe
 
Join Date: Jun 2007
Posts: 8
Mein Auto: E39 530D '02
Quote:
Originally Posted by bimmernav View Post
you must leave the car off without it running with the high beams on for 5 minutes to remove the surface charge. then test the battery. If lower than 12V then that is your issue for sure.

Here is a link to the training documents from BMW AG to BMW dealer techs on teaching them about the BMW battery and BMW electrical system

BMW Battery Training docs

Martin
Thanks mate,

But why does the screen freezes instead of also going off as radio? Also one or two times i had the radio playing but the screen was black And one more thing, sometimes when i open the bootlid i notice that nav cd is ejected from my MK3, but it goes back in by itself, maybe that is the end for my MK3?
Reply With Quote
  #7  
Old 06-04-2007, 09:52 AM
lmxu lmxu is offline
Registered User
Location: tysons corner va
 
Join Date: Jan 2006
Posts: 46
Mein Auto: 2000 740 IL
Recently, when my battery was about to go dead, that happened to me, very strange, but after I replaced it with a new Duralast, everything is fine again. just wanne throw it out here.
Reply With Quote
  #8  
Old 06-04-2007, 12:10 PM
taylorb taylorb is offline
Registered User
Location: Central Arkansas
 
Join Date: Jun 2007
Posts: 7
Mein Auto: BMW 05 X5
The same thing has been going on with our 2000 740il. First we noticed something when the navigation screen wouldn't come on and the time would freeze, but now the navigation doesn't come on at all and the radio cuts out at exactly 2 minutes. So the problem is the battery?
Reply With Quote
  #9  
Old 06-11-2007, 05:19 AM
Wader2 Wader2 is offline
Registered User
Location: Simpsonville, SC
 
Join Date: May 2007
Posts: 2
Mein Auto: 2000 740il
Update:

First off, thanks for all the information from everyone. I finally got a chance on friday and replaced the battery but no success. Still having the same issue.......
Reply With Quote
  #10  
Old 06-12-2007, 09:11 PM
98740il 98740il is offline
King Of M740il
Location: Memphis
 
Join Date: Feb 2007
Posts: 131
Send a message via Yahoo to 98740il
Mein Auto: BMW 740IL
Talking

Quote:
Originally Posted by Wader2 View Post
First off, thanks for all the information from everyone. I finally got a chance on friday and replaced the battery but no success. Still having the same issue.......
GOOD THING I GOT A 98 740IL LATE MODEL
__________________
$hittin clean out the Dinan cut outs out 840i,750il,740il,625i,525i,325i
Squattin on (Old Body)2002i
Reply With Quote
  #11  
Old 06-13-2007, 07:02 PM
bimmernav bimmernav is offline
Past Sponsor
Location: Austin, Tx
 
Join Date: May 2007
Posts: 48
Mein Auto: BMW
Since the battery did not fix your issue, which it typically does... The issue could be with either the nav computer or the radio.

What I did in my 01 was upgrade both in order to be SAT ready, Aux input ready, and MP3 CD changer ready.

Here is how to change the radio
Upgrading the E38/E39 to new style Radio
Reply With Quote
  #12  
Old 06-25-2007, 08:08 AM
f4y f4y is offline
Registered User
Location: Aiken, SC
 
Join Date: Jun 2007
Posts: 5
Mein Auto: 2000 BMW 740il
Angry 2000 740il-- same problem

My battery went dead months before this problem occurred. I have a new battery and have same issue with the radio and the screen. I thought it was water from the trunk that might have gotten into the navigation cd-rom, but I attempted to eject it, and got no response. The "on" light is not on, and the cd did not eject. I have checked my fuses; I dont see any blown under the hood. BMW even could not figure the problem, but they charged a nice diagnostic fee... (
Quote:
Originally Posted by Wader2 View Post
First off, thanks for all the information from everyone. I finally got a chance on friday and replaced the battery but no success. Still having the same issue.......
Reply With Quote
  #13  
Old 06-25-2007, 08:18 AM
f4y f4y is offline
Registered User
Location: Aiken, SC
 
Join Date: Jun 2007
Posts: 5
Mein Auto: 2000 BMW 740il
Unhappy radio/ navigation problem

my screen freezes also, sometimes is grey with lines, sometimes with display, but my radio goes off after about 2 minutes also. Have a new battery, which was installed prior to this problem, and came from BMW dealer parts dept. My second thought was the navigation cd with water in it from opening trunk since it is just below the canal for the trunk lid. Cannot eject navigation disc from trunk; no "on" light illuminated. Thinking this is the problem for sure, but don't know what to do... can u help? Checked the fuses under the hood, didn't see any that were blown... BMW dealer no help--charged for diagnostic testing, but found nothing.
Hatin that I bought this car...
Reply With Quote
  #14  
Old 06-25-2007, 08:53 AM
Jerry 745Li Jerry 745Li is offline
Officially Welcomed to the 'Fest
Location: Limerick, PA
 
Join Date: Jun 2007
Posts: 436
Mein Auto: 03' 745Li & 12' Hybrid7
Update your firmware!

My brother-in-law's 00' 740Li had the same issues. I simply downloaded the latest NAV firmware, burned it to a CD, updated and not a problem since. I found out about the NAV updates on X5world. Simpy goto their web site and search for NAV Update. First hit will be a thread on version 29.1. All the info is there to upgrade the NAV firmware. Try it out.

Jer
Reply With Quote
  #15  
Old 06-25-2007, 09:00 AM
crewdog843's Avatar
crewdog843 crewdog843 is offline
Officially Welcomed to the 'Fest
Location: Las Vegas, NV
 
Join Date: Mar 2006
Posts: 672
Mein Auto: '08 Z4 3.0si Roadie
Don't know if this is going to help or not, but it's worth a try.

I was having problems with my nav screen ('01 740i CD based NAV), where the screen morphed from its normal colors to a muddy brown color. I depressed the tape button, causing the NAV screen to swing out and then reached behind the screen feeling for the wire which I knew was back there somewhere. Finding it (blindly) I followed it to the connector, and simply reseated it.

Problem solved. No more color changes.

In any machine, vibrations can easily cause connectors to unseat as I learned from many years aboard large four engine aircraft filled with arcane radio equipment. We called it "brogan maintenance"....unseat and reseat, and 98% of the time, the problem just went away.

Try it, it might just work.

jake

PS: Since everything is controlled from that screen, or the buttons on it, this would normally have been my first step, which it was, and it solved everything.
__________________
Reply With Quote
  #16  
Old 06-25-2007, 03:09 PM
crewdog843's Avatar
crewdog843 crewdog843 is offline
Officially Welcomed to the 'Fest
Location: Las Vegas, NV
 
Join Date: Mar 2006
Posts: 672
Mein Auto: '08 Z4 3.0si Roadie
I might also add, do not pull the plug out, as it will be difficult to re-insert. Simply wiggle it from side to side, and then push it firmly back into the seat. Should do it.

jake
__________________
Reply With Quote
  #17  
Old 06-25-2007, 07:21 PM
f4y f4y is offline
Registered User
Location: Aiken, SC
 
Join Date: Jun 2007
Posts: 5
Mein Auto: 2000 BMW 740il
can't get the nav cd out

Thanx, I have a 2003 Nav cd in there; no power light on in the trunk where the cd is; it won't even eject the old one to place a new one in it...
Reply With Quote
  #18  
Old 06-25-2007, 07:24 PM
f4y f4y is offline
Registered User
Location: Aiken, SC
 
Join Date: Jun 2007
Posts: 5
Mein Auto: 2000 BMW 740il
remove which part of the dash to get to the wire?

I don't understand how to get to the wire
Reply With Quote
  #19  
Old 06-25-2007, 10:13 PM
crewdog843's Avatar
crewdog843 crewdog843 is offline
Officially Welcomed to the 'Fest
Location: Las Vegas, NV
 
Join Date: Mar 2006
Posts: 672
Mein Auto: '08 Z4 3.0si Roadie
On the 2001 and earlier models, if you select the tape deck (instead of radio or cd), the nav screen will swing out exposing the tape deck behind. If you reach behind the nav screen while the screen is slanted forward, you will be able to feel the wire which connects the screen to the cars electrical system. Follow the wire with your fingers below the tape deck and you will feel a connector....this is the one which you should wiggle around, left to right, right to left, and then give a firm push forward to seat it firmly. It is a male connector, into a female receptacle.

I know that once I reseated mine, I have never had another problem with the nav screen changing colors. As stated in a previous post, I learned this trick from my flying assignments with the USAF. Something else that helps, is a spray contact cleaner, but I don't think one will be able to get to the female receptacle without removing the nav screen. I remember taking the car to BMW, and they looked up the price of a new nav screen, because I thought that was what I would have to do, replace the screen. It was prohibitive. The solution came to me after that, and was a 'what have I got to lose' type solution,......and it worked.
__________________
Reply With Quote
  #20  
Old 06-25-2007, 10:20 PM
crewdog843's Avatar
crewdog843 crewdog843 is offline
Officially Welcomed to the 'Fest
Location: Las Vegas, NV
 
Join Date: Mar 2006
Posts: 672
Mein Auto: '08 Z4 3.0si Roadie
f4v: I just noticed you are in Aiken....my brother lives in Aiken...out at Cedar Creek. Maybe you are familiar with it. He lives off Veranda Lane. Has been known to visit the ABC from time to time (Aiken Brewing Company). Great little town, have spent a lot of pleasant hours there.

jake
__________________
Reply With Quote
  #21  
Old 07-03-2007, 01:39 PM
willbodnar willbodnar is offline
Registered User
Location: Pennsylvania
 
Join Date: Jul 2007
Posts: 1
Mein Auto: 2000 740iL
I'm having the same problem that everyone else is describing. I have an unilluminated power button on the navigation system in the trunk, the cd will not eject from said navigation system. My nav screen in the front is black and will not turn on and the power to the radio/cd/tape deck shuts off every few minutes.

I bought the car from my friend, who is a dealer, a few weeks back. He got it at the auction for me at a beautiful price, but with the knowledge that the nav was having problems. I've been trying to troubleshoot this problem without going to the dealer (stealer) and having them give me no real answers. My dealer friend's mechanic messed with it and found that there was no power getting to the front screen or the system in the trunk. I have yet to check the voltage on the battery, but from other's posts it doesn't seem like that will remedy my problem. The mechanic called my local bimmer dealer and also confirmed there was a TSB Recall on a retrofit cable for the nav, but my warranty is expired and the service manager told me that recall had been completed. When my mechanic called BMW they told him I may be able to get a recalibration done that should fix it, yet the service manager at BMW told me she never heard of such a thing even though someone from her service dept relayed that to my mechanic the day before (figures).

So she has suggested a diagnostic test, 1 hr labor/$93, but it seems that from previous posts this may simply be a waste.

Opinions requested....Should I pay for the diagnostic and keep my fingers crossed or just buy a new widescreen nav screen and an MKIV?

Any thoughts or experiences would be greatly appreciated.
Reply With Quote
  #22  
Old 08-15-2007, 07:45 AM
345ls1 345ls1 is offline
Registered User
Location: Richmond, VA
 
Join Date: Aug 2007
Posts: 3
Mein Auto: 2000 740IL
I am having same problem with 2000 740IL. I have a new battery before this started, is the loose connector the answer?
Reply With Quote
  #23  
Old 10-15-2007, 10:08 AM
bmwmercedes2 bmwmercedes2 is offline
Registered User
Location: kissimmee,fl
 
Join Date: Oct 2007
Posts: 1
Mein Auto: 540i
Radio problem

Quote:
Originally Posted by Wader2 View Post
I'm new to the forum and I've recently purchased a 2000 740il w/nav. My first BMW and an incredible car. However, from time to time the radio/CD will just cut off. In addition the display will freeze. You can manually turn the radio/CD back on but it will cut back off in about 1-2 min.. The display will stay frozen. Everything will reset when you shut the car off and back on. Any thoughts will be greatly appreciated. Thanks
Let me ask you, how is the instrument cluster, can you see all the numbers or letters? and the reason is because the radio and instrument cluster comunicate with each other, you might have to take the car to a BMW delaer for diagnostic, if the instrument cluster is bad that will solve the radio problem. I work on BMW for almost 4 years and we had that problem before and you must remember that the instrument cluster has to be installed with the GT1 BMW scan tool.( cluster is married to the car and can not be use on another vehicle.

Bobby.
Reply With Quote
  #24  
Old 12-06-2007, 05:04 AM
nompbsd nompbsd is offline
Registered User
Location: baton rouge, la
 
Join Date: Dec 2007
Posts: 34
Mein Auto: 2001 740il 2003 745Li
radio problems

so guys, what was the problem that you found with the radio and navi cutting off? I'm haveing these issues now.....Help.....
Reply With Quote
  #25  
Old 12-21-2007, 08:32 AM
jcollier jcollier is offline
Registered User
Location: Birmingham, Alabama
 
Join Date: Nov 2007
Posts: 7
Mein Auto: 740il
Posted this in another thread... but was having all the same problems... Here's what I did and it's been working fine for about a week with no problems.

I cut off the car and waited ~ 2 minutes then disconnected the battery. (at the time, the nav light was never on).. When I reconnected the battery I also pressed the eject button on the nav at the same time- the light on the nav unit came on when reconnected ... the disc popped out .. after securing the battery terminal I re-inserted the disc.... All systems back to normal.... did this last Saturday and have had no problems all week.... Not to say, this want happen again... but hopefully this solved my problem. My son (the computer nerd) thinks the nav was not re-booting properly with the disc in the unit.. My battery is holding 12.6 volts... so I know it's good..
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E38 (1995 - 2001)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Forum Jump


All times are GMT -7. The time now is 12:17 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms