Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 06-30-2007, 10:23 PM
timbot80 timbot80 is offline
Officially Welcomed to the 'Fest
Location: Richmond, CA
 
Join Date: Apr 2006
Posts: 107
Mein Auto: 2003 530I
windshield washer sprayer not working??

I know it has fluid its pretty crazy cuz the headlight sprayer goes off but not the windshield ones.??
Does anyone have a cule??
Thanks fellow e39'ers
__________________
" Pain is just proof that you're still alive"
'03 530I A/Sport _Slate Green/Black_w/ Navi
Reply With Quote
Ads by Google
  #2  
Old 07-01-2007, 03:47 AM
CMWalker CMWalker is offline
Registered User
Location: Janesville, Wisconsin
 
Join Date: Mar 2004
Posts: 94
Mein Auto: 99 M Coupe, 02 530i
There are two separate reservoirs. One for the intensive headlight wash. One for the windshield.

I think.
Reply With Quote
  #3  
Old 07-01-2007, 12:21 PM
528JD's Avatar
528JD 528JD is offline
Migrated to the X5 SAV
Location: North of Ann Arbor, MI
 
Join Date: May 2007
Posts: 861
Mein Auto: '07 X5, '00 528i
Correct, there are two reservoirs. The windshield one is next to the shock tower.

Could the nozzles be clogged, maybe post waxing?

a small push-pin should be small enough to open up the holes.
Reply With Quote
  #4  
Old 07-01-2007, 02:02 PM
KeithS KeithS is offline
Officially Welcomed to the 'Fest
Location: Central NJ
 
Join Date: Dec 2001
Posts: 1,614
Mein Auto: '11 335d, '00 540iT
Just had the pump go bad on mine

Just had the pump go bad on mine. Do you hear any buzzing when you activate the sprayer? If not pump may be bad, about $40.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 08:16 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms