Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 09-20-2007, 12:29 AM
Phat2000 Phat2000 is offline
Registered User
Location: Los Angeles, CA
 
Join Date: Sep 2007
Posts: 22
Mein Auto: 2000 540i
Bad Volume Knob on Radio - Need Fix

2000 540i - Stereo W/Navigation: Hoping for simple solution to replace knob without having to replace the whole unit. According to the dealer the knob is part of an assembly and is not repairable otherwise. They price the job at about $600, which is not going to happen. Any suggestions?
Reply With Quote
Ads by Google
  #2  
Old 09-20-2007, 12:28 PM
michelinman michelinman is offline
Registered User
Location: Toronto, Canada
 
Join Date: Nov 2005
Posts: 27
Mein Auto: 540ia
Do you have problem with the volume knob not turning the volume up/down? Had that problem with mine and thats because I tend to most of the time, use the steering wheel volume controls instead of the one on the radio. The volume knob electrical contacts were not making after not being moved for a long time and to "fix" that, I turned the volume knob up and down quickly several times until the knob works ok.
I just have to remember to use the volume knob on the radio unit once in a while to prevent the same problem from reoccuring and its been good since.
__________________
2000 540iA Cosmo Black, Sport Pkg, Premium Pkg, DSP, CD changer
Reply With Quote
  #3  
Old 09-20-2007, 01:23 PM
bimmerd00d's Avatar
bimmerd00d bimmerd00d is offline
just havin a heart attack
Location: Little Elm, TX
 
Join Date: Aug 2005
Posts: 2,732
Send a message via AIM to bimmerd00d Send a message via MSN to bimmerd00d Send a message via Yahoo to bimmerd00d
Mein Auto: 1998 540i 6-speed
www.bmaparts.com

you need part #65828372162, $3.79. I believe the standard knobs from the regular MID are the same ones. I am not certain of this, but from looking at them in person they look the same to me. If not, you could probably make it fit at $3.79

Here is another option, if you look at a widescreen nav unit, you can buy the knobs individually, they look the same to me. part number #65528385458

http://www.realoem.com/bmw/showparts...92&hg=65&fg=45
__________________
(as of 11/18/11)
2004 Volvo S60R - The new ride!
1998 540i 6-spd. - Sold!
2000 528iA sport - Mom's ride, 308k!!!! and still drives like new
2005 Dodge Ram 2500 Cummins - 145k, 800lb/ft. John Coal Train.
2001 Volvo C70 Coupe T5 - The wife's car, 170k. Needs a timing belt soon
Reply With Quote
  #4  
Old 09-20-2007, 07:44 PM
Phat2000 Phat2000 is offline
Registered User
Location: Los Angeles, CA
 
Join Date: Sep 2007
Posts: 22
Mein Auto: 2000 540i
Thanks for the info. Contacted Dealer with part no. you provided and as it turns out it's a simple and inexpensive fix. Dealer cost for part is less $10. The cost was originally misquoted because they assumed I was using a different stereo unit. Thanks again!
Reply With Quote
  #5  
Old 09-21-2007, 05:44 AM
bimmerd00d's Avatar
bimmerd00d bimmerd00d is offline
just havin a heart attack
Location: Little Elm, TX
 
Join Date: Aug 2005
Posts: 2,732
Send a message via AIM to bimmerd00d Send a message via MSN to bimmerd00d Send a message via Yahoo to bimmerd00d
Mein Auto: 1998 540i 6-speed
Quote:
Originally Posted by Phat2000 View Post
Thanks for the info. Contacted Dealer with part no. you provided and as it turns out it's a simple and inexpensive fix. Dealer cost for part is less $10. The cost was originally misquoted because they assumed I was using a different stereo unit. Thanks again!
awesome, glad i could help!
__________________
(as of 11/18/11)
2004 Volvo S60R - The new ride!
1998 540i 6-spd. - Sold!
2000 528iA sport - Mom's ride, 308k!!!! and still drives like new
2005 Dodge Ram 2500 Cummins - 145k, 800lb/ft. John Coal Train.
2001 Volvo C70 Coupe T5 - The wife's car, 170k. Needs a timing belt soon
Reply With Quote
  #6  
Old 09-21-2007, 11:18 PM
hosnimax hosnimax is offline
Registered User
Location: Oman-Muscat
 
Join Date: Sep 2005
Posts: 4
Mein Auto: M3 2003 and 528iA 1997
intersting information thanks


Max
Reply With Quote
  #7  
Old 09-22-2007, 01:55 PM
Phat2000 Phat2000 is offline
Registered User
Location: Los Angeles, CA
 
Join Date: Sep 2007
Posts: 22
Mein Auto: 2000 540i
Interesting. Quickly turned knobs up & down frew times as suggested by "Michelinman" above, and it seems to have done the trick! Original problem with knob was that when I turned the knob, the volume was erratic and would go extremely high or low... basically uncontrolled and annoying. I too very rarely used volume control on radio deferring to the steering wheel control. Thanks again!
Reply With Quote
  #8  
Old 09-28-2007, 12:49 PM
aiyagari aiyagari is offline
Registered User
Location: Sunnyvale, CA
 
Join Date: Sep 2007
Posts: 1
Mein Auto: 2003 330i Performance Pkg
Thumbs up Thanks, got it from Pelican

I have the same problem, but even worse -- the knob's volume function came back when I used the suggestion above (turn it back and forth quickly), but the on-off function (pressing the knob in) is not working properly -- you have to push the knob in really hard because the rubber springy action seems to have gotten spoiled. Dealer wants $900 to install new stereo -- ridiculous. Real OEM found me the part number, but their shopping cart is not working; went to Pelican Parts and ordered from there, should be coming in a couple of weeks. Thanks again for the info on how to find BMW part numbers. Even with shipping it will only be $15.
Reply With Quote
  #9  
Old 12-13-2007, 12:52 AM
refimail refimail is offline
Registered User
Location: California
 
Join Date: Oct 2004
Posts: 72
Mein Auto: 2003 325i
Quote:
Originally Posted by aiyagari View Post
I have the same problem, but even worse -- the knob's volume function came back when I used the suggestion above (turn it back and forth quickly), but the on-off function (pressing the knob in) is not working properly -- you have to push the knob in really hard because the rubber springy action seems to have gotten spoiled. Dealer wants $900 to install new stereo -- ridiculous. Real OEM found me the part number, but their shopping cart is not working; went to Pelican Parts and ordered from there, should be coming in a couple of weeks. Thanks again for the info on how to find BMW part numbers. Even with shipping it will only be $15.
aiyagari,
I recently ran into the same problem with my E46 radio (I had to press the volume knob hard to turn on/off the radio). I noticed that I could make the knob wobble slightly on its axis. I removed the head unit from the dash and, looking inside the housing just behind the radio knob, I noticed that the plastic white piece that held the tiny circuit board assembly, behind the radio knob, broke off from the mating surface of the inner part of the clear plastic faceplate. I carefully realigned and Super glued them back together, using a fine-tip pen dispenser, and haven't had a problem so far.
Reply With Quote
  #10  
Old 12-13-2007, 06:32 AM
Jase007 Jase007 is offline
Wrenchin' fool ...
Location: nova
 
Join Date: Jun 2004
Posts: 762
Mein Auto: e39 528it
I checked the part numbers provided above:

65828372162
65528385458

.. and these are for the radio button only. I'm not saying the rotating volume control quickly doesn't work but that I think the problem is with the actual on / volume mechanism. Lack of use may allow corrosion on the internal contacts and movement corrects but ... eventually I think it will fail again.

I have a similar volume problem but my actual problem is the on/off / volume mechanism IN the MID. These seem to be cheaply made as I have two MIDs and each has axial play [remove button and manipulate post]. On one of my MIDs I can actually apply slight axial pressure and it will turn radio on and / or off. Something internal where the post rotates to change volume shorts and radio power is cut. Typically, you'd have to push button / post in against detent to make this happen.

Will be opening opening mine up like refimail to investigate and will let you'll know if interested.
__________________
Jason

2000 528iT Sport 5M (mfg. 5/1999) ~ 1990 325iX 5M
BMW CCA member #130075
JScottRacing
Reply With Quote
  #11  
Old 12-13-2007, 02:17 PM
bimmerd00d's Avatar
bimmerd00d bimmerd00d is offline
just havin a heart attack
Location: Little Elm, TX
 
Join Date: Aug 2005
Posts: 2,732
Send a message via AIM to bimmerd00d Send a message via MSN to bimmerd00d Send a message via Yahoo to bimmerd00d
Mein Auto: 1998 540i 6-speed
If your pixels are dying on them, the dealer will replace this under the same warranty repair as the Instrument Cluster pixel issue. BMW of Dallas did for me at least, I had an E90 330i for a week while they located and installed the piece!
__________________
(as of 11/18/11)
2004 Volvo S60R - The new ride!
1998 540i 6-spd. - Sold!
2000 528iA sport - Mom's ride, 308k!!!! and still drives like new
2005 Dodge Ram 2500 Cummins - 145k, 800lb/ft. John Coal Train.
2001 Volvo C70 Coupe T5 - The wife's car, 170k. Needs a timing belt soon
Reply With Quote
  #12  
Old 05-06-2008, 11:53 AM
rockfish66 rockfish66 is offline
Officially Welcomed to the 'Fest
Location: NY, NY
 
Join Date: Nov 2003
Posts: 87
Mein Auto: '93 325is
Sorry to wake a sleeping thread, but...

I have an '03 325i with the Business CD and I had the fussy operation and "axial play" of the volume/on-off knob mentioned above.
Yesterday, the knob stopped working completely. It spins freely on its axis without changing the volume, and will not push-in to turn off the radio. If I pull the knob out slightly it seems to re-engage and I am able to change the volume, but if I try to push it in to turn off the radio it just "gives" with no resistance and bottoms out.

I have 2 questions:

1) If I buy the knob and try to replace it, how do I get the old one off? Do I just pull it off?

2) If it turns out out I need to get into the radio to do some glue-ing, is there a DIY posted on taking out the radio?

Thanks in advance.
__________________
_________________
(oo-00-oo)
'03 325i, '93 325is
Reply With Quote
  #13  
Old 05-14-2008, 11:06 AM
refimail refimail is offline
Registered User
Location: California
 
Join Date: Oct 2004
Posts: 72
Mein Auto: 2003 325i
Quote:
Originally Posted by rockfish66 View Post
I have 2 questions:

1) If I buy the knob and try to replace it, how do I get the old one off? Do I just pull it off?

2) If it turns out out I need to get into the radio to do some glue-ing, is there a DIY posted on taking out the radio?

Thanks in advance.
I had the same problem. You can pull the knob straight out and check for stripped threads. My radio knob was fine.

Look for the DIY to remove the dash trim and radio. Look for my post above and check if the knob's small circuit board is securely attached to the clear plastic inner faceplate. If not, Superglue them back together. Good luck.

Last edited by refimail; 05-14-2008 at 11:09 AM.
Reply With Quote
  #14  
Old 08-02-2008, 10:35 AM
blogger247 blogger247 is offline
Registered User
Location: UK
 
Join Date: Aug 2008
Posts: 1
Mein Auto: BMW 330CI
Stereo keeps loosing sound

Hi i thought my stereo had the same fault as above but it doesn't seem the case.

I have a 330 with the screen sat nav stereo and the sound keeps cutting out with no real ryme or reason. I have taken the head unit out to look at the volume knob but that seemed fine. When the stereo was out i drove the car and the cd was playing fine and then cut out as per usual so i think im right in assuming that is not the issue. When the sat nav is on the instructions come out loud and clear even when the stereo cuts out.

Any ideas would be great.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 12:58 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms