Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E36/7 Z3 (1996-2002)

E36/7 Z3 (1996-2002)
E36/7 Z3 Roadster, Z3 coupe, Z3 M Roadster and Z3 M Coupe talk with our gurus here.

Reply
 
Thread Tools Display Modes
  #1  
Old 02-19-2008, 08:33 AM
NJ-Eric NJ-Eric is offline
Registered User
Location: Texas, USA
 
Join Date: Oct 2007
Posts: 53
Mein Auto: Z4 Coupe
Z4: Problems with the Z4...

First off, my intention is not to start a complaint thread. I'm just wondering whether there are any known problems that are common to the Z4.

To start, my 2007 left me stranded this past weekend with 3000 miles on the odometer. It turns out that my alternator went south. In addition my BMW Assist system was disconnected (from the very start, it has never worked) and the dash panel that holds the aux input jack was loose.

The latter problems are very minor and I knew about them. I just didn't have the time to have my dealer sort them out yet. I was quite surprised by the alternator though.

Any other things w/ the Z4 to look out for? I'm guessing that I was simply unlucky w/ the alternator issue.

Thanks.

-Eric
__________________

2007 Z4 Coupe, premium, sport, x-leather, M-seats
Reply With Quote
Advertisement
  #2  
Old 02-19-2008, 08:36 AM
pal's Avatar
pal pal is offline
S54=Living on the Edge
Location: New Jersey
 
Join Date: Nov 2007
Posts: 1,486
Mein Auto: 2007 M Coupe, 2004 Audi T
My dealer told me to click the BMW assist 24 hrs after delivery and that is when BMW NA initializes the system with your info etc. What dealer did you get it from?

As far as the alternator, I think I have heard one other case here Re: that ... possibly a bad batch??

The Aux input panel was/is loose on my Z4M as well ... it does not rattle and does not fall off so I am not bringing it to the dealer.
Reply With Quote
  #3  
Old 02-19-2008, 12:26 PM
gotoschoolhere's Avatar
gotoschoolhere gotoschoolhere is offline
Officially Welcomed to the 'Fest
Location: Los Angeles
 
Join Date: Jul 2007
Posts: 1,344
Mein Auto: Z4 Roadster 35i
Sorry to hear about your problems, but I think you may be an isolated case. I have some quirks with mine and when the 1,200 miles check up rolls around, I'll have them corrected but nothing major.

You local BMW center should remedy the situation. Nothing to loose sleep over. I know it is hard when it is your car.
__________________
Omar Sayyed
Operational Intelligence <-- What I do
Reply With Quote
  #4  
Old 02-19-2008, 12:36 PM
NJ-Eric NJ-Eric is offline
Registered User
Location: Texas, USA
 
Join Date: Oct 2007
Posts: 53
Mein Auto: Z4 Coupe
Thanks for the replies. I'm glad that it's an isolated problem. The car has been tremendous fun, otherwise.

Pal, I remember you from the Audi board. I hope that your M is everything that you hoped it would be. I don't miss my TT at all handling wise. However, in the wet the TT is very hard to beat. I'm sure that you've come to that conclusion also... I haven't dared to drive in the snow.

-Eric
__________________

2007 Z4 Coupe, premium, sport, x-leather, M-seats
Reply With Quote
  #5  
Old 02-19-2008, 12:41 PM
Hawkeye16 Hawkeye16 is offline
Officially Welcomed to the 'Fest
Location: Iowa
 
Join Date: Aug 2007
Posts: 125
Mein Auto: Kawasaki ZX-7R
I haven't heard of any alternator problems like that either. My dash Aux panel wiggles but like pal said, it doesn't rattle so I am cool with it.

I would definitely get the BMW Assist hooked up though, just incase it is a nice feature to have in emergencies.
__________________
2007 Z4 3.0si Coupe / 6MT / Black Metallic Saphire / Premium Package / Sport Package / M Seats / Heated Seats
2008 Yamaha R6 / Raven / Fender Eliminator / Shaved Blinkers / GPR v4
2008 Nissan Titan XE / KC / Long Bed / Line-x
Reply With Quote
  #6  
Old 02-19-2008, 02:33 PM
PaulGT3 PaulGT3 is offline
Officially Welcomed to the 'Fest
Location: Mammoth
 
Join Date: Nov 2007
Posts: 115
Mein Auto: 07 GT3,07 Z4M
Main problem is wife wont let me drive it.
__________________

2007 Z4 M Coupe
2006 X5 4.8is
2007 Porsche GT3
Reply With Quote
  #7  
Old 02-19-2008, 02:36 PM
pal's Avatar
pal pal is offline
S54=Living on the Edge
Location: New Jersey
 
Join Date: Nov 2007
Posts: 1,486
Mein Auto: 2007 M Coupe, 2004 Audi T
Quote:
Originally Posted by NJ-Eric View Post
Pal, I remember you from the Audi board. I hope that your M is everything that you hoped it would be. I don't miss my TT at all handling wise. However, in the wet the TT is very hard to beat. I'm sure that you've come to that conclusion also... I haven't dared to drive in the snow.

-Eric
I have about 6200 miles on the MC since I got it back in Oct/Nov of last year and I have to admit that the chassis is very well sorted. While I do miss the 225 TT whenever I see one on the road, I forget about it the moment I am behind the wheel of the M. Am planning on doing a few track events with the MC starting as soon as March so lets see how I feel after that.

Last week I drove home (35 mi) during that snow storm we had and the M was not bad at all with the Pirelli Snowsport 210 tires ... the traction control light did not even kick in- I was driving 40-50 mph on the turnpike and 287. Though not as confidence inspiring as the TT, I was nevertheless impressed.
Reply With Quote
  #8  
Old 02-19-2008, 05:05 PM
NJ-Eric NJ-Eric is offline
Registered User
Location: Texas, USA
 
Join Date: Oct 2007
Posts: 53
Mein Auto: Z4 Coupe
This just in: It appears now that I have DME problems.

I was wondering about how it could have been the alternator when - according to my measurements - the battery resting (open circuit) voltage was exactly 12.65 and with the engine running the system voltage was 14.3, meaning it was charging.

I told them that it seemed very much like a relay or solenoid problem, but they insisted it was the alternator. Now with that replaced, the car still isn't right. It was probably the DME all along!

I guess we'll see on tomorrow... or the next day....

-Eric
__________________

2007 Z4 Coupe, premium, sport, x-leather, M-seats
Reply With Quote
  #9  
Old 02-20-2008, 05:56 AM
pal's Avatar
pal pal is offline
S54=Living on the Edge
Location: New Jersey
 
Join Date: Nov 2007
Posts: 1,486
Mein Auto: 2007 M Coupe, 2004 Audi T
Sorry to hear that Eric ... I hope they fix it right soon.

What dealer are you taking it to?
Reply With Quote
  #10  
Old 02-20-2008, 06:05 AM
da geez's Avatar
da geez da geez is offline
Escape Artist®
Location: Nebulous
 
Join Date: Nov 2007
Posts: 616
Mein Auto: MY 07 M Coupe
My Coupe has been problem free. By coincidence, I'm another former TT owner - 2002 ALMS.

By an even greater coincidence, I met the present owner of my old TT (I sold it to Carmx) and she hates the reliability. I understand it suffers from all sorts of electrical problems.

Good luck sorting out your Coupe.
__________________
Telepath wanted: you know where to apply.



2007 Interlagos Blue M Coupe
2004 325i and I'm not sure what color it is except for dark silver.
Reply With Quote
  #11  
Old 02-20-2008, 07:02 AM
NJ-Eric NJ-Eric is offline
Registered User
Location: Texas, USA
 
Join Date: Oct 2007
Posts: 53
Mein Auto: Z4 Coupe
Thanks, all.

Pal, I go to Open Road BMW in Edison, NJ for my service needs. It's a bit of a tight location out on Route 1, but it's convenient. They seem to be a bunch of great folks - really professional, attentive and personable.

With my previous 2 Audis, I went to Bell Audi in Rahway. I never liked leaving my car there... and they always seemed to find a way to put small dents in my doors. Seriously, it was like someone there had a BB rifle and made it their business to "ping" your door before it left their shop. The good thing about Bell Audi is that it's close to rail station into Manhattan.

Yes, Mr. Geez Audi electricals tended to be very problematic. My 2001 TT had thewhole host of "usual" problems. My 2002 was trouble free right up to a week prior to my warranty running out: My gas guage went down to empty on a full tank (the dreaded fuel sender unit problem) and I knew that the car had to go. I got it repaired and fully sorted out under warranty and traded right away for the Z4. Not having the TT out of wrranty is a serious load off of my mind.

Pal, did you join BMW CCA? I really need to address or look into the driving schools and track days scheduled for this year. Also, do you plan on attending any of the NJ Chapter meetings in Clark, NJ? I don't know, but something about seeing pictures of the club members standing around in lederhosen kind of makes me wonder...

-Eric
__________________

2007 Z4 Coupe, premium, sport, x-leather, M-seats
Reply With Quote
  #12  
Old 02-20-2008, 07:23 AM
pal's Avatar
pal pal is offline
S54=Living on the Edge
Location: New Jersey
 
Join Date: Nov 2007
Posts: 1,486
Mein Auto: 2007 M Coupe, 2004 Audi T
Eric- I used to go to Bell Audi but found their techs to be a bunch of idiots so started going to Bernardsville Audi and they were great.

I had a bad Sales experience at Open Road Edison so decided to not go there and ended up buying my MC at Denville BMW. I had the 1200 mile service there as well. Sales was awesome and the salesperson actually came to my house to do the paperwork as I was real busy at work ... no opinion on the Service yet; will see when I have the first problem.

I have not joined BMWCCA yet and still hang with the local VW/Audi crowd ... as for track events, I plan to go with PDA and TrackDaze for various events and possible with ACNA for Mount Tremblant in the Fall.

My 2002 TT had some electrical issues- cluster, ECU but the 2004 was pretty good after the DSG mechatronic was replaced at 22K miles. Both the cars were tracked a lot and modded but I found that the 225 was a much better car overall- more satisfying as it was lighter and much better balanced than the 3.2. The latter was fun due to the motor and trans combination.

The M Coupe is starting to develop some creaks, but that is expected of a sports coupe ...
Reply With Quote
  #13  
Old 02-20-2008, 07:42 AM
da geez's Avatar
da geez da geez is offline
Escape Artist®
Location: Nebulous
 
Join Date: Nov 2007
Posts: 616
Mein Auto: MY 07 M Coupe
To be fair, I did have two minor problems. The LED in the hatch never worked from the first day. I ended up getting pulled over for that and had it repaired straight away. Also, the support struts (certainly they are not tower struts - but what?) were never tightened. They're tight now.

So far, nothing else, but I'm wondering what else lurks.
__________________
Telepath wanted: you know where to apply.



2007 Interlagos Blue M Coupe
2004 325i and I'm not sure what color it is except for dark silver.

Last edited by da geez; 02-20-2008 at 07:46 AM.
Reply With Quote
  #14  
Old 02-21-2008, 05:10 PM
NJ-Eric NJ-Eric is offline
Registered User
Location: Texas, USA
 
Join Date: Oct 2007
Posts: 53
Mein Auto: Z4 Coupe
I doubt that anyone is still tracking this thread, but I am still waiting to have a new DME module installed in my Z4. That's five days idle starting tomorrow... and the big snow starts tonight. If the car is actually repaired this weekend, I would rather not drive it home from the dealer.

Oh well. I'm sure that the vast majority of Z4s will not suffer this sort of electronic failure.

-Eric
__________________

2007 Z4 Coupe, premium, sport, x-leather, M-seats
Reply With Quote
  #15  
Old 02-21-2008, 06:00 PM
gotoschoolhere's Avatar
gotoschoolhere gotoschoolhere is offline
Officially Welcomed to the 'Fest
Location: Los Angeles
 
Join Date: Jul 2007
Posts: 1,344
Mein Auto: Z4 Roadster 35i
Quote:
Originally Posted by PaulGT3 View Post
Main problem is wife wont let me drive it.
Just like a typical guy... Here is a guy with a GT3 but still wants to drive his wife's car around. Would you let her drive your car.
__________________
Omar Sayyed
Operational Intelligence <-- What I do
Reply With Quote
  #16  
Old 02-22-2008, 11:31 AM
PaulGT3 PaulGT3 is offline
Officially Welcomed to the 'Fest
Location: Mammoth
 
Join Date: Nov 2007
Posts: 115
Mein Auto: 07 GT3,07 Z4M
I love her car. its very much what a classic sports car is supposed to be.
The GT3 is a great car and the Z4 is as close as you can get for the money.
in fact I turned down the Cayman S in favor of the Z4. Its that good!!
__________________

2007 Z4 M Coupe
2006 X5 4.8is
2007 Porsche GT3
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E36/7 Z3 (1996-2002)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 08:15 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms