Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E28 (1982 - 1988)

E28 (1982 - 1988)

Reply
 
Thread Tools Display Modes
  #1  
Old 02-13-2010, 04:19 PM
jvaughn21 jvaughn21 is offline
Registered User
Location: Kansas
 
Join Date: Oct 2008
Posts: 29
Mein Auto: 1988 E28
Oil Light

Does anyone know why my oil light flickers when the car is idling? Oil level is fine.
Reply With Quote
Advertisement
  #2  
Old 02-14-2010, 04:45 AM
south26 south26 is offline
Officially Welcomed to the 'Fest
Location: Dayton, OH
 
Join Date: May 2009
Posts: 787
Mein Auto: 535i 1989
The question is how many miles and do you have a 528e?

It could be that you have a worn out engine that needs the bearings replaced and the oil pump, or your oil pressure switch is going bad.

Andy
Reply With Quote
  #3  
Old 02-14-2010, 08:09 AM
jvaughn21 jvaughn21 is offline
Registered User
Location: Kansas
 
Join Date: Oct 2008
Posts: 29
Mein Auto: 1988 E28
Yes it is a 528e, and the odometer has been stuck at 156,000 since i bought it a year and a half ago.

Last edited by jvaughn21; 02-14-2010 at 08:15 AM.
Reply With Quote
  #4  
Old 02-15-2010, 07:36 PM
south26 south26 is offline
Officially Welcomed to the 'Fest
Location: Dayton, OH
 
Join Date: May 2009
Posts: 787
Mein Auto: 535i 1989
I would replace the oil presuure sensor and see if that takes care of the problem. If that does not do it I would see about borrowing or buying a a kit to test your oil pressure. If it is low after it warms up that means that you need to replace the bearings and the pump. Since it is a 528e it is not that bad of a job. I did it last summer. You do not need to take the engine out since there is enough cleance to remove the oil pan. The Bentaly is good for the specs but the directions are horrible, the Hanse has great directions but no specs so with both manuals you can do it very easily. I did not replace mine for 3 months I just put in 10w50 and STP and raised the RPMS to 1200 so the oil light would not come on. I then took the engine apart.

Andy
Reply With Quote
  #5  
Old 02-17-2010, 01:05 PM
jimoreno jimoreno is offline
Officially Welcomed to the 'Fest
Location: Parsippany, NJ
 
Join Date: Jul 2006
Posts: 487
Mein Auto: 2006 X3
I agree, just change the fuel pressure sender and see how it goes. They tend to start leaking also so it's a good idea to get them replaced.
__________________
Jimmy Moreno
1995 530i
1986 535i
Reply With Quote
  #6  
Old 02-17-2010, 03:04 PM
south26 south26 is offline
Officially Welcomed to the 'Fest
Location: Dayton, OH
 
Join Date: May 2009
Posts: 787
Mein Auto: 535i 1989
No the oil pressure sensor. It is down by the oil filter.

Andy
Reply With Quote
  #7  
Old 03-23-2010, 08:37 PM
mihigloria3 mihigloria3 is offline
Registered User
Location: Oregon
 
Join Date: Apr 2008
Posts: 13
Mein Auto: BMW 330i & BMW X5
I have this same problem. I have a 2003 330i with 100k miles. I replaced both oil pressure switches and the oil level sender. Also put in 5w30 sythetic with Mann oil filter. Still comes on at idle. Any more ideas??
Reply With Quote
  #8  
Old 03-24-2010, 08:52 AM
catso's Avatar
catso catso is offline
catso
Location: Chicago
 
Join Date: Dec 2009
Posts: 2,958
Mein Auto: 2000 323i, 1988 528e
Quote:
Originally Posted by mihigloria3 View Post
I have this same problem. I have a 2003 330i with 100k miles. I replaced both oil pressure switches and the oil level sender. Also put in 5w30 sythetic with Mann oil filter. Still comes on at idle. Any more ideas??
Measure the actual oil pressure. Sounds like you have a problem.
Reply With Quote
  #9  
Old 03-24-2010, 03:23 PM
south26 south26 is offline
Officially Welcomed to the 'Fest
Location: Dayton, OH
 
Join Date: May 2009
Posts: 787
Mein Auto: 535i 1989
Ya sounds like you need a engine rebuild.

Andy
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E28 (1982 - 1988)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Forum Jump


All times are GMT -7. The time now is 02:37 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms