Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)

X5 E70 (2007 - 2013)
E70 BMW X5 produced between 2007 and 2013. Discuss the E70 X5 with other BMW owners here.

Reply
 
Thread Tools Display Modes
  #1  
Old 01-29-2008, 07:28 AM
Xelerator Xelerator is offline
Registered User
Location: Xanadu
 
Join Date: Jan 2008
Posts: 3
Mein Auto: X-Wing
E70 running board white staining

Hello mates,

any members with staining issues here?
What cluld be the cause for the white staining?

Thanks!

Chris
Reply With Quote
Advertisement
  #2  
Old 01-29-2008, 07:41 AM
denaliman denaliman is offline
Officially Welcomed to the 'Fest
Location: Canada
 
Join Date: Jan 2007
Posts: 214
Mein Auto: 2013 X6M
Quote:
Originally Posted by Xelerator View Post
Hello mates,

any members with staining issues here?
What cluld be the cause for the white staining?

Thanks!

Chris
Yes it is common. Probably caused by Acidic cleaners. A little flitz polish and elbow grease removes it. Don't go to the car wash they use cheap products and that could be your problem.
__________________
2013 X6M Sapphire Black-current
2013 Audi S4-current
2007 BMW X5 4.8i (E70)-sold
Reply With Quote
  #3  
Old 01-29-2008, 07:55 AM
Xelerator Xelerator is offline
Registered User
Location: Xanadu
 
Join Date: Jan 2008
Posts: 3
Mein Auto: X-Wing
Quote:
Originally Posted by denaliman View Post
...A little flitz polish and elbow grease removes it...
The Running boards are anodized (usually 10-20 microns), polishing could take that off and the bare aluminium appears.
Reply With Quote
  #4  
Old 01-29-2008, 07:59 AM
denaliman denaliman is offline
Officially Welcomed to the 'Fest
Location: Canada
 
Join Date: Jan 2007
Posts: 214
Mein Auto: 2013 X6M
I had the same problem and did mine with no problem. If that doesn't work call the dealer and have them replaced. Lot's of people had the same problem over at X5 world.
__________________
2013 X6M Sapphire Black-current
2013 Audi S4-current
2007 BMW X5 4.8i (E70)-sold
Reply With Quote
  #5  
Old 01-29-2008, 08:21 AM
Xelerator Xelerator is offline
Registered User
Location: Xanadu
 
Join Date: Jan 2008
Posts: 3
Mein Auto: X-Wing
Quote:
Originally Posted by denaliman View Post
... Lot's of people had the same problem over at X5 world.
What is the root cause (seems to be linked to carwash operating principle)?

Is there any issue with DIY cleaners?
Reply With Quote
  #6  
Old 01-29-2008, 01:12 PM
denaliman denaliman is offline
Officially Welcomed to the 'Fest
Location: Canada
 
Join Date: Jan 2007
Posts: 214
Mein Auto: 2013 X6M
Quote:
Originally Posted by Xelerator View Post
What is the root cause (seems to be linked to carwash operating principle)?

Is there any issue with DIY cleaners?
Stay away from highly acidic or alkali cleaners. Use only good quality car wash, no dish soap. If your using a tire cleaner watch the overspray on the running boards.
__________________
2013 X6M Sapphire Black-current
2013 Audi S4-current
2007 BMW X5 4.8i (E70)-sold
Reply With Quote
  #7  
Old 01-29-2008, 01:51 PM
XZLR8's Avatar
XZLR8 XZLR8 is offline
Officially Welcomed to the 'Fest
Location: Ohio
 
Join Date: Sep 2002
Posts: 2,262
Mein Auto: X6M
I had mine replaced, as they had white residue at delivery. No problem with the new ones.
__________________

2014 BMW X6 ///M | SpaceGray/BlackPerforatedFullMerino/CarbonLeather
2014 BMW 328xi Touring M-Sport | GlacierSilver/BlackDakota/DarkBurlWalnut
2014 BMW X6 35i M-Perf | TitaniumSilver/BlackNappa/DarkBamboo [wife's ride]

BMW HISTORY | '13 650xiGC, '12 650xi, '11 535xi, '11 X6 50i, '09 750i, '09 328xiT, '08 650i, '07 750i, '07 X5 4.8i, '06 650i, '05 745i, '05 325xiT, '03 745i, '02 745i, '01 325Cic, '01 X5 4.4i, and on...
Reply With Quote
  #8  
Old 08-17-2008, 05:50 AM
Philippos Philippos is offline
Registered User
Location: Greece
 
Join Date: Aug 2008
Posts: 1
Mein Auto: BMW X5 (E70)
Hello !

I am from Greece and I have the same problem with my new BMW X5 (E70).
Please tell me:
The BMW Dealer, changed your Running board or you managed to clean it, by yourself ?
And with witch product did you clean it?

Here you find and others like us:
http://www.x5world.com/x5-e70-forum/...rd-stains.html
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 03:53 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms