Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)

X3 E83 (2004 - 2010)
Talk about the E83 BMW X3 in this forum!

Reply
 
Thread Tools Display Modes
  #1  
Old 11-30-2008, 10:50 AM
HokieMike HokieMike is offline
Registered User
Location: VA
 
Join Date: Nov 2008
Posts: 10
Mein Auto: 2005 X3
X3 Airbag Light Help

Greetings all. Bought an 05 X3 a few months back. Learned a ton by lurking here, but now have an issue that I looking for some help with. I installed an ipod adaptor and an amplifier last weekend. AFter powering back up, the airbaig light was on. Did my research here and on other forums, and found this to be a somewhat common issue. I decided to purchase a Peaker Research R5/SRS tool to reset the light, assuming it simply needed resetting. That led to several questions:

For those familiar with the Peake reader, in the FA code, it shows 06, a table which does not appear in the manual or the website. Hit the GO button again, it shows error code 60. I am not sure what this means, and I am hoping someone here can clue me in.

Just for kicks, I did try the light reset. By toggling into the CA mode and hitting select. It showed clear, but did not clear the light.

Thoughts? I guess I could have a legit airbag issue, but I think it has to be related to the stereo install. I do not believe any of the airbag sensors were touched, but I could be wrong.

Obviously, the dealer is the final, best option. If I cannot ascertain the problem myself, I will absolutely go to the dealer, as I do not wish to risk my personal safety. Any input would be appreciated. Thanks. Mike
Reply With Quote
Advertisement
  #2  
Old 11-30-2008, 12:20 PM
skierbri10 skierbri10 is offline
Registered User
Location: Colorado
 
Join Date: Nov 2008
Posts: 74
Mein Auto: 2007 X3
Which airbag light is it? The Passenger one? There is a recall for the passenger seat sensor I believe. Yours might be under ther recall. Sorry that I can't give you more info on anything.
Reply With Quote
  #3  
Old 11-30-2008, 02:23 PM
HokieMike HokieMike is offline
Registered User
Location: VA
 
Join Date: Nov 2008
Posts: 10
Mein Auto: 2005 X3
Skier,
It is the airbag fault light in the dash cluster, not the passenger side issue. I wish it were just that!
Reply With Quote
  #4  
Old 11-30-2008, 02:59 PM
jviss jviss is offline
Registered User
Location: Westborough, MA
 
Join Date: Nov 2008
Posts: 81
Mein Auto: '06 X3
Quote:
Originally Posted by HokieMike View Post
Greetings all. Bought an 05 X3 a few months back. Learned a ton by lurking here, but now have an issue that I looking for some help with. I installed an ipod adaptor and an amplifier last weekend. AFter powering back up, the airbaig light was on. Did my research here and on other forums, and found this to be a somewhat common issue. I decided to purchase a Peaker Research R5/SRS tool to reset the light, assuming it simply needed resetting. That led to several questions:

For those familiar with the Peake reader, in the FA code, it shows 06, a table which does not appear in the manual or the website. Hit the GO button again, it shows error code 60. I am not sure what this means, and I am hoping someone here can clue me in.

Just for kicks, I did try the light reset. By toggling into the CA mode and hitting select. It showed clear, but did not clear the light.

Thoughts? I guess I could have a legit airbag issue, but I think it has to be related to the stereo install. I do not believe any of the airbag sensors were touched, but I could be wrong.

Obviously, the dealer is the final, best option. If I cannot ascertain the problem myself, I will absolutely go to the dealer, as I do not wish to risk my personal safety. Any input would be appreciated. Thanks. Mike
I don't understand the logic of this. Stereo install, power up, airbag light on. Coincidental, but why assume its related? Why buy a $120 tool just for this?

Dealer is the "best, final option?" I would have said "first, best option."

I think you're stuck with it now, the dealer option and the tool, unfortunately.
Reply With Quote
  #5  
Old 11-30-2008, 03:08 PM
kringer2 kringer2 is offline
Registered User
Location: Colorado
 
Join Date: Jun 2007
Posts: 38
Mein Auto: X3, Corvette, 328iC,325iC
Did you take the seat out to install your stuff? If you did make sure all the connections are tight under the seats. I installed a unit under my seat in my E36. Powered the unit up before reinstalling the seat - Air Bag light. Just make sure all the connections are still tight ,.
__________________
Reply With Quote
  #6  
Old 11-30-2008, 03:09 PM
jviss jviss is offline
Registered User
Location: Westborough, MA
 
Join Date: Nov 2008
Posts: 81
Mein Auto: '06 X3
more

The Peake R5/SRS is apparently not compatible with '05 BMWs, according to their website.
Reply With Quote
  #7  
Old 12-01-2008, 07:01 AM
HokieMike HokieMike is offline
Registered User
Location: VA
 
Join Date: Nov 2008
Posts: 10
Mein Auto: 2005 X3
jviss,
You are right about what the Peake website says about the tool's compatibilty with new modelsl. However, I have read where others have used it on 05 and newer models successfully. Since I figured to be doing more stereo work to the car, and I was able to get the tool for way less than that price, and I figured it was worth a shot. I am sure I can sell it for what I have in it.

kringer,
good advice. I will go through the car again to make sure something wasn't left undone.

Thanks. Mike
Reply With Quote
  #8  
Old 12-01-2008, 08:54 PM
ARX3 ARX3 is offline
Officially Welcomed to the 'Fest
Location: Reston VA
 
Join Date: Dec 2008
Posts: 237
Mein Auto: E60 '08 535xi, E83 '07 X3
Not sure if it's same on E83, but on my old E36 M3, if any of the airbags got disconnected without disconnecting the battery first, a stored airbag error is recorded that only dealer can reset. This may also apply to seat belt pre-tensioners or any of the seat sensors.

Next time you may want to disconnect the battery first, and not connect it until you double check that all connections are reconnected.

--Rob
__________________
BMWCCA #135536
Reply With Quote
  #9  
Old 12-01-2008, 08:56 PM
ARX3 ARX3 is offline
Officially Welcomed to the 'Fest
Location: Reston VA
 
Join Date: Dec 2008
Posts: 237
Mein Auto: E60 '08 535xi, E83 '07 X3
Quote:
Originally Posted by HokieMike View Post
jviss,
kringer,
good advice. I will go through the car again to make sure something wasn't left undone.

Thanks. Mike
Too late!
__________________
BMWCCA #135536
Reply With Quote
  #10  
Old 12-01-2008, 09:03 PM
X3-terrestrial's Avatar
X3-terrestrial X3-terrestrial is offline
Aficionado
Location: N.Miss - Memphis,TN Area
 
Join Date: Aug 2008
Posts: 2,630
Mein Auto: '05 X3, '95 M3, '89 MkI
Quote:
Originally Posted by ARX3 View Post
Not sure if it's same on E83, but on my old E36 M3, if any of the airbags got disconnected without disconnecting the battery first, a stored airbag error is recorded that only dealer can reset. This may also apply to seat belt pre-tensioners or any of the seat sensors.

Next time you may want to disconnect the battery first, and not connect it until you double check that all connections are reconnected.

--Rob
He's right ^^ dealer needs to clear code, even if you reconnect any wires.
__________________
"If everything seems under control, you're just not going fast enough"
-Mario Andretti.

___________________
River City Bimmers BMW CCA
2005 X3 3.0i ZPP, Htd seats, Htd strng, Black Sapphire on Terracotta.
1995 ///M3 Coupe, Lux, MT, Htd seats, Cosmos Black on Black.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 06:56 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms