Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E36 (1991 - 1999)

E36 (1991 - 1999)
The E36 chassis 3-Series BMW was a huge hit among driving enthusiasts from the first moment the car hit the pavement. The E36 won numerous awards over the years it was produced and is still a favorite of many BMW enthusiasts to this day! -- View the E36 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 01-26-2009, 02:11 AM
2sickfish2 2sickfish2 is offline
Registered User
Location: New Zealand
 
Join Date: Jan 2009
Posts: 2
Mein Auto: 1993 325i
Exclamation Instrument Cluster Not Working!! Help!!

I have a 1993 325i 4door and have recently just hooked up a new head unit sub and amp now only my speedo works out of my instrument cluster works all the rest (tacho temp fuel ect) when i start the car the hand break light and another red light next to it just light up and stay on for the hole trip. if anyone out there can help me it would be very helpfull before i have to take it to an auto sparky.

Thanks all lots
Reply With Quote
Ads by Google
  #2  
Old 01-26-2009, 08:00 AM
HyphE36's Avatar
HyphE36 HyphE36 is offline
Search Button Upper Right
Location: San Francisco
 
Join Date: Oct 2008
Posts: 2,234
Mein Auto: E36 95 325IS Black/Black
Check fuses and relays for the Instrument Cluster. Fuses that have to do with Instrument Cluster for your year should be 22, 23, 25, 27, 31, 37, and 46. I'm not sure if any relays (the larger squares in your power distribution box surrounded by fuses, there should be 15 relays, not all may be used) actually deal with the Instrument Cluster, however Relay #1. Fuel Pump Relay and Relay #2. System(main) Relay. may send information to the Instrument Cluster as well.

If there is no problem there then pull your new HU out and check to make sure the wires are connected without horribly interfering with any other wires in the area. You may also want to pull out your Instrument Cluster and check the connections to that. If all connections and electronic communications seem to be fine (use a digital multimeter to know for sure) then you may want to pull the cover off the back of the Instrument Cluster and look for a short in the circuitry on the Cluster itself.

Did you unhook your battery while installing your new components? Not sure if you have to or not, but it could be possible that if you didn't it somehow allowed for a power surge to reach your Cluster and fry parts, or pop a fuse, or relay, or fault wiring...

I'm doing similar tests/fixes in my car because my cluster won't light up, but its not the bulbs or the fuses, so I have to delve deeply into e36 electrical land too... it sucks...

There is a lot to check, good luck bro and let us know how it goes
__________________
Bilstien PSS9's / SPC Rear Control Arms / DDM Smoked Corners, Sides, Tails / K&N FIPK2 / CXRacing All Aluminum Radiator w Aluminum Shroud and Electric Fan / Stewart Components Waterpump / Aluminum Tstat Housing / SamcoSport Coolant Hoses / Fan Delete Mod - 14" Electric Pull Fan / UBERGROUND Battery Cable / NGK Ir.IX Plugs / Royal Purple Fluids for; Engine, Differential, Transmission, Power Steering.
. SOLD
MEMBER OF THE MOST EXCLUSIVE SECRET CLUB ON THE 'FEST
Reply With Quote
  #3  
Old 01-27-2009, 01:37 AM
2sickfish2 2sickfish2 is offline
Registered User
Location: New Zealand
 
Join Date: Jan 2009
Posts: 2
Mein Auto: 1993 325i
Hey thanks for the help man i recheaked all of the fuses that you listed i had cheaked them all before bar 25 and replacing that seems to have fixed it.

God luck with your car bro and thanks again for the help
Reply With Quote
  #4  
Old 01-27-2009, 04:08 PM
HyphE36's Avatar
HyphE36 HyphE36 is offline
Search Button Upper Right
Location: San Francisco
 
Join Date: Oct 2008
Posts: 2,234
Mein Auto: E36 95 325IS Black/Black
Glad to have been a help bro and thanks for the luck wish, I'll need it to be rid of my electrical gremlins ><
__________________
Bilstien PSS9's / SPC Rear Control Arms / DDM Smoked Corners, Sides, Tails / K&N FIPK2 / CXRacing All Aluminum Radiator w Aluminum Shroud and Electric Fan / Stewart Components Waterpump / Aluminum Tstat Housing / SamcoSport Coolant Hoses / Fan Delete Mod - 14" Electric Pull Fan / UBERGROUND Battery Cable / NGK Ir.IX Plugs / Royal Purple Fluids for; Engine, Differential, Transmission, Power Steering.
. SOLD
MEMBER OF THE MOST EXCLUSIVE SECRET CLUB ON THE 'FEST
Reply With Quote
Reply

Bookmarks

Tags
dash, gauge, instrument cluster, tacho


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E36 (1991 - 1999)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 06:58 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms