Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E46 (1999 - 2006)

E46 (1999 - 2006)
The fourth generation 3 Series (E46 chassis) was introduced in 1999 and set the standard for engineering and performance during it's years of production including being named to Car & Driver's 10 best list every one of those years! ! -- View the E46 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 02-07-2009, 05:55 PM
dougcampbell81 dougcampbell81 is offline
Registered User
Location: US
 
Join Date: Aug 2006
Posts: 2
Mein Auto: 2003 BMW 330XI
Tire Pressure Control (RDC)/Tire Pressure Monitor (TPM) pre 2007 problems

I have a 2003 330XI w/sport package which comes with the Tire Pressure Monitor (TPM) system.

My amber tire light comes on after about 6 minutes of resetting tire pressures, even with correct tire pressures.

Dealer confirmed that all 4 tire "wheel electronics modules-RDC" part number 36118378682 were working properly.

Says they initially read an error in right front (RF) transponder, but then swapped the front tires, reset the system, and an error still read with the RF transponder. They did a continuity test and all 4 antennas read ok. So they ruled that the "Control Unit RDC" part number 36146759023 was being flaky and needed to be replaced, and of course is $250 plus.

Has anybody else had to replace their RDC control unit? Anybody have one for sale?

Here are the Tire Pressure Control (RDC) parts for my model.

http://www.realoem.com/bmw/showparts...84&hg=36&fg=15

Last edited by dougcampbell81; 02-07-2009 at 07:59 PM.
Reply With Quote
Ads by Google
  #2  
Old 05-31-2009, 11:19 AM
larerick larerick is offline
Registered User
Location: washington
 
Join Date: May 2009
Posts: 2
Mein Auto: BMW 530i
Tire pressure module

Did you find the control unit, if so where did you find the part?
I recently purchased an 07 530i that did not have a TPC module under the spare wheel. I am now looking for one myself. It also requires an aerial also that is missing.
Of course my tire pressure yellow icon light is always on. As far as i can tell this is all that i need to correct this problem. The tires seem to have the right sending parts.
Reply With Quote
  #3  
Old 05-31-2009, 12:47 PM
Doug330XI Doug330XI is offline
Registered User
Location: Harrisburg
 
Join Date: Feb 2009
Posts: 5
Mein Auto: 2003 330XI 5sp MT
Quote:
Originally Posted by larerick View Post
Did you find the control unit, if so where did you find the part?
I recently purchased an 07 530i that did not have a TPC module under the spare wheel. I am now looking for one myself. It also requires an aerial also that is missing.
Of course my tire pressure yellow icon light is always on. As far as i can tell this is all that i need to correct this problem. The tires seem to have the right sending parts.
The problem was resolved. See this link.

http://forum.e46fanatics.com/showthr...682&highlight=

I am unfamiliar with the tire pressure monitoring system for your car. These systems varied greatly from model to model and year to year.

You can find parts at

http://www.realoem.com/bmw/

and purchase from

http://www.ecstuning.com/

If your car is still under warranty and maintenance plan, BMW may be able to correct the problem for free.
Reply With Quote
  #4  
Old 05-31-2009, 12:55 PM
jcourcoul jcourcoul is offline
Supporter of Bimmer Lore
Location: Mexico
 
Join Date: Nov 2008
Posts: 5,192
Mein Auto: 2006 325Ci
Just as an off chance, have you or the dealer confirmed that the receiving antennae in all four wheel wells are alive and well? One may be missing or the connector compromised.

As for larerick's missing transponder in the spare, that shouldn't be a problem as the system will only monitor the 4 rolling wheels and you'll have to check the spare once in awhile. Not a biggie, since it doesn't roll and isn't subject to nails, potholes and other hazards.
__________________

2006 325Ci
Reply With Quote
  #5  
Old 05-31-2009, 02:52 PM
Doug330XI Doug330XI is offline
Registered User
Location: Harrisburg
 
Join Date: Feb 2009
Posts: 5
Mein Auto: 2003 330XI 5sp MT
Quote:
Originally Posted by jcourcoul View Post
Just as an off chance, have you or the dealer confirmed that the receiving antennae in all four wheel wells are alive and well? One may be missing or the connector compromised.

As for larerick's missing transponder in the spare, that shouldn't be a problem as the system will only monitor the 4 rolling wheels and you'll have to check the spare once in awhile. Not a biggie, since it doesn't roll and isn't subject to nails, potholes and other hazards.

I've changed my screen name from dougcampbell81 to doug330xi

There was nothing wrong with the antennas, connectors or main RDC control module. It was a faulty tire pressure sensor transmitter. Dealer misdiagnosed this at my expense.

See this post

http://forum.e46fanatics.com/showthr...682&highlight=

Last edited by Doug330XI; 05-31-2009 at 02:55 PM.
Reply With Quote
  #6  
Old 05-31-2009, 10:46 PM
larerick larerick is offline
Registered User
Location: washington
 
Join Date: May 2009
Posts: 2
Mein Auto: BMW 530i
I bought the car without the pressure sensing module; which I discovered later. This module sits in a slot just under my spare tire with an antenna. It is my understanding that the module works by telling the computer/screen to turn off the yellow icon and continues to monitor the tires pressure. The concern I have is that my run-flat-tires can be damaged if I travel more than the recommended 150 miles without air in the tire. I haven't checked two of the tires for the sensors but I know they all have the them, but don't know if they work.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E46 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 06:10 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms