Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 03-20-2009, 09:33 PM
seano523i seano523i is offline
Registered User
Location: Canberra - Australia
 
Join Date: Mar 2009
Posts: 14
Mein Auto: BMW E39 523i
E39 Dashboard Indicator lights and click

Hello there,

OK so this is the first time I've posted on here. I have often looked at the various posts and have been able to save a fortune in repair costs thanks to the users on here and the way the knowledge is shared.

I have a problem that I was hoping someone could answer for me. I have a 98 E39 523i. The indicators work, however, not inside the vehicle if that makes sense? The outside bulbs flash but the dashboard direction indicator lamps do not work (Little green direction arrows) Oh and niether does the audible clicking. Sometimes I forget to cancel it and because I can't see or hear the indicators I end up driving for ages with my blinkers on, I must look rather silly.

Does anyone know if there is a relay or something that controls those two functions? Oh I also believe other things such as lights on warning etc do not work.

Any help would be appreciated.
Reply With Quote
Ads by Google
  #2  
Old 07-29-2009, 11:33 AM
slowtype slowtype is offline
Registered User
Location: Portland, ME
 
Join Date: Jul 2009
Posts: 1
Mein Auto: 540i
Any update on this?

I'm looking at a vehicle with the same problem and want to know whats involved with getting this fixed.
Reply With Quote
  #3  
Old 01-04-2011, 10:07 AM
ChristiaanN ChristiaanN is offline
Registered User
Location: South Africa
 
Join Date: Jan 2011
Posts: 1
Mein Auto: E39 528
Please would somebody help. I have exactly the same problem on mine
Reply With Quote
  #4  
Old 01-04-2011, 12:05 PM
bmw_n00b13's Avatar
bmw_n00b13 bmw_n00b13 is offline
Freude am Fahren
Location: Cambridge, ON
 
Join Date: Feb 2008
Posts: 6,372
Mein Auto: 99 528iA
I'd suspect a loose wire or a bad LCM or cluster, in that order.
__________________
'99 528i ('98/12 build). 174,000km BY29428/Royalrot
Breaking My Wallet since 2009
Mods: Stoptech SS brake hose, 280piece toolkit resting on trunk floor, Beisan VANOS seals
'99 540i (grandfather's)

Reply With Quote
  #5  
Old 01-01-2012, 01:15 AM
ruskiromka ruskiromka is offline
Registered User
Location: melbourne
 
Join Date: Sep 2009
Posts: 24
Mein Auto: E39 523i
Did anyone get any resolution on this?

I've got exactly the same problem as described on my 1998.. sigh
Reply With Quote
  #6  
Old 01-01-2012, 05:38 AM
QSilver7's Avatar
QSilver7 QSilver7 is offline
Officially Welcomed to the 'Fest
Location: Northeast Indiana
 
Join Date: Aug 2008
Posts: 5,658
Mein Auto: 1997 740iL / 2006 X5 4.4
__________________
Q {BMW CCA Member #191509}
2006 E53 X5 4.4i (Sterling Gray) 12/05 mfg date <<~>> 97 740iL (Arctic Silver) 3/97 mfg date
(SOLD)
99 540iT (Orient Blue) <<~>> 95 525IT (Alpine White)
91 735iL (Schwarz Black) <<~>> 85 325e (Bronzit)

http://imageshack.com/scaled/grid240/822/e38e532ndsigpic.jpg
Reply With Quote
  #7  
Old 01-01-2012, 05:52 AM
JimLev JimLev is offline
Officially Welcomed to the 'Fest
Location: MA
 
Join Date: Dec 2003
Posts: 3,616
Mein Auto: 540/6, S60 Volvo, Tribeca
Try disconnecting the battery to drain out all of the stored charges in the modules.
It's probably not that, but at least this won't cost you anything.
When that doesn't work you will probably need to bring it in for the big $$$$ fix.
Hopefully it will help some of you.
Reply With Quote
  #8  
Old 02-18-2012, 04:27 PM
Gee_115 Gee_115 is offline
Registered User
Location: Dayton, OH
 
Join Date: Jan 2012
Posts: 43
Mein Auto: 550i
Any solution?
Reply With Quote
  #9  
Old 04-29-2012, 09:07 AM
Bob Barnes Bob Barnes is offline
Registered User
Location: San Jose
 
Join Date: Oct 2007
Posts: 1
Mein Auto: 1998 528I
Gee,

Did you find a solution? I have the same problem with my 1998 E39. All lights work but no dash indicators flashing with signal or Emergency switch.
Reply With Quote
  #10  
Old 04-29-2012, 11:04 AM
Gee_115 Gee_115 is offline
Registered User
Location: Dayton, OH
 
Join Date: Jan 2012
Posts: 43
Mein Auto: 550i
Quote:
Originally Posted by Bob Barnes View Post
Gee,

Did you find a solution? I have the same problem with my 1998 E39. All lights work but no dash indicators flashing with signal or Emergency switch.
I do not know if these guys resolved this issue. I was just curious. My issue was no indicators, wipers or anything on the steering. My fix was to replace the steering column switch(SZL module). However, my car is an 07 E60. This problem sounds more like the instrument cluster.
Reply With Quote
  #11  
Old 12-26-2012, 07:46 AM
nero2173 nero2173 is offline
Registered User
Location: uk
 
Join Date: Apr 2012
Posts: 1
Mein Auto: BMW E39 530D
Indictors not working on dash

Hello, this an old blog but i had the same issues , indicators working outside but not inside, pdc not working, wipers going haywire, central locking not working.
i found that the leads for the CD multi changer were getting damp. when i dry them the electrics all worked,
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 09:04 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms