Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 04-02-2009, 12:43 PM
mjmille6 mjmille6 is offline
Registered User
Location: No Cal
 
Join Date: Jan 2006
Posts: 5
Mein Auto: X5
Cool X5 Parking Distance Control (PDC) Issue

My PDC doesn't work. I took it into a shop and they said that the wires touched the mufler. They spliced the wires together again but it didn't fix the problem.

Could this have shorted out the system?

Any ideas on how to assess the magnitude of the problem or ideas on how to get it fixed?

Is there a master control element that would have to be replaced if it was in fact shorted out? If so, does anyone have any idea of how expensive such a repair would be?

Thanks.

Jim
Reply With Quote
Advertisement
  #2  
Old 04-06-2009, 04:46 PM
tiy8198 tiy8198 is offline
Registered User
Location: amityville, ny
 
Join Date: Mar 2009
Posts: 41
Mein Auto: x5 3.0
HI Jim

I had my parking sensors replaced a lil over a yr ago, bmw did it, cost me about 450...i think. i believe its 108 a sensor, plus the cost of labor. Dont remember the exact price because i had two things done at once. But im positive it was no less thann450-500.

To answer your question anything could have shorted the system, i dnt think splicing the wires was the best idea. My issue was that someone pulled off one of my sensors in the back. BMW had to re-wire the entire car and then replace the missing sensor. It was amazing because that one sensor completely stopped the front and back sensors from working.

Sry for your trouble and i hope this helps
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 08:38 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms