Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E90/E91/E92/E93 (2006 - 2013)

E90/E91/E92/E93 (2006 - 2013)
The E9X is the 4th evolution of the BMW 3 series including a highly tuned twin turbo 335i variant pushing out 300hp and 300 ft. lbs. of torque. BMW continues to show that it sets the bar for true driving performance! -- View the E9X Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 04-18-2009, 04:06 PM
RatherBeInCabo's Avatar
RatherBeInCabo RatherBeInCabo is offline
Officially Welcomed to the 'Fest
Location: Simi Valley, CA
 
Join Date: Apr 2008
Posts: 333
Mein Auto: 2007 328i
Sluggish Idrive

Just picked up an 07 328i with Nav on Thursday. The Idrive response seems to be very slow. If I change tracks on a CD or jog the control to communication or any of the other choices, it takes several seconds to respond. My previous car was a 545i w/o nav but had the Idrive and the response was instantaneous. Is this normal for the E90?
__________________
Current 10 VW GTI MKVI
Current 08 528i
Retired 07 328i
Retired 05 545i
Reply With Quote
Ads by Google
  #2  
Old 04-18-2009, 05:12 PM
Spagolli94 Spagolli94 is offline
Officially Welcomed to the 'Fest
Location: Philly
 
Join Date: Jan 2009
Posts: 1,602
Mein Auto: 2006 330i
Mine is only slow for maybe the first minute the car is on - like it is still busy booting up behind the scenes or something. Other than that, it's okay. Not super fast, but not slow enough to be annoying.
Reply With Quote
  #3  
Old 04-18-2009, 05:45 PM
Mineo335i Mineo335i is offline
335i N3WB
Location: Orlando, FL
 
Join Date: Jan 2009
Posts: 379
Mein Auto: 11' Audi S4 Prestige
Quote:
Originally Posted by Spagolli94 View Post
Mine is only slow for maybe the first minute the car is on - like it is still busy booting up behind the scenes or something. Other than that, it's okay. Not super fast, but not slow enough to be annoying.
Same with mine. Maybe for the first minute sometimes ill try to raise the volume and get no response, or change tracks on the ipod and nothing, but after that its fine.
__________________

Currently Drive: 2011 S4 Prestige, Quartz Gray, Black Alcantara, Adv key, B&O, NAV + rear sensors, 19's, Carbon Fiber Trim, iPod...
Previously drove:2007 335i Coupe, Titanium Silver Metallic,Black Leather, Gray Poplar trim, Premium package, Cold weather package, Sports package, i-Drive, Rear sensors, iPod.

Previously drove: 1998 3000GT Vr-4 Red/Black TT AWD AWS
Reply With Quote
  #4  
Old 04-18-2009, 07:24 PM
DocYahoo DocYahoo is offline
Registered User
Location: So Cal
 
Join Date: May 2006
Posts: 67
Mein Auto: 335 Coupe
For me, the iDrive (specifically when it's trying to map a route) has always been slow. Sometimes it would take up to 2 minutes to map a route.

What I have found though is if I have my phone on me, the first minute or two after starting the car, the car is pulling contacts from my phone. But like others have mentioned, the first minute or two the iDrive seems to be initializing it self. Because if you have the convenience package and you activates the car by standing next to it before actually starting it, when you do start it, the car seems to initialize right away.
Reply With Quote
  #5  
Old 04-19-2009, 04:39 AM
moviebumm's Avatar
moviebumm moviebumm is online now
Officially Welcomed to the 'Fest
Location: New York
 
Join Date: Dec 2005
Posts: 593
Mein Auto: 2014 BMW 435 xDrive
On my 2006 330xi, my nav is excruciatingly slow. What I do is I start my car about 15 to 20 minutes early and then the navigation/iDrive works better.
__________________
2014 435 xDrive

Estoril Blue
Black Kidney Grills
Black Dakota Leather
Aluminum Hexagon trim
Highlight trim finishers Estoril Blue matte

6 Speed Manual Transmission

M Sport
Cold Weather Package
Driver Assistance Package
Driver Assistance Plus
Dynamic Handling Package
Lighting Package
19" Light Alloy Wheels (style 442M)
Premium Package
Technology Package
M Sport Brakes
Concierge Services
Parking Assistant
Power Rear Sunshade
Harmon Kardon surround sound system

Ordered on 12/07/2013
Reply With Quote
  #6  
Old 04-19-2009, 10:39 AM
BimmerRat BimmerRat is offline
Officially Welcomed to the 'Fest
Location: Beverly Hills, CA
 
Join Date: May 2007
Posts: 106
Mein Auto: 2007 335i Coupe
Quote:
Originally Posted by Spagolli94 View Post
Mine is only slow for maybe the first minute the car is on - like it is still busy booting up behind the scenes or something. Other than that, it's okay. Not super fast, but not slow enough to be annoying.
I have the same problem. especially when switching between wither CD, AUX or Satellite.
__________________
2007 335i Coupe Jet Black / Black Leather / Steptronic w. Paddles / Aluminum / Premium / Sport / CA / Navigation / Satellite
Reply With Quote
  #7  
Old 04-19-2009, 10:54 AM
RatherBeInCabo's Avatar
RatherBeInCabo RatherBeInCabo is offline
Officially Welcomed to the 'Fest
Location: Simi Valley, CA
 
Join Date: Apr 2008
Posts: 333
Mein Auto: 2007 328i
Sounds like a common issue that I will just live with...Possibly have the dealer check it when I am in for scheduled service.
__________________
Current 10 VW GTI MKVI
Current 08 528i
Retired 07 328i
Retired 05 545i
Reply With Quote
  #8  
Old 04-21-2009, 04:39 PM
mikepinkerton mikepinkerton is offline
Registered Drooler
Location: Northern VA
 
Join Date: Dec 2004
Posts: 398
Mein Auto: '12 335i, '11 X3
My 06 nav was dog-slow, and then i got an upgrade some time in late 2007 and that made it faster. Really the primary way to get it fast is to get the a new 09, which is one of the main reasons I turned in my 06 lease for a new 09 rather than keeping it or getting another used older model.

The new nav is much easier to use and much faster.
-Mike
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E90/E91/E92/E93 (2006 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 09:20 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms