Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E85 / E86 Z4 (2003-2008)

E85 / E86 Z4 (2003-2008)
E85 Z4 convertible and E86 Z4 coupe talk with our BMW gurus here.

Reply
 
Thread Tools Display Modes
  #1  
Old 04-24-2009, 04:41 AM
doncoggs doncoggs is offline
Registered User
Location: Melbourne
 
Join Date: Apr 2009
Posts: 22
Mein Auto: BMW Z4 2003
Z4 CD Player...Clicking noise?

G'day everyone, I have this annoying clicking sounds that occurs once the engine has been switched off, it continues for about 10 seconds on every occasion? Can anyone tell me how to fix the problem...thanks
Reply With Quote
Ads by Google
  #2  
Old 04-24-2009, 05:31 AM
jragan's Avatar
jragan jragan is offline
Officially Welcomed to the 'Fest
Location: Fort Worth, Texas
 
Join Date: Dec 2007
Posts: 471
Mein Auto: 07 Imola Red/Black MCoupe
Does the same clicking also occur if you open the driver's door after the car's been sitting a while? If so, then it's normal and doesn't need "fixing".
__________________
His: E86 ///M Coupe: Pics Track Pics Vids
Hers: 997-1 C4S: Pics
Reply With Quote
  #3  
Old 04-24-2009, 06:09 PM
doncoggs doncoggs is offline
Registered User
Location: Melbourne
 
Join Date: Apr 2009
Posts: 22
Mein Auto: BMW Z4 2003
Yeah as the door is opened as well...but why does it make that noise, i no its not much, just kind of annoying, that all...cheers mate
Reply With Quote
  #4  
Old 08-28-2009, 11:57 PM
kjbrazil kjbrazil is offline
Registered User
Location: Mountain View, Ca
 
Join Date: Jun 2008
Posts: 21
Mein Auto: 2005 525i
I've been having this same problem. It's incredibly annoying and would like to have it resolved. I just recently went under my extended warranty and I'm pretty sure these types of issues are not covered. Let me know if you found a fix.
Reply With Quote
  #5  
Old 08-29-2009, 05:03 PM
jragan's Avatar
jragan jragan is offline
Officially Welcomed to the 'Fest
Location: Fort Worth, Texas
 
Join Date: Dec 2007
Posts: 471
Mein Auto: 07 Imola Red/Black MCoupe
It's not a bug or an issue or a problem to fix. It's the car spinning the discs up to speed so they're "ready to go" when you turn the car on. It's a convenience FEATURE.
__________________
His: E86 ///M Coupe: Pics Track Pics Vids
Hers: 997-1 C4S: Pics
Reply With Quote
  #6  
Old 08-29-2009, 05:37 PM
kjbrazil kjbrazil is offline
Registered User
Location: Mountain View, Ca
 
Join Date: Jun 2008
Posts: 21
Mein Auto: 2005 525i
It is NOT a feature. It is an issue with the CD player. Yes, it's performing a normal check but it should not make that much noise (or any noise at all for that matter) when doing so. How would you describe something as "normal" when the entire time I've owned the car it has never done it and now suddenly it does? It's also not "normal" for a mid-size luxury sedan to make a loud disc spinning noise every time a door is opened.
Reply With Quote
  #7  
Old 08-29-2009, 09:47 PM
Jermy1304 Jermy1304 is offline
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Mar 2009
Posts: 508
Mein Auto: 2003 BMW Z4 3.0i
I have this issue that is very similar. When listening to the Cd Player with the car running I get a staticy click that occurs every 25 seconds or so. No idea what it is......sounds like a quiet static pop coming from under the dash
Reply With Quote
  #8  
Old 11-19-2009, 12:47 PM
chargedZ chargedZ is offline
Registered User
Location: Santa Rosa, CA
 
Join Date: Jun 2009
Posts: 55
Mein Auto: 2003 Z4 3.0
This issue started for me about two weeks ago...and I agree this is NOT normal. Has anyone found a solution to this issue? Other than replacing the head unit that is...?!
Reply With Quote
  #9  
Old 11-19-2009, 01:24 PM
kjbrazil kjbrazil is offline
Registered User
Location: Mountain View, Ca
 
Join Date: Jun 2008
Posts: 21
Mein Auto: 2005 525i
So far no solution that I've come up with besides replacing it. I was thinking about trying to clean it with an automobile CD player cleaner. It could be possible that over time it's just gotten dirty inside which could cause the noise and the occasional trouble playing CDs. I've been thinking about this one: http://www.amazon.com/Dry-Automobile.../dp/B0002IEEUC. Even if it doesn't work I guess it only sets you back about $10.
Reply With Quote
  #10  
Old 11-19-2009, 10:19 PM
chargedZ chargedZ is offline
Registered User
Location: Santa Rosa, CA
 
Join Date: Jun 2009
Posts: 55
Mein Auto: 2003 Z4 3.0
I agree...it's worth trying to clean it. I am going to call the local dealer, see if they have run across this issue before. Although it's unlikely that they will have a solution besides replacing it. I also will ask my local BMW tuner, see what they think.
Reply With Quote
  #11  
Old 11-20-2009, 10:12 AM
kjbrazil kjbrazil is offline
Registered User
Location: Mountain View, Ca
 
Join Date: Jun 2008
Posts: 21
Mein Auto: 2005 525i
All sounds good. Let us know what the dealer/tuner says and I'll let you know how the cleaning method works out.
Reply With Quote
  #12  
Old 11-21-2009, 12:00 PM
chargedZ chargedZ is offline
Registered User
Location: Santa Rosa, CA
 
Join Date: Jun 2009
Posts: 55
Mein Auto: 2003 Z4 3.0
I haven't had a chance to make any calls yet...but I fear the worst at this point.

The clicking noise now stays for a couple minutes and it's freaking out when trying to receive or eject CD's...once I get the CD in and working...it works fine.

I know a good car stereo repair man locally, I might see if he has any ideas. Might be cheaper to have him fix it then replacing the HU.
Reply With Quote
  #13  
Old 12-28-2011, 07:32 PM
pyronical pyronical is offline
Registered User
Location: Auckland, NZ
 
Join Date: Dec 2011
Posts: 1
Mein Auto: BMW Z4 3.0i '04 (E85)
Sorry to necro bump this old thread, but I have the identical problem with my head unit. Wondering if anyone found a solution.
Reply With Quote
  #14  
Old 02-05-2013, 03:19 AM
ST Nathan ST Nathan is offline
Registered User
Location: Victoria, BC
 
Join Date: Jul 2012
Posts: 3
Mein Auto: 2003 Z4 3.0i
Quote:
Originally Posted by pyronical View Post
Sorry to necro bump this old thread, but I have the identical problem with my head unit. Wondering if anyone found a solution.
Pretty much exactly what this guy said.
Got the same issue with rapid clicking sounds coming from the head unit when a cd is in, upon opening door or turning off the car. Would be great if it's fixable without replacing the whole thing. It's been doing this for the 4 years or so that I've owned the car and hasn't gotten any worse, but it hasn't gotten any less annoying either.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E85 / E86 Z4 (2003-2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 05:15 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms