Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E36/7 Z3 (1996-2002)

E36/7 Z3 (1996-2002)
E36/7 Z3 Roadster, Z3 coupe, Z3 M Roadster and Z3 M Coupe talk with our gurus here.

Reply
 
Thread Tools Display Modes
  #1  
Old 06-26-2015, 08:42 AM
z3don z3don is offline
Registered User
Location: Wisconsin
 
Join Date: Jun 2015
Posts: 3
Mein Auto: 2001 z3
Not working covertible

Hello and help,
2001 z3 that for some reason the top does not want to work so I am doing it manually for now.
Fuses under the hood look fine.
I wanted to look at the switches in the center console but have not been able to remove it.
I tried to remove the tray, in the console, and got the front of it out, but could not get the rear to come out and did not want to break it.
I tried to remove the console by removing the one screw per side near the rear, but it did not seem to help.
What am I don't wrong and any help would be greatly appreciated.

Have a great day,
Don

Last edited by z3don; 06-26-2015 at 08:43 AM.
Reply With Quote
Advertisement
  #2  
Old 06-26-2015, 09:38 AM
Wolfbeef123 Wolfbeef123 is offline
Registered User
Location: Mission, TX
 
Join Date: Mar 2015
Posts: 61
Mein Auto: BMW Z3
Quote:
Originally Posted by z3don View Post
Hello and help,
2001 z3 that for some reason the top does not want to work so I am doing it manually for now.
Fuses under the hood look fine.
I wanted to look at the switches in the center console but have not been able to remove it.
I tried to remove the tray, in the console, and got the front of it out, but could not get the rear to come out and did not want to break it.
I tried to remove the console by removing the one screw per side near the rear, but it did not seem to help.
What am I don't wrong and any help would be greatly appreciated.

Have a great day,
Don
Check your brake sensor, if all lights are working then its fine.
If you lower the top and try to put it up will it work?
There's a microswitch located inside of the top which lets the system know that you raised it and to start the hydraulic pump.
That's what went wrong with mine.
Reply With Quote
  #3  
Old 06-26-2015, 09:43 AM
khammack khammack is offline
Warning - Thin Air
Location: Denver, Colorado
 
Join Date: Jun 2004
Posts: 807
Mein Auto: 2002 M Roadster/2014 435i
I would check the micro switch in the top frame over the drivers head. It is what tells the computer that you have pushed the top up the required amount before the pump takes over. There is also a switch on the brake which seems to fail a lot. It lets the computer know you have the brake pressed before the computer will let the top move. The console is a pain to remove. Here is a link to how it is done - http://www.bimmerfest.com/forums/sho...d.php?p=631115
__________________

2014 435i M-Sport, Mineral Gray, Black Dakota Leather, Driver Assistance Pkg, Prem Pkg, Tech Pkg, 8 Speed Sport AT, Heated Front Seats, Active Cruise Control, BMW Perf Tune w/MPE, BMW Limited Slip Diff, BBS CH Wheels.

2002 M Roadster, Steel Gray Metailic, Gray Nappa Leather, Black Soft Top, Steel Gray Metailic Hard Top, TC Kline Double Adj Shocks with H&R Springs, Stromung Exhaust, SSR Type C Wheels.
Reply With Quote
  #4  
Old 06-27-2015, 06:41 AM
z3don z3don is offline
Registered User
Location: Wisconsin
 
Join Date: Jun 2015
Posts: 3
Mein Auto: 2001 z3
Brake Light Switch

After reading your responses and others on this site I checked and found that my tail lights were not working, thus it would appear that my brake light switch is defective or somehow not working properly.
I have to assume that once I figure out how to get it replaced/fixed my convertible top will again work.
Thanks to all who took the time to respond to my, not so unique, problem.
It's amazing how much you miss something, when it was working you took it for granted; IE: Z3.........
Have a great day and thanks again,
Don
Reply With Quote
  #5  
Old 06-27-2015, 11:50 AM
khammack khammack is offline
Warning - Thin Air
Location: Denver, Colorado
 
Join Date: Jun 2004
Posts: 807
Mein Auto: 2002 M Roadster/2014 435i
I have note done this (yet), but here are some good directions telling how to do it.
http://www.pelicanparts.com/BMW/tech...eplacement.htm
__________________

2014 435i M-Sport, Mineral Gray, Black Dakota Leather, Driver Assistance Pkg, Prem Pkg, Tech Pkg, 8 Speed Sport AT, Heated Front Seats, Active Cruise Control, BMW Perf Tune w/MPE, BMW Limited Slip Diff, BBS CH Wheels.

2002 M Roadster, Steel Gray Metailic, Gray Nappa Leather, Black Soft Top, Steel Gray Metailic Hard Top, TC Kline Double Adj Shocks with H&R Springs, Stromung Exhaust, SSR Type C Wheels.
Reply With Quote
  #6  
Old 06-29-2015, 07:10 PM
BMWFrenzy BMWFrenzy is offline
Banned
Location: USA
 
Join Date: Jun 2015
Posts: 15
Mein Auto: 2002 BMW M Convertible
I think i'm having the same problem. Will take note of the comments here. I might need to check and see what's the real problem why the convertible top stopped working.
Reply With Quote
  #7  
Old 06-29-2015, 07:25 PM
33Bravo 33Bravo is offline
Registered User
Location: Minneapolis
 
Join Date: Jun 2015
Posts: 6
Mein Auto: M Roadster
I just figured out that on my M roadster - it was the switch in the top. Easy test - just jumpered the switch and it now works fine. I'll replace the switch.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E36/7 Z3 (1996-2002)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 02:17 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
© 2001-2015 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms