Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E30 (1982 - 1993)

E30 (1982 - 1993)
God's Chariot. The E30 was produced primarily from 1982 through 1991. The cabriolet was the one exception which was produced through 1993.

Reply
 
Thread Tools Display Modes
  #1  
Old 08-26-2009, 01:54 PM
copakeman copakeman is offline
Registered User
Location: East Coast USA
 
Join Date: Nov 2006
Posts: 9
Mein Auto: BMW ix 1989,90,91
89 325ix l & r turn signals loud buzz sound

Hello everyone. I had a blower motor problem, which turned out to be the heater switch and the resistor pack. I had taken out the consol, front heater/ac panenl, drivers side under dash cover, and the radio. I first diagnosed the switch being bad (it was), replaced it and put everything back together without trying it. the radio and turn signals worked. tried the blower, ng. i took everything apart again, now the problem was the resistor pack. i put everything back together and i have these problrms.

left and righ turn signals, both make a loud buzzing sound when turned on. no turn indicators light on the dashboard.

4 way flasher switch lights up when depressed, but no exterior lights turn on.

the radio wont turn, front panel stays black. (bmw radio).

i don't hear the power antenna motor when i turn on the radio.

the radio has the correct voltages on the power cables. i checked all the fuses with an ohm meter, they are all ok. the fuse in the radio is ok too.

the car drives great, except for the above.

i am not sure where to start on the buzzing problem. any help would be greatly appreciated by me.

thank you
c
Reply With Quote
Ads by Google
  #2  
Old 08-26-2009, 05:02 PM
copakeman copakeman is offline
Registered User
Location: East Coast USA
 
Join Date: Nov 2006
Posts: 9
Mein Auto: BMW ix 1989,90,91
fixed everything !

i had the heater/ac panel on and off at least 15 times. On the final install
i (not on purpose) swapped the rear defroster sw and the emergencty flasher sw. that was the problem.

put them in the correct slots and the turn signals/flasher worked correctly again.

i found 1 power cable that had dropped below everything, and was hidden from sight.
my fingers found it, pluggrd it in and the radio worked.

stress and panic usually fixes all.

thank you
c
Reply With Quote
  #3  
Old 08-26-2009, 05:31 PM
E30-325's Avatar
E30-325 E30-325 is offline
Officially Welcomed to the 'Fest
Location: East Coast
 
Join Date: Jun 2008
Posts: 969
Mein Auto: BMW 325is
Glad we could help
__________________
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E30 (1982 - 1993)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 08:25 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms