Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 09-01-2009, 01:36 PM
ixfedad ixfedad is offline
Registered User
Location: Iowa
 
Join Date: Sep 2009
Posts: 1
Mein Auto: 2005 X5
Unhappy 2005 X5 Whistles at high Speed

All, can you help me figure out why when I drive over 75 mph I get a very high pitched wistle like a tea kettle. It used ot only happen when the wind was blowing right, but now it happens all the time. The dealer won't drive it over 70 to hear it hence I am trying to diognose before I waste my time with them again. I also notice when I am behind larger vehicles the noise goes away, but behind a smaller car it is still there.

Any help would be great!
Reply With Quote
Ads by Google
  #2  
Old 09-01-2009, 06:38 PM
Omega Man Omega Man is offline
Registered User
Location: The Woodlands Texas
 
Join Date: Aug 2009
Posts: 2
Mein Auto: Corvette Z06
Sounds like leaky windshield. I have had vehicles in the past that had the same problem. The reason it goes away when following large vehicles is because your drafting them. When you move out into the clean air it returns.

You can try a glass shop and have them inspect it and look for any areas where the windshield may be separating or ask the dealer if it is a know issue.

Yes this is my first post here.

YMMV
Reply With Quote
  #3  
Old 09-07-2009, 05:07 PM
DJD33 DJD33 is offline
Registered User
Location: Chicago
 
Join Date: Oct 2008
Posts: 16
Mein Auto: 2008 335i sport
I recall having this issue with my 2003 540i. I fixed it by putting in the two "jack pads", which where removed by the previous owner. See here for the part: http://www.turnermotorsport.com/html...ID=51718268885

Hope this fixes it.

-DJD
Reply With Quote
  #4  
Old 09-07-2009, 05:08 PM
DJD33 DJD33 is offline
Registered User
Location: Chicago
 
Join Date: Oct 2008
Posts: 16
Mein Auto: 2008 335i sport
Correction: I put all 4 jack pads on, not just two noted in my previous reply, and it eliminated my whistle issue.
Reply With Quote
  #5  
Old 12-30-2009, 04:30 PM
seeskan seeskan is offline
Registered User
Location: Irvine, CA USA
 
Join Date: Dec 2009
Posts: 16
Mein Auto: 05 X5 4.4/05 330CIC
I have the same problem on my 2005 X5. At speeds above mph,a whistling noise starts inside front part of the ceiling. It sounds more like a tea kettle coming to boil! The strange thing is that if I slightly push or pull on front part the ceiling, the noise gets louder or stops! Could it still be a door/windscreen seal or wipers??
PS: I checked, all my jack pads are intact!
Reply With Quote
  #6  
Old 01-17-2013, 02:12 PM
seeskan seeskan is offline
Registered User
Location: Irvine, CA USA
 
Join Date: Dec 2009
Posts: 16
Mein Auto: 05 X5 4.4/05 330CIC
Easy fix!!

Got a tube of wind shield sealant (clear in color and runny Almost like Crazy Glue). Put a bead along the edge of the black rubber seal on top of the wind shield, problem solved. The tea kettle stopped boiling!!
Reply With Quote
  #7  
Old 01-18-2013, 10:29 AM
Mudnyrey Mudnyrey is offline
Registered User
Location: Beaverton, OR
 
Join Date: Jul 2012
Posts: 93
Mein Auto: X5 3.0i
I had a similar problem after I purchased new tires and had them sipped. The sound adjusted to RPM so I thought it might have been a wheel bearing noise. So without and further to do, $300 dollars later, and 3 days at the shop for diagnoses... taking the door panel off, removing and taping the drivers side mirror, they finally swapped the four tires and the sound went away.

I've never had problems with tires! So brought it back to American tire since they wereunder full warranty and they up'd me to the original Michelins.

Even though mine is rare, check the windshield and molding. If needed, purchase the "Blue" painters 3M tape and tape off your front windshield etc. and see if the problem goes away.

Regards,

Mud~
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 04:45 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms