Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 09-01-2009, 10:01 PM
nicks1k nicks1k is offline
Officially Welcomed to the 'Fest
Location: CA
 
Join Date: Apr 2007
Posts: 130
Mein Auto: 99' 540i6, 83' 533i
SES light on got multiple codes

Hi guys I purchased a new to me 540i after I crashed my 98 540iA few months ago. its a 99 540i6 I did pre purchase inspection but other then valve covers and ps hose nothing else was wrong. shortly after driving it home I got a SES light on got a computer read out for code 026 - multiplication mixture adaptation bank 1 control limit reached ; code 028 - additive mixture adaptation bank 1 control limit reached ; code 029 additive mixture adaptation bank 2 control limit reached. its intermittent sometimes check engine turns off. I noticed it sometimes stalls in reverse, and if I give it throttle then let go it alnost stalls but then rpms jump up and idle goes back to normal. I searched around came up with air leak by maf but I checked evrything seems fine. could it be the maf failing ? I also had a code 134 last time I did a read out says learning function lower stop throttle actuator could this be the reason why my car almost stalls and my idle jumps. at the moment the car has SES light on after I reset it couple of hours earlier it came back up. I had an oil change and transmission fluid flush so ar and a new belt put on it, but the SES light is bugging me lol any help or tips are greatly appreciated .
__________________
98 540iA RIP
99 540i6 Weekend driver
Reply With Quote
Advertisement
  #2  
Old 09-02-2009, 11:02 AM
nicks1k nicks1k is offline
Officially Welcomed to the 'Fest
Location: CA
 
Join Date: Apr 2007
Posts: 130
Mein Auto: 99' 540i6, 83' 533i
I also checked voltage for the MAF while car idling gave me 1.43V is that good? I thought its suppose to be around 5V?
__________________
98 540iA RIP
99 540i6 Weekend driver
Reply With Quote
  #3  
Old 09-02-2009, 01:15 PM
nicks1k nicks1k is offline
Officially Welcomed to the 'Fest
Location: CA
 
Join Date: Apr 2007
Posts: 130
Mein Auto: 99' 540i6, 83' 533i
bumpity bump..can this be related to o2 sensors ?
__________________
98 540iA RIP
99 540i6 Weekend driver
Reply With Quote
  #4  
Old 09-02-2009, 04:01 PM
nicks1k nicks1k is offline
Officially Welcomed to the 'Fest
Location: CA
 
Join Date: Apr 2007
Posts: 130
Mein Auto: 99' 540i6, 83' 533i
ehh anybody? lol

heres some data i got off the diagnostic reader from the car while
it was idling after the SES light was cleared. (but came back 3 hours later)

Air mass=21.8kg/h

Air-mass-flow voltage value = 1.41V <<
Camshaft position = 0.00 cr bank 1
Camshaft position = -0.11 cr bank 2 (negative could that be something?)

Adaptation angle 1 crankshaft sensor gear bank 1 =4.60 cr
Adaptation angle 2 crankshaft sensor gear bank 1 =7.07 cr
Adaptation angle 3 crankshaft sensor gear bank 1 =7.29 cr
Adaptation angle 4 crankshaft sensor gear bank 1 =5.07 cr
Adaptation angle 5 crankshaft sensor gear bank 2 =1.96 cr
Adaptation angle 6 crankshaft sensor gear bank 2 =2.26 cr
Adaptation angle 7 crankshaft sensor gear bank 2 =2.24 cr
Adaptation angle 8 crankshaft sensor gear bank 2 =0.69 cr

Additive mixture adaptation (idle) bank 1 = -6.18ms < is it suppose to be negative?

Additive mixture adaptation (idle) bank 2 = -5.67ms < is it suppose to be negative?

Multiplicative mixture adaptation (part load) bank 1 = -0.03%
is it suppose to be negative?

Multiplicative mixture adaptation (part load) bank 2 = -0.02%
is it suppose to be negative?

Throttle-valve position (at idle) 2.35%

Voltage throttle potentiometer 1 0.63V ~~~i think this
is why i got the throttle actuator learning function code 134

Voltage throttle potentiometer 2 4.36V

Aver. rough running cylinder 1 0.139 1/s
Aver. rough running cylinder 2 0.056 1/s
Aver. rough running cylinder 3 0.200 1/s
Aver. rough running cylinder 4 0.000 1/s
Aver. rough running cylinder 5 0.014 1/s
Aver. rough running cylinder 6 0.000 1/s
Aver. rough running cylinder 7 -0.197 1/s is it suppose to
be negative?
Aver. rough running cylinder 8 -0.192 1/s is it suppose to
be negative?
__________________
98 540iA RIP
99 540i6 Weekend driver
Reply With Quote
  #5  
Old 09-02-2009, 04:55 PM
bmw_n00b13's Avatar
bmw_n00b13 bmw_n00b13 is offline
Freude am Fahren
Location: Cambridge, ON
 
Join Date: Feb 2008
Posts: 6,372
Mein Auto: 99 528iA
Vacuum or intake leak?

I assume negative means below par, positive means above par.
__________________
'99 528i ('98/12 build). 174,000km BY29428/Royalrot
Breaking My Wallet since 2009
Mods: Stoptech SS brake hose, 280piece toolkit resting on trunk floor, Beisan VANOS seals
'99 540i (grandfather's)

Reply With Quote
  #6  
Old 09-03-2009, 07:34 PM
nicks1k nicks1k is offline
Officially Welcomed to the 'Fest
Location: CA
 
Join Date: Apr 2007
Posts: 130
Mein Auto: 99' 540i6, 83' 533i
yeah I looked at the part where MAF connects to airbox filter seems to be some what loose ill get new rubber that goes in between see if that works. if not ill go to the indy next week, can't stand ses light on my dash
__________________
98 540iA RIP
99 540i6 Weekend driver
Reply With Quote
  #7  
Old 09-03-2009, 09:26 PM
ztom's Avatar
ztom ztom is offline
I gotta have more cowbell
Location: Thousand Oaks CA
 
Join Date: Sep 2007
Posts: 857
Mein Auto: 1997 528i
idle control valve or CVV?
Reply With Quote
  #8  
Old 09-03-2009, 11:07 PM
nicks1k nicks1k is offline
Officially Welcomed to the 'Fest
Location: CA
 
Join Date: Apr 2007
Posts: 130
Mein Auto: 99' 540i6, 83' 533i
i have a 99 540i so there is no ICV right? Im not sure about CCV can someone confirm please?
__________________
98 540iA RIP
99 540i6 Weekend driver
Reply With Quote
  #9  
Old 09-03-2009, 11:14 PM
nicks1k nicks1k is offline
Officially Welcomed to the 'Fest
Location: CA
 
Join Date: Apr 2007
Posts: 130
Mein Auto: 99' 540i6, 83' 533i
also if im going to replace CCV what else should i replace while im at it ?
__________________
98 540iA RIP
99 540i6 Weekend driver
Reply With Quote
  #10  
Old 09-03-2009, 11:17 PM
bmw_n00b13's Avatar
bmw_n00b13 bmw_n00b13 is offline
Freude am Fahren
Location: Cambridge, ON
 
Join Date: Feb 2008
Posts: 6,372
Mein Auto: 99 528iA
Have a look here: http://www.bimmerfest.com/forums/sho...d.php?t=379225
__________________
'99 528i ('98/12 build). 174,000km BY29428/Royalrot
Breaking My Wallet since 2009
Mods: Stoptech SS brake hose, 280piece toolkit resting on trunk floor, Beisan VANOS seals
'99 540i (grandfather's)

Reply With Quote
  #11  
Old 09-03-2009, 11:30 PM
sddale sddale is offline
Officially Welcomed to the 'Fest
Location: San Diego
 
Join Date: May 2004
Posts: 121
Mein Auto: 2000 540iA
Quote:
Originally Posted by nicks1k View Post
also if im going to replace CCV what else should i replace while im at it ?
When I had mine done all the intake gaskets and the one in front...I think these are the part numbers:

11-61-7-501-563 COVER 1
11-61-1-729-727 PROFILE-GASKET 1
11-61-1-433-328 PROFILE-GASKET 4
13-54-7-510-433 PROFILE-GASKET 1

My car ran so much better after replacing all the gaskets.

00 540iA
155kmi
Reply With Quote
  #12  
Old 09-04-2009, 09:30 AM
nicks1k nicks1k is offline
Officially Welcomed to the 'Fest
Location: CA
 
Join Date: Apr 2007
Posts: 130
Mein Auto: 99' 540i6, 83' 533i
thanks im going to try and do same see if that clears the SES
__________________
98 540iA RIP
99 540i6 Weekend driver
Reply With Quote
  #13  
Old 09-07-2009, 04:11 PM
nicks1k nicks1k is offline
Officially Welcomed to the 'Fest
Location: CA
 
Join Date: Apr 2007
Posts: 130
Mein Auto: 99' 540i6, 83' 533i
Well thought id give an update. On saturday i decided to take off the throttle and clean it because it would stick sometimes when going in neutral from reverse. So i got some throttle cleaner, took the throttle off cleaned it let it dry, also cleaned my MAF with CRC maf cleaner. Once all seemed to be dried up i put everything back together. One thing i noticed because of the valve cover leaks ther was a lot of sludge around the bottom of throttle, and some of it was getting inside because the back of the throttle plate was black from oil etc. Anyhow i put throttle back on made sure all the screws tight, also checked the intake manifold and re-torqued all the screws. I started the car Engine Fail safe prog came up, i turned it off and unplugged the battery. Then started the car again no check engine or engine fail safe, the throttle response is amazing, no more jump at idle while going from reverse to neutral. Idle is very smooth. Im still wondering if the check engine light going to come back for that vacuum leak or not so ill see in few days.
__________________
98 540iA RIP
99 540i6 Weekend driver
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 08:32 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms