Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)

E34 (1989 - 1995)

Reply
 
Thread Tools Display Modes
  #1  
Old 11-29-2009, 01:24 PM
MissQwavoo MissQwavoo is offline
MissQwavoo
Location: salem oregon
 
Join Date: Nov 2009
Posts: 3
Mein Auto: 95 bmw 530i
my car wont start :(

someone help me please..my car wont start.....i want to buy a new batter but what if thats not the problem? lights turn on, the car just wont start. any ideas on what it could be?
Reply With Quote
Ads by Google
  #2  
Old 11-29-2009, 06:09 PM
BrothaMansWhip2's Avatar
BrothaMansWhip2 BrothaMansWhip2 is offline
Blue Miracle Whip
Location: Ann Arbor, Michigan
 
Join Date: Apr 2008
Posts: 316
Mein Auto: e34 touring 525I
can you be a little more specific? Like when it started doing it? Are the other accessories working?
__________________
Went from a 87 e30 with Stick Shift,
To a 92/3 e34 Touring with an M50 in it!

88 e30
87 e30
1992/3 525I Touring
Reply With Quote
  #3  
Old 11-30-2009, 11:01 AM
MissQwavoo MissQwavoo is offline
MissQwavoo
Location: salem oregon
 
Join Date: Nov 2009
Posts: 3
Mein Auto: 95 bmw 530i
lights turn on...makes a weird clicking noise when i try to start it..thought it was the battery, but if it was the battery lights wouldnt turn on right??

well....it first broke down on the freeway..got it towed to a gas station..put half a tank....still didnt turn on....its gay. im pissed off
Reply With Quote
  #4  
Old 11-30-2009, 06:11 PM
BrothaMansWhip2's Avatar
BrothaMansWhip2 BrothaMansWhip2 is offline
Blue Miracle Whip
Location: Ann Arbor, Michigan
 
Join Date: Apr 2008
Posts: 316
Mein Auto: e34 touring 525I
I'd lean towards the starter or alternator..Were you able to jump it?
__________________
Went from a 87 e30 with Stick Shift,
To a 92/3 e34 Touring with an M50 in it!

88 e30
87 e30
1992/3 525I Touring
Reply With Quote
  #5  
Old 12-02-2009, 08:10 AM
Dynamic Entry Dynamic Entry is offline
Registered User
Location: Calgary, AB
 
Join Date: Aug 2009
Posts: 4
Mein Auto: 1990.5 e34 525 iA
OP please let us know everything you tried. Finding out the reason a car won't start can take a lot of trial and error.

Did this all happen suddenly or did the problem develop over time and finally climax now? As asked above, did you try to jump it? The starter clicking but not cranking over sounds like it isn't getting enough juice. If you can jump it, then there is very good reason to suspect your battery needs replacing. If jumping it doesn't help than we can suspect your connections between the battery and the starter or the starter itself, or possibly something else.

The last time my e34 didn't start it ended up being the Crank Position Sensor was shot. It took me a lot of internet time, pulling timing and valve covers, spark plugs and checking the timing chain and a lot of help from others to figure it out.

The last time my Subaru didn't start, all I needed was to clean the battery terminal connections. For what it is worth, the lights and accessories worked fine, it just wouldn't crank. This made me wonder about the battery health and the starter motor, but no it was more simple.

Electrical connections are strange and finicky, diagnosing them can be reallly fun sometimes.

Last edited by Dynamic Entry; 12-02-2009 at 08:17 AM.
Reply With Quote
  #6  
Old 12-02-2009, 03:40 PM
WhoNew WhoNew is offline
New Guy of the Month
Location: Oak Lawn IL
 
Join Date: May 2008
Posts: 187
Mein Auto: 98 528i 96 318iC
Lights and other accessories use a fraction of the power it takes to turn the starter motor over.

From what it sounds like in the limited OP, sounds like the battery needs a charge.
__________________
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 08:35 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms