Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 12-10-2009, 03:03 PM
hanzo540i hanzo540i is offline
Registered User
Location: Tucson, AZ
 
Join Date: Jan 2007
Posts: 5
Mein Auto: 2009 X5 35d
Right turn signal won't cancel

Howdy all.
On my 99 540i the right turn signal works in the neutral, or in the right position, as long as the key is on, or if the car is running. When I turn the key off the turn signals stop flashing. The left side appears to work fine, but if I return the stalk back to the center position, or the right position, the right side starts flashing. All of the turn signal lights, front and rear work like they should, (flash at normal speed) and the dash indicator lights work fine.

I haven't modified anything within the light system, factory Xenon system. I don't think it is the LCM, since they stop flashing when I turn the key off. I am at a loss. Anyone out there have any ideas? Maybe the turn signal stalk is bad?

Thanks.
Reply With Quote
Advertisement
  #2  
Old 12-10-2009, 08:47 PM
bmw_n00b13's Avatar
bmw_n00b13 bmw_n00b13 is offline
Freude am Fahren
Location: Cambridge, ON
 
Join Date: Feb 2008
Posts: 6,372
Mein Auto: 99 528iA
Probably the turn signal stalk. http://www.bimmerboard.com/forums/posts/551946
__________________
'99 528i ('98/12 build). 174,000km BY29428/Royalrot
Breaking My Wallet since 2009
Mods: Stoptech SS brake hose, 280piece toolkit resting on trunk floor, Beisan VANOS seals
'99 540i (grandfather's)

Reply With Quote
  #3  
Old 12-11-2009, 07:33 AM
hanzo540i hanzo540i is offline
Registered User
Location: Tucson, AZ
 
Join Date: Jan 2007
Posts: 5
Mein Auto: 2009 X5 35d
Thanks for the great writeup. It will make this job much easier! By the way I disconnected the battery last night, to try to reset everything and when I reconnected the battery, the right parking lights came on... another indication that the stalk is broken internally.

Thanks again for your help.
Reply With Quote
  #4  
Old 12-11-2009, 08:23 AM
bmw_n00b13's Avatar
bmw_n00b13 bmw_n00b13 is offline
Freude am Fahren
Location: Cambridge, ON
 
Join Date: Feb 2008
Posts: 6,372
Mein Auto: 99 528iA
Yep, guess you have the new LCM with the one-side signal lights.

If it's not the stalk, it's probably the LCM or trunk wiring harness. Try to find a used stalk though, new ones are pretty shockingly expensive.

e38.org is an overlooked, excellent resource!
__________________
'99 528i ('98/12 build). 174,000km BY29428/Royalrot
Breaking My Wallet since 2009
Mods: Stoptech SS brake hose, 280piece toolkit resting on trunk floor, Beisan VANOS seals
'99 540i (grandfather's)

Reply With Quote
  #5  
Old 12-12-2009, 12:54 PM
hanzo540i hanzo540i is offline
Registered User
Location: Tucson, AZ
 
Join Date: Jan 2007
Posts: 5
Mein Auto: 2009 X5 35d
Yeah, I know what you mean. I did find a used switch for $30. It will take a couple of days to ship though. I went through all of the wiring pretty good and checked everything, including all of the grounding points.

I took apart the old switch and nothing looks bad... maybe one of the tiny resistors has gone out, time will tell when I get in the new switch.

All of the part numbers I found said that if the car was built before 02/99, then it has one type of switch, if it was built after 02/99 then it used the latter type. My car was built on 11/98, but it has the latter type of switch... weird. Maybe this has something to do with the Sport package?

Anyhow, I'll wait for the new switch and see what happens. Thanks again for your help.
Reply With Quote
  #6  
Old 04-22-2014, 10:11 PM
bluebee's Avatar
bluebee bluebee is offline
Seek to understand,^Value
Location: San Jose, California
 
Join Date: Mar 2008
Posts: 21,248
Mein Auto: 02 BMW 525i M54 auto 130K
See also:
> E39 (1997 - 2003) > Turn signal stalk locked into position, until I forced it, & something snapped!
> E39 (1997 - 2003) > Turn signal/high beam switch repair
> E39 (1997 - 2003) > Turn signal wont reset after I make a turn
__________________
Each repair should invariably add to our knowledge base by the process of inexorable incrementalism.
Your job, in return, is to read the suggested threads, where the best people will always add value to those threads, either by pictures or by descriptions, so the next person with the same problem stands on your shoulders.
See also: E39 Bestlinks & How to easily find what you need
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 01:47 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms