Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)

X3 E83 (2004 - 2010)
Talk about the E83 BMW X3 in this forum!

Reply
 
Thread Tools Display Modes
  #1  
Old 12-10-2009, 09:18 PM
figman figman is offline
Registered User
Location: Westchester County, NY
 
Join Date: Nov 2009
Posts: 28
Mein Auto: Mitsubishi
Unhappy First Problem with X3

Here it goes, I took the X3 to the dealer to show them 3 small chips/cracks on the windshield. I test drove it twice and did not see it. The first night when we got it home we decided to go for a evening drive, I was impressed with the Xenon lights but while the wife is driving I noticed the windshield. First I was pissed becaused that was supposed to be check by whoever certified the truck. Within 24 hours upon delivery I stopped by the dealer and spoke with the salesman. Right away he said they will take care of it and gave an appointment. This past Tuesday I dropped it off and got the loaner that I mentioned on my other post. Later, I got a call saying that they need it to replace the windshield and at first I was happy but then a bit sceptical. So I got the truck back today, drove to work and then home, soon after we decided to go christmas shopping. Everything was fine until we got a couple miles from home on the way back , all of the sudden I start hearing a rattle in the lower section of the windshield. I got the truck for just under two weeks and never heard the rattle, now it looks like the dealer did not wait long enought to let the sealant cure and the glass sounds like got separated in the lower section. the upper section still has the clear tape they put on the outside. The lower section it looks like is held in place by a rubber molding. I am afraid to remove the tape in the top, but I am heading back to the dealer first thing tomorrow morning. It is my luck? do you think they will fix it again withoug given me hassle? I believe the cold weather in the area did not help, around 30 degrees. Now the wife is upset, I am concerned that in the long run and due to the stiff suspension this will happen again.

What do you think? so far I have a good impression from the dealership
Reply With Quote
Advertisement
  #2  
Old 12-10-2009, 10:49 PM
Sonoman707 Sonoman707 is offline
Officially Welcomed to the 'Fest
Location: Healdsburg, CA
 
Join Date: Oct 2004
Posts: 682
Mein Auto: 2008 X3 3.0si
Driviing in below freezing temps right after installation probably not a great idea - especially given the stiff suspension.

That said - a windshield isn't that big of deal... what - $300 - $400 installed? Wait until summer for the next replacement.
Reply With Quote
  #3  
Old 12-11-2009, 09:58 AM
UncleJ UncleJ is offline
Officially Welcomed to the 'Fest
Location: Silicon Valley
 
Join Date: May 2006
Posts: 6,553
Mein Auto: '06 X3
Fig, they fixed it and it wasn't done right, let them do it again and this time keep it in the barn overnight while the sealant cures instead of sticking it out in the back lot. I doubt the stiff suspension caused it as opposed to the freezing weather you have. Good luck!
Reply With Quote
  #4  
Old 12-11-2009, 02:29 PM
X3emist's Avatar
X3emist X3emist is offline
Officially Welcomed to the 'Fest
Location: NW Georgia USA
 
Join Date: Nov 2009
Posts: 1,311
Mein Auto: 06 X3 Sport
Make them fix it

you don't want to wait until warmer weather and no need to. You do not want a leak which is another possibility.
Reply With Quote
  #5  
Old 12-11-2009, 04:07 PM
X3-terrestrial's Avatar
X3-terrestrial X3-terrestrial is offline
Aficionado
Location: N.Miss - Memphis,TN Area
 
Join Date: Aug 2008
Posts: 2,631
Mein Auto: '05 X3, '95 M3, '89 MkI
All work performed by a delear has individual warranty of 1 year/10,000 miles. They will make it right.
Reply With Quote
  #6  
Old 12-11-2009, 06:35 PM
mikelahti mikelahti is offline
Officially Welcomed to the 'Fest
Location: Long Island, New York
 
Join Date: May 2008
Posts: 105
Mein Auto: 2008 X3
This looks like a minor problem to be taken care of by the dealer.

Major problem: paragraph posts so we can read them. Densely packed text will cross your eyes.
__________________
2008 BMW X3
2006 Porsche 997 2S Cabrio
Reply With Quote
  #7  
Old 12-11-2009, 06:37 PM
jammat jammat is offline
Officially Welcomed to the 'Fest
Location: In transit
 
Join Date: Jul 2006
Posts: 661
Mein Auto: 335i xDrive Coupe
Quote:
Originally Posted by Sonoman707 View Post
Driviing in below freezing temps right after installation probably not a great idea - especially given the stiff suspension.

That said - a windshield isn't that big of deal... what - $300 - $400 installed? Wait until summer for the next replacement.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 05:19 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms