Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 01-19-2010, 02:06 PM
chaddc chaddc is offline
Registered User
Location: Ohio
 
Join Date: Jan 2010
Posts: 3
Mein Auto: 1999 BMW 528i
Question 528i Problems

Yes, I have read the thousands of articles with the 1999 528i ABS, TSC lights, and speedometer not working. However, I would like to share my personal experience to maybe get some help. Last winter my TSC and Abs lights would come on and off randomly. It became more and more common over time that the would be on. Then it got to when I would start my car they would be off but once backing out of my drive as soon as Id start to brake their would be a weird grinding noise and they would come on (grinding noise would then go away). During this time my speedometer always worked. However, this past Christmas eve it stopped. Throught the next week or two it would work and then stop again so I began reading. One said pack Abs in dry ice and if it works then its your module that is bad. Well in Ohio its been 10 degrees at night and wasnt working as soon as I started the car so I went to option two. Really hoped that it was the infamous driver side rear speed sensor. So I ordered one from Ebay (only $45 with shipping) Read how to do it (VERY EASY, email me if you need to know how) and still no luck. So I thought possibly someones info may have been wrong and put the new sensor on the passenger rear side. Still no luck. So today I took it to the BMW dealer, paid $110 for the diagnostics, just to be told its the ABS module, but might be a sensor too. But with the module being bad they cant diagnostic past that point to tell in any or all sensors are bad. So I hear modulemaster is very reputable. Checked out their website and one of their questions is " Why they arent the cheapest". So to some this up... If anyone has any idea about my car, any questions, or need help, or know of module rebuilds for less, please let me know. Thank you guys. chaddcline@yahoo.com
Reply With Quote
Ads by Google
  #2  
Old 01-19-2010, 02:47 PM
Rgol Rgol is offline
Officially Welcomed to the 'Fest
Location: NashVegas TN
 
Join Date: Nov 2002
Posts: 341
Mein Auto: '99 528i Sport 5-spd
I had the same probloem. My mechanic took out my ABS module and shipped it to a company to repair and rebuild it. I have been driving all week with all the lights on and no speedo. I will get it tomorrow and have it put back in. I will find out where he sent it.
__________________
1999 Dinan 5 | 528is 5-Speed
Reply With Quote
  #3  
Old 01-19-2010, 02:53 PM
chaddc chaddc is offline
Registered User
Location: Ohio
 
Join Date: Jan 2010
Posts: 3
Mein Auto: 1999 BMW 528i
Would greatly appreciate it. I see where its at and is only literally 6 bolts. simple enough but if there are cheaper places out there that do just as good of work then Ill take it. They offered me $200 trade in for my car, never in my life did I feel so insulted. A 1999 528i (with the package that has heated steering wheel and 6 disc cd changer) with only 85,000 miles and they offered me $200 hahaha. I appreciate your help. Thanks!
Reply With Quote
Reply

Bookmarks

Tags
help needed


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 12:23 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms