Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)

X3 E83 (2004 - 2010)
Talk about the E83 BMW X3 in this forum!

Reply
 
Thread Tools Display Modes
  #1  
Old 07-14-2014, 09:56 PM
63ajr 63ajr is offline
Registered User
Location: Australia
 
Join Date: Jul 2014
Posts: 1
Mein Auto: 2004 X3
Red face 2004 X3 and the wiper washer

I have an 2004 X3 and the wiper washer does not work. There is water in the reservoir but neither the front or rear pumps work.

I have checked the fuses and they seem fine. How can I check the pumps? Is there one for the front and one for the rear?
Reply With Quote
Advertisement
  #2  
Old 07-15-2014, 06:36 AM
Supercourse Supercourse is offline
Officially Welcomed to the 'Fest
Location: British Columbia, Canada
 
Join Date: Feb 2008
Posts: 3,450
Mein Auto: 2004 X3 2.5i
2 pumps, side by side.

Check that their electrical connectors are in place, and not corroded.

You should be able to confirm if 12V is getting to that point when stalk operated.

When was last time they worked? Unlikely that both pumps would go out together, but possible I suppose.

Be careful you are not pumping water into the car interior because of a break in the line.
Reply With Quote
  #3  
Old 07-15-2014, 08:53 AM
swampX3 swampX3 is offline
Officially Welcomed to the 'Fest
Location: New Orleans
 
Join Date: May 2013
Posts: 1,169
Mein Auto: X3 and 330
a good link/pics

part no 4 for the pumps .....they pull out easily

http://realoem.com/bmw/showparts.do?...36&hg=61&fg=45

also ....if you buy new then add a few $$$$ for the filter/grommet combo the plug suction sits in....they are part no 5 .....get one for each pump

http://realoem.com/bmw/diagrams/j/w/196.png

Last edited by swampX3; 07-15-2014 at 08:55 AM. Reason: add info
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 10:36 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
© 2001-2015 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms