Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E46 (1999 - 2006)

E46 (1999 - 2006)
The fourth generation 3 Series (E46 chassis) was introduced in 1999 and set the standard for engineering and performance during it's years of production including being named to Car & Driver's 10 best list every one of those years! ! -- View the E46 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 03-15-2010, 05:33 PM
CaptainTrap's Avatar
CaptainTrap CaptainTrap is offline
a man made of men like me
Location: Bethel, CT
 
Join Date: Jun 2007
Posts: 839
Mein Auto: 2001 330i 5MT ZSP
My car went into limp mode twice today

I pulled over and shut it down, followed by a restart and it went back to normal. I have had the Service Engine Soon light on 2 times this month but it cleared itself. When i got home I hooked it up to my laptop and used carsoft 6.5 to scan it and this is what it found:

-DME Module: ~Idle Speed Actuator (Mechanical Jamming)
~Mixture Deviation: bank 1
~Mixture Deviation: bank 2

-Instrument Cluster Module: ~D7 Fuel Tank Sensor 2 (without fuel pump)
~EGS signal disturbed

-ABS/ASC Module: ~Pressure Sensors
~CAN ERROR: Engine Speed (RPM)

-ZKE/ZVM Module: ~Pin Contact, Drivers Door
~Relay for rear FH drive (passenger's side) sticks

can anyone interpret these error codes and identify anything that may be causing the EML and ABS lights to go on and go into limp mode? thanks
__________________
2001 330i ZSP 5MT H&R Sport Cup Kit 18" VMR v710 18x8.5

BMW CCA #: 399644
Reply With Quote
Advertisement
  #2  
Old 03-15-2010, 07:31 PM
cmccurdy1 cmccurdy1 is offline
Registered User
Location: Jasper, Georgia
 
Join Date: Aug 2009
Posts: 3
Mein Auto: 325ci
Don't know about the codes but my M3 was doing that-ABS and EML lights come on and a few second later it goes into limp mode. Turn it off and start it up, everythings fine - it does it again in about 30 minutes. Replaced throttle postion sensor and its been fine ever since
Reply With Quote
  #3  
Old 03-15-2010, 07:33 PM
cmccurdy1 cmccurdy1 is offline
Registered User
Location: Jasper, Georgia
 
Join Date: Aug 2009
Posts: 3
Mein Auto: 325ci
Don't know about the codes but my M3 was doing that-ABS and EML lights come on and a few second later it goes into limp mode. Turn it off and start it up, everythings fine - it does it again in about 30 minutes. Replaced throttle position sensor and its been fine ever since
Reply With Quote
  #4  
Old 03-15-2010, 07:36 PM
Fast Bob's Avatar
Fast Bob Fast Bob is offline
Keeping it surreal
Location: Here, there, everywhere....
 
Join Date: Jun 2004
Posts: 34,506
Mein Auto: 2004 330Ci ZHP 3 pedals
My car went into limp mode twice today

Try some Extenze in the gas tank....
__________________
The road goes ever onward....
(R.I.P. Jever)

*Please support the Wounded Warrior Project*

When faced with choosing between two evils, always go with the one you`ve never tried before....
Reply With Quote
  #5  
Old 03-15-2010, 10:19 PM
CaptainTrap's Avatar
CaptainTrap CaptainTrap is offline
a man made of men like me
Location: Bethel, CT
 
Join Date: Jun 2007
Posts: 839
Mein Auto: 2001 330i 5MT ZSP
lol
__________________
2001 330i ZSP 5MT H&R Sport Cup Kit 18" VMR v710 18x8.5

BMW CCA #: 399644
Reply With Quote
  #6  
Old 03-16-2010, 12:58 AM
mujjuman mujjuman is offline
tappa tappa toit
Location: NY
 
Join Date: Feb 2009
Posts: 4,687
Mein Auto: hoopty
Quote:
Originally Posted by Fast Bob View Post
Try some Extenze in the gas tank....
lol

remove the ICV... see if its actually stuck/dirty/not free...
clean it up real good, set to dry. reassemble.... see if problem persists.
__________________
mujjuman
Reply With Quote
  #7  
Old 03-16-2010, 10:44 AM
catso's Avatar
catso catso is offline
catso
Location: Chicago
 
Join Date: Dec 2009
Posts: 2,956
Mein Auto: 2000 323i, 1988 528e
Quote:
Originally Posted by Fast Bob View Post
Try some Extenze in the gas tank....
Reply With Quote
  #8  
Old 03-16-2010, 07:38 PM
CaptainTrap's Avatar
CaptainTrap CaptainTrap is offline
a man made of men like me
Location: Bethel, CT
 
Join Date: Jun 2007
Posts: 839
Mein Auto: 2001 330i 5MT ZSP
ok last night i cleared the codes (please note that the SES light is not on nor has been on save for the two occasions i already mentioned. It is usually not on.) And today it went into limp mode again, EML light and ABS light came on and car was sluggish. Shut down and turn back on and its back to normal.

I just got home from work and scanned it again and here is what i got.

DME Module: Mixture Deviation Bank 1 and Bank 2
~and~
Idle Speed Actuator (mechanical jamming)

Instrument Cluster Module: EGS Signal Disturbed

After some superficial research i have found that the EGS is the e46 transmission computer control module. What could be causing this disturbance? are these problems related?

The Idle Speed Actuator is what we call the Idle Control Valve or ICV. When i was chasing my mixture deviation codes several weeks/months ago and had my airbox out i cleaned the ICV and it appeared to be in good working order. I guess Ill take it out on thursday and give it a cleaning as mujjuman suggested. hopefully a good cleaning will remove whatever is jamming it. the funny thing is tho my idle is smooth as butter with no surges. I hope this is related to my new mixture deviation codes because i thought i put those to rest after the leaky valve cover gasket was replaced. is this a reasonable thought?

Anyone else have any ideas? thanks
__________________
2001 330i ZSP 5MT H&R Sport Cup Kit 18" VMR v710 18x8.5

BMW CCA #: 399644
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E46 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 09:25 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms