Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)

X3 E83 (2004 - 2010)
Talk about the E83 BMW X3 in this forum!

Reply
 
Thread Tools Display Modes
  #26  
Old 12-22-2012, 08:07 PM
fivepointnine fivepointnine is offline
Officially Welcomed to the 'Fest
Location: Somerset, UK
 
Join Date: Jul 2011
Posts: 359
Mein Auto: BMW X3, Hyundai Genesis
from what I understand alot of these problems are traced back to the master light switch, I think there is even a SIB for it.
Reply With Quote
  #27  
Old 12-23-2012, 05:05 AM
alpha1 alpha1 is offline
Registered User
Location: Nairobi
 
Join Date: Dec 2012
Posts: 7
Mein Auto: BMW X3
I hear you Evlengr. There's a lot of expensive (on the part of BMW owners) assumptions made by the dealer here.

Turns out the problem was a short in the ignition system. Car's back to normal.
Reply With Quote
  #28  
Old 12-25-2012, 08:35 AM
brunke brunke is offline
Registered User
Location: Mobile Al
 
Join Date: Dec 2012
Posts: 23
Mein Auto: 08 X3, 08 Harley FLSTC
Electrical heaven!

I have a problem with washer pumps and caused some others doing a temporary fix. I wired a toggle switch to operate the pump and ran wires through the dash panel assembly. In the process, I disconnected a couple of small plugs in a terminal under the radio fascia cover. It knocked out the ac and we were leaving on a trip. Fortunately, I went to the last place I touched and found the plug out of place - a very delicate connection - no firm latch.
Reply With Quote
  #29  
Old 04-25-2013, 05:10 AM
alpha1 alpha1 is offline
Registered User
Location: Nairobi
 
Join Date: Dec 2012
Posts: 7
Mein Auto: BMW X3
Evlengr. I can see that you do not have your X3 any more...
Reply With Quote
  #30  
Old 09-10-2013, 02:23 AM
qpid qpid is offline
Registered User
Location: Nairobi
 
Join Date: Sep 2013
Posts: 1
Mein Auto: X3
Alpha1 I am in Nairobi....Kindly inbox me the contacts of the mechanic who diagnosed your issue. Thanks.
Reply With Quote
  #31  
Old 10-28-2014, 05:57 PM
Feyd ipo3 Feyd ipo3 is offline
Registered User
Location: New York
 
Join Date: Jun 2014
Posts: 12
Mein Auto: 2015 235i
Had 2014 x3 with all sorts of electrical issues including, wipers on when car off, lights flashing, screen going dim then bright and many more. After 4 months BMW replaced. God bless. New car has some electrical issues it bearable. I love this new BMW I will deal with it. Have heard many new owners having problems. Love BMW. Let's hope they fix it. Good luck with problem. Let us know
Reply With Quote
  #32  
Old 09-14-2015, 06:39 PM
luke chipman luke chipman is offline
Registered User
Location: franklin tn
 
Join Date: Sep 2015
Posts: 1
Mein Auto: 04 x3 3.0i
04 x3 3.0i just died in the middle of the road

i turned the key off and back on and it started right back up -what have i got myself into ?
only had this thing less than thirty days!!
Reply With Quote
  #33  
Old 01-11-2017, 01:31 PM
lindyluu lindyluu is offline
lindy
Location: utah
 
Join Date: Jan 2017
Posts: 5
Mein Auto: 2005 x3
Quote:
Originally Posted by sexipink View Post
I have a 2005 X3 with about 50k miles and about 2 months ago I started having electrical problems. 1st it started with my inside lights flickering on and off, and my radio shutting off. The inside lights flickered for a couple of days then stopped, but my radio still ocassionaly shuts off. Then I noticed that my outside lights wouldnt work when on auto, but worked fine when I manually turned them on. My seat & steering warmer, and back windshield wiper no longer work as well.

My car is no longer under warranty with Bmw, but I do have a third party warranty that covers eletrical problems. So I took it into Bmw last thursday. After 6 days of having my car they still dont know what the problem is. So finally they called me today saying they think they know what the problem is (what do you mean think). They claim it appears someone spilled something on the passenger side and its all over the wires because there very sticky, and since it appears to be a spill most likely my warranty wont cover it. So for them to finish diagnosing the problem its going to cost me $750, and thats not including whatever the cost is to fix this unknown problem.


This just sounds like a bunch of BS to me, I would think the wires wouldve been the 1st place they looked especially since they said these wires run into everything im having problems with. It took them 6 days to find this???
So needless to say im picking my car back up with the same promblems it had when I dropped it off. And on top of that I have to pay them $100.00 for the diagnostics when they didnt even actually tell me what the problem is.



Sorry for the loooonng post, but can someone please help me. Do you think what their saying makes sense?? (mind you I dont recall anyone spilling anything in my car). Does anyone know someone in the Northen NJ area that deals with bmw electrical problems???
seems you are having the same problems I am currently having. Did you resolve this??
if so how?? I have replaced the starter and the alternator twice, then was told it was the ignition relay and replaced the ignition and is still not staying charged.
Reply With Quote
  #34  
Old 01-11-2017, 01:50 PM
lindyluu lindyluu is offline
lindy
Location: utah
 
Join Date: Jan 2017
Posts: 5
Mein Auto: 2005 x3
I have replaced the starter and the alternator twice, then was told it was the ignition relay and replaced the ignition and is still not staying charge.
Anyone know what causes this to happen??
Reply With Quote
  #35  
Old 03-30-2017, 06:27 PM
TanjeeRides's Avatar
TanjeeRides TanjeeRides is offline
Officially Welcomed to the 'Fest
Location: New York
 
Join Date: Jan 2013
Posts: 184
Mein Auto: X5
So what was the issue he found alpha1?
__________________
Hot chick working on her hot car what could be better?
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 11:34 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
© 2001-2015 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms