Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)

E34 (1989 - 1995)

Reply
 
Thread Tools Display Modes
  #1  
Old 04-14-2010, 09:37 PM
remuse remuse is offline
Registered User
Location: Southern California
 
Join Date: Oct 2006
Posts: 17
Mein Auto: '04 545
Onboard Computer display/clock not working

My onboard computer display/clock does not appear to be displaying the clock anymore on my '95 525i. It appears to be the display only.

Could someone advise how to fix this based on their experience? Is this a DIY or do I need to take it into either a shop/dealer. Any thoughts on the cost of the part/parts?

Thanks in advance.
Reply With Quote
Ads by Google
  #2  
Old 04-15-2010, 05:42 AM
BMR_LVR's Avatar
BMR_LVR BMR_LVR is offline
Humble E34 lover
Location: Asheboro, NC
 
Join Date: Dec 2008
Posts: 5,264
Mein Auto: 1992 525i
I had a similar situation on the clock of my E36. The two units are somewhat different, but it may be the same solution.

All I had to do was remove the unit and replace a couple of the bulbs in the back. It was easy to do and fixed the problem. One thing I noticed when mine failed was that if the sun was coming through my rear window, I could still barely see the clock and it was showing the correct time, therefore I knew the clock was functioning, I just could not see it properly. So, the new bulbs fixed it.

I don't know if you have this or not, but here is a link to the Bentley manual that may show how to remove the unit (I haven't read it specificall for the 34, but the Bentley for the E36 did show how to do it on that car).

http://www.bimmerwerkz.com/forum/5-s...0-a-42558.html

Hope this helps,
Steve
__________________
Most problems are usually something simple !

Quote:
Originally Posted by noego View Post
It's Deja Poo - as in, I've heard this **** before.
Steve

Calypso Red 1992 525i with 200K miles

1991 735i - Sold
1992 525i - Sold
1995 325is - Sold
2000 528i - Sold

Reply With Quote
  #3  
Old 04-15-2010, 08:32 AM
yaofeng yaofeng is offline
Yaofeng
Location: East Brunwsick, New Jersey
 
Join Date: Mar 2008
Posts: 295
Mein Auto: 525/540it/540it/325/mini
Google is your friend.

http://www.bimmerboard.com/forums/posts/560290
__________________
'95 525i 5 speed, built 5/94, with a 93 m50tu engine
'94 540it built 3/93, converted to 6 speed with a 93 e32 m60 engine
'01 540it, built 6/01
'03 325i 5 speed, built 9/02
'10 mini 6 speed
Reply With Quote
  #4  
Old 04-15-2010, 10:50 PM
remuse remuse is offline
Registered User
Location: Southern California
 
Join Date: Oct 2006
Posts: 17
Mein Auto: '04 545
Thank you to everyone for their help!
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 05:28 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms