Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E36/7 Z3 (1996-2002)

E36/7 Z3 (1996-2002)
E36/7 Z3 Roadster, Z3 coupe, Z3 M Roadster and Z3 M Coupe talk with our gurus here.

Reply
 
Thread Tools Display Modes
  #1  
Old 04-20-2010, 11:43 AM
MvertDoug's Avatar
MvertDoug MvertDoug is offline
Making fast faster
Location: columbia, MO, United States
 
Join Date: Aug 2009
Posts: 148
Mein Auto: 2006 z4M roadster
S54 engine "stumbles" when at idle

S54 engine "stumbles" when at idle. It only does this after about five minutes or so of running. It always happens at idle when stationary. I stopped at a car lot yesterday,left it running and it "dropped" a couple of times. Almost like it throttles down then back up. Radiator fan kicking on? Air con is off when this happens. Anyone else notice this with the car running in the driveway?
__________________
2008 BMW M COUPE- -DME TUNE-RPI RAM AIR-H&R SPORT SPRINGS-GRUPPE M INTAKE-EISENMANN RACE EXHAUST-TEKARBON ANGEL EYES PROJECT
Reply With Quote
Advertisement
  #2  
Old 04-20-2010, 11:49 AM
jragan's Avatar
jragan jragan is offline
Officially Welcomed to the 'Fest
Location: Fort Worth, Texas
 
Join Date: Dec 2007
Posts: 471
Mein Auto: 07 Imola Red/Black MCoupe
When was the last time you ran a bottle of techron through?
__________________
His: E86 ///M Coupe: Pics Track Pics Vids
Hers: 997-1 C4S: Pics
Reply With Quote
  #3  
Old 04-20-2010, 11:56 AM
MvertDoug's Avatar
MvertDoug MvertDoug is offline
Making fast faster
Location: columbia, MO, United States
 
Join Date: Aug 2009
Posts: 148
Mein Auto: 2006 z4M roadster
Quote:
Originally Posted by jragan View Post
When was the last time you ran a bottle of techron through?
09/2010. Added to my weekend list of todo's.
__________________
2008 BMW M COUPE- -DME TUNE-RPI RAM AIR-H&R SPORT SPRINGS-GRUPPE M INTAKE-EISENMANN RACE EXHAUST-TEKARBON ANGEL EYES PROJECT
Reply With Quote
  #4  
Old 04-20-2010, 12:14 PM
aestheticstorm's Avatar
aestheticstorm aestheticstorm is offline
Rad Racer World Champion
Location: San Jose, CA
 
Join Date: Apr 2008
Posts: 548
Mein Auto: '08 Z4 M Coupé (S.Bronze)
This happens to me a few times a week, after the engine has been running at least 25 minutes (like when I'm stopped at a red light). Is this a problem or some normal "reset" procedure by the computer? FYI I always use Chevron Supreme 92 (which has a Techron additive).
__________________

'08 Z4 M Coupé Sepang Bronze, Black/Black, Madeira Wood, CDV delete // 49th from End of Production
Reply With Quote
  #5  
Old 04-20-2010, 12:18 PM
wildag's Avatar
wildag wildag is offline
///M 'n it up!
Location: Reston, VA
 
Join Date: Dec 2004
Posts: 1,686
Send a message via AIM to wildag
Mein Auto: '06 Z4 M Roadster
Quote:
Originally Posted by mousitch View Post
09/2010. Added to my weekend list of todo's.
Are you from the future?!?!
__________________

DreamingWell.com Web Services
Reply With Quote
  #6  
Old 04-20-2010, 12:21 PM
jragan's Avatar
jragan jragan is offline
Officially Welcomed to the 'Fest
Location: Fort Worth, Texas
 
Join Date: Dec 2007
Posts: 471
Mein Auto: 07 Imola Red/Black MCoupe
Do you have the charcoal pre-filter in place?
__________________
His: E86 ///M Coupe: Pics Track Pics Vids
Hers: 997-1 C4S: Pics
Reply With Quote
  #7  
Old 04-20-2010, 12:23 PM
aestheticstorm's Avatar
aestheticstorm aestheticstorm is offline
Rad Racer World Champion
Location: San Jose, CA
 
Join Date: Apr 2008
Posts: 548
Mein Auto: '08 Z4 M Coupé (S.Bronze)
Quote:
Originally Posted by jragan View Post
Do you have the charcoal pre-filter in place?
What's a charcoal pre-filter? Mine's stock setup.
__________________

'08 Z4 M Coupé Sepang Bronze, Black/Black, Madeira Wood, CDV delete // 49th from End of Production
Reply With Quote
  #8  
Old 04-20-2010, 12:26 PM
MvertDoug's Avatar
MvertDoug MvertDoug is offline
Making fast faster
Location: columbia, MO, United States
 
Join Date: Aug 2009
Posts: 148
Mein Auto: 2006 z4M roadster
Quote:
Originally Posted by wildag View Post
Are you from the future?!?!
oops!


Does everyone here have their chacoal filter removed? I'm debating taking it in to service because my warranty only has five days left.
__________________
2008 BMW M COUPE- -DME TUNE-RPI RAM AIR-H&R SPORT SPRINGS-GRUPPE M INTAKE-EISENMANN RACE EXHAUST-TEKARBON ANGEL EYES PROJECT
Reply With Quote
  #9  
Old 04-20-2010, 12:28 PM
MvertDoug's Avatar
MvertDoug MvertDoug is offline
Making fast faster
Location: columbia, MO, United States
 
Join Date: Aug 2009
Posts: 148
Mein Auto: 2006 z4M roadster
Quote:
Originally Posted by jragan View Post
Do you have the charcoal pre-filter in place?
Beat me to it. Yes it's removed. Ive seen the TSB that talks about that. It's going back in too. So much for that extra 1/2 HP.
__________________
2008 BMW M COUPE- -DME TUNE-RPI RAM AIR-H&R SPORT SPRINGS-GRUPPE M INTAKE-EISENMANN RACE EXHAUST-TEKARBON ANGEL EYES PROJECT
Reply With Quote
  #10  
Old 04-20-2010, 12:33 PM
jragan's Avatar
jragan jragan is offline
Officially Welcomed to the 'Fest
Location: Fort Worth, Texas
 
Join Date: Dec 2007
Posts: 471
Mein Auto: 07 Imola Red/Black MCoupe
Quote:
Originally Posted by aestheticstorm View Post
What's a charcoal pre-filter? Mine's stock setup.
If you open up your air box, you'll actually have two filters in there. One is a charcoal pre-filter and then there's your actual paper filter. It's a pretty popular "mod" to remove the charcoal pre-filter, however there's a BMW TSB out that lists its removal as a possible cause for engine operational issues (no one's really been able to confirm or deny this occurrence, however).
__________________
His: E86 ///M Coupe: Pics Track Pics Vids
Hers: 997-1 C4S: Pics
Reply With Quote
  #11  
Old 04-20-2010, 12:57 PM
Dammmittt's Avatar
Dammmittt Dammmittt is offline
///M
Location: In between locations...
 
Join Date: Jun 2007
Posts: 1,371
Mein Auto: 07 M Coupe
Mine used to do that too...never took out the charcoal filter...hasn't happened in ages though....not sure what the reason is/was. Plenty has changed since the last time it happened,a couple years ago.
__________________


07 ///M Coupe (Premium Package) Black Saphire Ext. Imola Red Int.

Best Website in the History of the Internet!
Reply With Quote
  #12  
Old 04-20-2010, 01:41 PM
MvertDoug's Avatar
MvertDoug MvertDoug is offline
Making fast faster
Location: columbia, MO, United States
 
Join Date: Aug 2009
Posts: 148
Mein Auto: 2006 z4M roadster
Quote:
Originally Posted by Dammmittt View Post
Mine used to do that too...never took out the charcoal filter...hasn't happened in ages though....not sure what the reason is/was. Plenty has changed since the last time it happened,a couple years ago.
Weird. I just noticed mine doing it a couple of weeks ago. I've had the char filter out for about 8 months.
__________________
2008 BMW M COUPE- -DME TUNE-RPI RAM AIR-H&R SPORT SPRINGS-GRUPPE M INTAKE-EISENMANN RACE EXHAUST-TEKARBON ANGEL EYES PROJECT
Reply With Quote
  #13  
Old 04-20-2010, 02:18 PM
jragan's Avatar
jragan jragan is offline
Officially Welcomed to the 'Fest
Location: Fort Worth, Texas
 
Join Date: Dec 2007
Posts: 471
Mein Auto: 07 Imola Red/Black MCoupe
Could it be the DME adjusting to the first warm days?
__________________
His: E86 ///M Coupe: Pics Track Pics Vids
Hers: 997-1 C4S: Pics
Reply With Quote
  #14  
Old 04-20-2010, 02:21 PM
MvertDoug's Avatar
MvertDoug MvertDoug is offline
Making fast faster
Location: columbia, MO, United States
 
Join Date: Aug 2009
Posts: 148
Mein Auto: 2006 z4M roadster
This could be. Also I do the DME "reset" trick every time I get her out of the garage. So even that could be as the DME resets itself.
__________________
2008 BMW M COUPE- -DME TUNE-RPI RAM AIR-H&R SPORT SPRINGS-GRUPPE M INTAKE-EISENMANN RACE EXHAUST-TEKARBON ANGEL EYES PROJECT
Reply With Quote
  #15  
Old 04-20-2010, 05:21 PM
MvertDoug's Avatar
MvertDoug MvertDoug is offline
Making fast faster
Location: columbia, MO, United States
 
Join Date: Aug 2009
Posts: 148
Mein Auto: 2006 z4M roadster
Charcoal filter back in. Weather preventing me from taking it out tomorrow.
__________________
2008 BMW M COUPE- -DME TUNE-RPI RAM AIR-H&R SPORT SPRINGS-GRUPPE M INTAKE-EISENMANN RACE EXHAUST-TEKARBON ANGEL EYES PROJECT
Reply With Quote
  #16  
Old 04-20-2010, 05:33 PM
aestheticstorm's Avatar
aestheticstorm aestheticstorm is offline
Rad Racer World Champion
Location: San Jose, CA
 
Join Date: Apr 2008
Posts: 548
Mein Auto: '08 Z4 M Coupé (S.Bronze)
Quote:
Originally Posted by mousitch View Post
Charcoal filter back in. Weather preventing me from taking it out tomorrow.
Obviously it's not the filter as I'm having the same symptoms with it in.
__________________

'08 Z4 M Coupé Sepang Bronze, Black/Black, Madeira Wood, CDV delete // 49th from End of Production
Reply With Quote
  #17  
Old 04-20-2010, 05:37 PM
MvertDoug's Avatar
MvertDoug MvertDoug is offline
Making fast faster
Location: columbia, MO, United States
 
Join Date: Aug 2009
Posts: 148
Mein Auto: 2006 z4M roadster
Quote:
Originally Posted by aestheticstorm View Post
Obviously it's not the filter as I'm having the same symptoms with it in.
Have you taking it in to be looked at? I'm thinking about it.
__________________
2008 BMW M COUPE- -DME TUNE-RPI RAM AIR-H&R SPORT SPRINGS-GRUPPE M INTAKE-EISENMANN RACE EXHAUST-TEKARBON ANGEL EYES PROJECT
Reply With Quote
  #18  
Old 04-20-2010, 06:26 PM
aestheticstorm's Avatar
aestheticstorm aestheticstorm is offline
Rad Racer World Champion
Location: San Jose, CA
 
Join Date: Apr 2008
Posts: 548
Mein Auto: '08 Z4 M Coupé (S.Bronze)
Quote:
Originally Posted by mousitch View Post
Have you taking it in to be looked at? I'm thinking about it.
I very highly doubt you'll be able to reproduce it to check anything out. I'm not losing sleep over it.

Might be a Sepang Bronze isolated problem
__________________

'08 Z4 M Coupé Sepang Bronze, Black/Black, Madeira Wood, CDV delete // 49th from End of Production

Last edited by aestheticstorm; 04-20-2010 at 06:30 PM.
Reply With Quote
  #19  
Old 04-21-2010, 06:24 AM
MvertDoug's Avatar
MvertDoug MvertDoug is offline
Making fast faster
Location: columbia, MO, United States
 
Join Date: Aug 2009
Posts: 148
Mein Auto: 2006 z4M roadster
Quote:
Originally Posted by aestheticstorm View Post
I very highly doubt you'll be able to reproduce it to check anything out. I'm not losing sleep over it.

Might be a Sepang Bronze isolated problem

That damn Sepang! My only issue with it is that it is causing me to stall out occasionally when I start off after idling for a bit. It's like I have to clean it out before i start or it just jumps and dies. I know I havent forgot how to drive it. Hopefully like I said just a fuel issue.
__________________
2008 BMW M COUPE- -DME TUNE-RPI RAM AIR-H&R SPORT SPRINGS-GRUPPE M INTAKE-EISENMANN RACE EXHAUST-TEKARBON ANGEL EYES PROJECT
Reply With Quote
  #20  
Old 04-21-2010, 06:39 AM
Zuzax's Avatar
Zuzax Zuzax is offline
Calvinball Professional
Location: In the Transmogrifier
 
Join Date: Sep 2006
Posts: 1,103
Mein Auto: '07 M Roadster
Could it be your Powerchip tune mucking things up?

Not a believer in the Sepang theory. I too have a Sepang (mightiest of the colors) and have not had the issue.
__________________

2007 Z4 M Roadster Sepang/Sepang-X/Black, Premium, Nav, BMW Strut Bar, Stubby Antenna, Dice, UUC clutch stop, Star Specs, and the rest joyfully stock.
Reply With Quote
  #21  
Old 04-21-2010, 07:14 AM
MvertDoug's Avatar
MvertDoug MvertDoug is offline
Making fast faster
Location: columbia, MO, United States
 
Join Date: Aug 2009
Posts: 148
Mein Auto: 2006 z4M roadster
Quote:
Originally Posted by Zuzax View Post
Could it be your Powerchip tune mucking things up?
If I'm still having problems down the road I'm going to PChip do a reflash. They are supposed to be coming out with a brand new program for the s54 in July.
__________________
2008 BMW M COUPE- -DME TUNE-RPI RAM AIR-H&R SPORT SPRINGS-GRUPPE M INTAKE-EISENMANN RACE EXHAUST-TEKARBON ANGEL EYES PROJECT
Reply With Quote
  #22  
Old 04-21-2010, 07:47 AM
thekurgan's Avatar
thekurgan thekurgan is offline
Bad Lieutenant
Location: Sacramento, CA
 
Join Date: Jul 2007
Posts: 5,844
Mein Auto: S65B40 Powered
Quote:
Originally Posted by mousitch View Post
That damn Sepang! My only issue with it is that it is causing me to stall out occasionally when I start off after idling for a bit. It's like I have to clean it out before i start or it just jumps and dies. I know I havent forgot how to drive it. Hopefully like I said just a fuel issue.
Italian tune-up might be what she needs.

Have you got ahold of the techron concentrate yet? Is it a myth that the oil must be changed after using the concentrate?
__________________

08 E90M3 6MT Alpinweiss/Schwartz/BMW Pedals/Dinan Exhaust/BMW Alcantara wheel
Reply With Quote
  #23  
Old 04-21-2010, 08:00 AM
MvertDoug's Avatar
MvertDoug MvertDoug is offline
Making fast faster
Location: columbia, MO, United States
 
Join Date: Aug 2009
Posts: 148
Mein Auto: 2006 z4M roadster
Quote:
Originally Posted by thekurgan View Post
Italian tune-up might be what she needs.

Have you got ahold of the techron concentrate yet? Is it a myth that the oil must be changed after using the concentrate?
Do the Italian tune-up everyday I can. Found a good isolated straightaway last Sunday. 155 with the top down feels so good. Ive never changed the oil after techron since it goes in the gas. I need to check on that.
__________________
2008 BMW M COUPE- -DME TUNE-RPI RAM AIR-H&R SPORT SPRINGS-GRUPPE M INTAKE-EISENMANN RACE EXHAUST-TEKARBON ANGEL EYES PROJECT
Reply With Quote
  #24  
Old 04-21-2010, 10:49 AM
Erhan Erhan is offline
Registered User
Location: Seattle
 
Join Date: Oct 2007
Posts: 83
Mein Auto: 2007 MC
Quote:
Originally Posted by aestheticstorm View Post
Might be a Sepang Bronze isolated problem
haha no it is not I have the same issue. I had the car serviced. The AC belt was broken so the dealer though that was the reason (which made sense). But than it happened a week after the service too. Right now I don't have a clue about the reason
Reply With Quote
  #25  
Old 04-21-2010, 11:27 AM
Proph Proph is offline
Registered User
Location: Seattle
 
Join Date: Jan 2006
Posts: 66
Mein Auto: 05 Z4 3.0i
How often are you guys seeing this happen? On my M54 engine, it's happened twice in the 1+ year that I've own the car. I'm not too worried.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E36/7 Z3 (1996-2002)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 09:59 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms