Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)

7 Series - E65 / E66 (2002 - 2008)
Discussion pertaining to the flagship BMW here.

Reply
 
Thread Tools Display Modes
  #1  
Old 05-27-2010, 10:32 PM
GMan745Li GMan745Li is offline
Registered User
Location: GA
 
Join Date: May 2010
Posts: 25
Mein Auto: 745Li
04 745Li - Stalling while idle

Car starts fine, no hesitation, no ruff idle. Car stalls while idling in and out of gear. Can hear a rush of air from the passenger side of engine when it stalls. Sounds like pressure escaping from midway of to rear of engine. Car will start right back with no problem. Time of stalling varies from when the car is started to when it occur. Easily recreated by pulling the oil dip stick out and pushing it back in.
Reply With Quote
Advertisement
  #2  
Old 05-29-2010, 07:27 AM
Keif Keif is offline
Master Tinkerer
Location: Houston, TX
 
Join Date: Mar 2008
Posts: 2,201
Mein Auto: 2007 Alpina B7
Is this only within a few minutes after starting the car, or also when the car has been warm and running for a while?
__________________
 
Black 2007 Alpina B7
Tension strut bushings
 
White 2007 Alpina B7
Supercharger clutch/bearings, replaced exhaust valve/pulled head, sunroof seal, 6000K angel eyes
 
Black 2002 BMW 745Li (sold)
KW v3's, blue angel eyes, 8000K headlights & HID fogs, rebuilt alternator & mounting bracket gasket, sunroof seal, CCVs, plugs, sway bar bushings, timing & valve cover gaskets, valve stem seals, guibo joint, mechatronic sealing sleeve, trans fluid, sanded headlights...
Reply With Quote
  #3  
Old 05-30-2010, 08:39 AM
AMONEYXL AMONEYXL is offline
Registered User
Location: QUEENS NY
 
Join Date: Apr 2010
Posts: 46
Mein Auto: 91 E30 99 E46 04 E66
clean ur maf sensor
Reply With Quote
  #4  
Old 05-30-2010, 11:59 AM
AAOO750 AAOO750 is offline
Registered User
Location: Texas
 
Join Date: May 2010
Posts: 65
Mein Auto: 2007 750i
Keif, my 2007 750i is stalling too. It stalls once the car is hot and always seems like it happens when I'm coming to a stop. The last time it stalled when I went to restart the engine turned over about four to five times longer than a normal start before finally firing up. Got the transmission error too during the stall.

Any thoughts?

Fuel pump??? ikob, seems to think my integrated supply module needs to be replaced. I might try replacing next week just to rule it out.
__________________
Reply With Quote
  #5  
Old 05-30-2010, 12:59 PM
AMONEYXL AMONEYXL is offline
Registered User
Location: QUEENS NY
 
Join Date: Apr 2010
Posts: 46
Mein Auto: 91 E30 99 E46 04 E66
did u guys try to clean ur maf's i had the same problem too and thats what i did and my car works like new again
Reply With Quote
  #6  
Old 05-30-2010, 01:10 PM
AAOO750 AAOO750 is offline
Registered User
Location: Texas
 
Join Date: May 2010
Posts: 65
Mein Auto: 2007 750i
I'll check out the MAF. I just went out to move the car and it wouldn't start again. I figured out a way to get it to crank which I have recreated three times now. If I go ape **** on the start/stop button pushing it in and releasing it real fast the car will crank on the 15-20th press. I think I have an electrical problem. Hoping the integrated supply module fix will work.
__________________

Last edited by AAOO750; 05-30-2010 at 02:26 PM.
Reply With Quote
  #7  
Old 05-30-2010, 01:56 PM
AMONEYXL AMONEYXL is offline
Registered User
Location: QUEENS NY
 
Join Date: Apr 2010
Posts: 46
Mein Auto: 91 E30 99 E46 04 E66
do u have a check engine light if so u sould get it scanned that would help alot
Reply With Quote
  #8  
Old 05-30-2010, 02:29 PM
AAOO750 AAOO750 is offline
Registered User
Location: Texas
 
Join Date: May 2010
Posts: 65
Mein Auto: 2007 750i
Yes but it comes and goes. They replaced my crankcase speed sensor last week. The codes it's throwing are in this thread.

http://www.bimmerfest.com/forums/sho...=457581&page=2
__________________
Reply With Quote
  #9  
Old 05-30-2010, 02:45 PM
AMONEYXL AMONEYXL is offline
Registered User
Location: QUEENS NY
 
Join Date: Apr 2010
Posts: 46
Mein Auto: 91 E30 99 E46 04 E66
can u list the codes maybe i can help u.
Reply With Quote
  #10  
Old 05-30-2010, 02:53 PM
AAOO750 AAOO750 is offline
Registered User
Location: Texas
 
Join Date: May 2010
Posts: 65
Mein Auto: 2007 750i
Quote:
Originally Posted by AMONEYXL View Post
can u list the codes maybe i can help u.
Reply in the thread in the link below. Don't want to hijack this thread as my problems are different. Codes are in the link. I need to rescan to see if there are any new ones from this morning when it didn't start.

http://www.bimmerfest.com/forums/sho...=457581&page=2
__________________
Reply With Quote
  #11  
Old 05-31-2010, 04:45 PM
GMan745Li GMan745Li is offline
Registered User
Location: GA
 
Join Date: May 2010
Posts: 25
Mein Auto: 745Li
Took it to the dealer who finally took time to listen to me and he was able to hear the pressure release sound when it stalled out. Currently it is at the dealer facing a $3400 repair.
They found:
1) The fuel pump not sending a signal.
2) Replacing the engine wiring harness (???)
3) The crankcase vent valves.
I can go alone with the fuel pump replacement and very little in agreement with the vent valves.
The Wiring Harness - I can't see how this should be a contributing cause, the tech stated he has seen a faulty wiring harness cause the transmissions code that pop in on repeated start attempt. They said it could be worn insultation on the wires. Has anyone heard of this before?
Reply With Quote
  #12  
Old 05-31-2010, 04:50 PM
GMan745Li GMan745Li is offline
Registered User
Location: GA
 
Join Date: May 2010
Posts: 25
Mein Auto: 745Li
AAOO750 - check your battery cables to make sure they are tight - that was one of my issues.
Check your nav CD, read before it may not be turning off and drawing the battery down.
I took my CD out and will insert when I know I may need it.
Read some guy had himself locked in his trunk to verify this one.
Reply With Quote
  #13  
Old 05-31-2010, 06:19 PM
Keif Keif is offline
Master Tinkerer
Location: Houston, TX
 
Join Date: Mar 2008
Posts: 2,201
Mein Auto: 2007 Alpina B7
AAOO750, I can bring stuff up to you at some point this week and we can pull information, run tests, etc. if you want. Not a big deal. Let me know. I can't promise we'll find the problem for sure, but we'll likely be able to narrow things down a little at least.

Quote:
Originally Posted by GMan745Li View Post
Took it to the dealer who finally took time to listen to me and he was able to hear the pressure release sound when it stalled out. Currently it is at the dealer facing a $3400 repair.
They found:
1) The fuel pump not sending a signal.
2) Replacing the engine wiring harness (???)
3) The crankcase vent valves.
I can go alone with the fuel pump replacement and very little in agreement with the vent valves.
The Wiring Harness - I can't see how this should be a contributing cause, the tech stated he has seen a faulty wiring harness cause the transmissions code that pop in on repeated start attempt. They said it could be worn insultation on the wires. Has anyone heard of this before?
Heard of the wiring harness and IVM causing similar issues, but I'm not a fan of guessing and throwing parts at something.

CCV valves -- buy these yourself and do these yourself, there is a DIY for this and it takes a flathead screwdriver and 5 minutes. It's seriously one of those things so easy that you shouldn't pay someone else to do it.
__________________
 
Black 2007 Alpina B7
Tension strut bushings
 
White 2007 Alpina B7
Supercharger clutch/bearings, replaced exhaust valve/pulled head, sunroof seal, 6000K angel eyes
 
Black 2002 BMW 745Li (sold)
KW v3's, blue angel eyes, 8000K headlights & HID fogs, rebuilt alternator & mounting bracket gasket, sunroof seal, CCVs, plugs, sway bar bushings, timing & valve cover gaskets, valve stem seals, guibo joint, mechatronic sealing sleeve, trans fluid, sanded headlights...

Last edited by Keif; 05-31-2010 at 06:28 PM.
Reply With Quote
  #14  
Old 05-31-2010, 07:19 PM
GMan745Li GMan745Li is offline
Registered User
Location: GA
 
Join Date: May 2010
Posts: 25
Mein Auto: 745Li
Thanks Keif, I agree with CCV DIY, the parts are about $40 and the dealer quoted $314 for the job. I will call him tomorrow to cancel that part of the repair and order CCV.
Reply With Quote
  #15  
Old 06-03-2010, 02:48 PM
GMan745Li GMan745Li is offline
Registered User
Location: GA
 
Join Date: May 2010
Posts: 25
Mein Auto: 745Li
Problem SOLVED: Engine Wiring Harness was not the cause.
Problem - No Start, cuts off at idle:
Cause: Crankshaft position sensor defective, fuel pump defective causing it to short out SBS relay.
Fix: Performed short test, interrograted fault memory, replaced fuel pump, replaced SBSR and programmed new control unit, replaced crankshaft position sensor.
Reply With Quote
  #16  
Old 06-05-2010, 10:04 AM
kippk kippk is offline
Registered User
Location: St. Louis, MO
 
Join Date: May 2010
Posts: 64
Mein Auto: 2004 745i
Quote:
Originally Posted by GMan745Li View Post
Car starts fine, no hesitation, no ruff idle. Car stalls while idling in and out of gear. Can hear a rush of air from the passenger side of engine when it stalls. Sounds like pressure escaping from midway of to rear of engine. Car will start right back with no problem. Time of stalling varies from when the car is started to when it occur. Easily recreated by pulling the oil dip stick out and pushing it back in.
I had similar issue but only on cold starts after "choke" came OFF. The coils for each cylinder needed to be replaced and problem solved.
__________________

'04 745i - 35% tint, Sun Curtains, Convenience & Comfort Access, Premium Sound, 22" DaVinci Wheels, 3M invisible bra
__________________________________________________
I need someone to protect me from all the measures they take in order to protect me.
Reply With Quote
  #17  
Old 06-07-2010, 11:08 AM
GMan745Li GMan745Li is offline
Registered User
Location: GA
 
Join Date: May 2010
Posts: 25
Mein Auto: 745Li
M. Wong, not sure the purpose of your post but if you could reframe from associating this type of language in my post. Thank you.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 02:38 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms