Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E28 (1982 - 1988)

E28 (1982 - 1988)

Reply
 
Thread Tools Display Modes
  #1  
Old 06-12-2010, 05:37 PM
delorean175 delorean175 is offline
Registered User
Location: SLO, CA
 
Join Date: Jun 2010
Posts: 1
Mein Auto: 1986 528e 325k, 1982 528e
No power to the Fuel Injectors! HELP!

I recently did a valve adjustment on my 86 528e. Everything went smoothly. Upon the first warm up everything went great. Then after about 5 min It started missing. I tried to diagnose weather it was spark or fuel. at this point i wasn't sure. During the test run it started missing and i ran it for a fraction of a min after it started. Then the RPM started dropping from idle and it died.

Later i found that piston no 5 lost spark. So i was able to cut the wire and put the end back on. Then the wire got a good connection. So i put the wire back on and i tried starting it. I got nothing. It appeared to be spark issues but then again the wire could have pulled apart when i removed it after the test run. Anyway.

I checked all the other wires. They all seamed fine. I checked the spark and Its there. So i tried using some starting fluid. The car runs but then it dies as soon as it burns off all the fluid. So of course it has to be fuel system. I checked the pump. It has power and tomorrow morning im going to check to see if it is pumping.

I checked the power to the injectors and theres nothing. Im not quite sure what else to check. First thing i checked was fuse panel but everything looks in order there. does anyone have any takes on this?

also i checked the fuel pump. I get power to it, but i tried a new Fuel pump relay anyways; i still got nothing.

Thanks in advance!
Reply With Quote
Advertisement
  #2  
Old 06-13-2010, 11:12 AM
catso's Avatar
catso catso is offline
catso
Location: Chicago
 
Join Date: Dec 2009
Posts: 2,956
Mein Auto: 2000 323i, 1988 528e
There are two pumps, one in the tank and one under the car. I think the Motronic unit controls the injectors but I wouldn't suspect that just yet. The fuel pressure regulator is something you may want to check. Do you have a Bentley manual? The section on fuel supply is very informative and gives you a good trobleshooting procedure.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E28 (1982 - 1988)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Forum Jump


All times are GMT -7. The time now is 10:01 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms