Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E38 (1995 - 2001)

7 Series - E38 (1995 - 2001)

Reply
 
Thread Tools Display Modes
  #26  
Old 08-02-2010, 08:06 PM
balance balance is offline
Officially Welcomed to the 'Fest
Location: NC
 
Join Date: Feb 2009
Posts: 758
Mein Auto: 97 740iL
Good job man !!! You're lucky you changed it before it took out the fuel pump. I wouldn't go back to that mechanic anytime soon. The fuel filter should be changed every 30,000 miles.
Reply With Quote
  #27  
Old 08-04-2010, 08:52 AM
poohbear15 poohbear15 is offline
Registered User
Location: ny
 
Join Date: Mar 2010
Posts: 31
Mein Auto: 740i
oh gosh i think i spoke too soon, car ran perfect for two days n last night it shut off on me, the first thing i thought was the fuel pump n im guessing thats wat it is. any other suggestions?????? btw bmw wants like $411 for the fuel pump is there any other company that can offer me a good one for less $
Reply With Quote
  #28  
Old 08-04-2010, 10:48 AM
poohbear15 poohbear15 is offline
Registered User
Location: ny
 
Join Date: Mar 2010
Posts: 31
Mein Auto: 740i
ok so i just drove the car with the back seat out so i could hear the fuel pump, wen i started drivin it would make a funny noise other than the quiet hummmm. idk if this is normal please let me know so i can make the next move
Reply With Quote
  #29  
Old 08-04-2010, 01:09 PM
poohbear15 poohbear15 is offline
Registered User
Location: ny
 
Join Date: Mar 2010
Posts: 31
Mein Auto: 740i
also can sumbody tell me how t remove the fuel pump
Reply With Quote
  #30  
Old 08-04-2010, 02:29 PM
balance balance is offline
Officially Welcomed to the 'Fest
Location: NC
 
Join Date: Feb 2009
Posts: 758
Mein Auto: 97 740iL
All the fuel pump is, is a small electrical motor, so it should only be making one noise. I haven't had to change mine yet, but there should be a write-up on www.E38.org. And $411 sounds way too high, but I get all my parts from a distributer that sells to german car dealerships, so my prices are usually lower than the what I see in other places.
Reply With Quote
  #31  
Old 08-04-2010, 07:23 PM
poohbear15 poohbear15 is offline
Registered User
Location: ny
 
Join Date: Mar 2010
Posts: 31
Mein Auto: 740i
i realized the connector goin to the pump was a lil loose so i tightened it, so far so good but ima have to wait n make sure
Reply With Quote
  #32  
Old 08-06-2010, 06:57 AM
poohbear15 poohbear15 is offline
Registered User
Location: ny
 
Join Date: Mar 2010
Posts: 31
Mein Auto: 740i
ok so it wasnt the connection must be the fuel pump, anybody suggest any companies other than oem that offer good ones
Reply With Quote
  #33  
Old 08-06-2010, 12:19 PM
balance balance is offline
Officially Welcomed to the 'Fest
Location: NC
 
Join Date: Feb 2009
Posts: 758
Mein Auto: 97 740iL
Fuel pumps are pretty simple, and even the cheap ones should last a very long time. The only thing you would probably notice with the more expensive ones is less noise while its running.

Has it shut off again sinse the last time you posted?
Reply With Quote
  #34  
Old 08-06-2010, 02:37 PM
poohbear15 poohbear15 is offline
Registered User
Location: ny
 
Join Date: Mar 2010
Posts: 31
Mein Auto: 740i
yeah it has, i had the car running in my driveway n it shut off after and hour, then i turned it on n it shut off after 20 mins or so. i got the fuel level very low so i cud pull out the pump. it was easy gettin it out now i gotta wait till tomorrow morning for the new one. oh btw there was as good amt of debris i had to clean at the bottom of the pump reservoir
Reply With Quote
  #35  
Old 08-07-2010, 01:54 PM
balance balance is offline
Officially Welcomed to the 'Fest
Location: NC
 
Join Date: Feb 2009
Posts: 758
Mein Auto: 97 740iL
If you change the fuel pump, make sure you change the mesh filter that is connected to the bottom of the pump as well.

When the car shuts off, the lights on the dash stay on right? Does it sputter at all, or does it just feel like someone turned the key off?
Reply With Quote
  #36  
Old 08-07-2010, 02:31 PM
Payback's Avatar
Payback Payback is offline
Officially Welcomed to the 'Fest
Location: Sykesville, MD
 
Join Date: Jan 2009
Posts: 143
Mein Auto: 97' 740iL
http://allmercedes.com/.
Try this company out. I order BMW parts from them at good prices and the overnight shipping is wonderful.

Good Luck!
__________________

97' 740iL
"Phantom Of The Opera"
Reply With Quote
  #37  
Old 08-07-2010, 02:58 PM
poohbear15 poohbear15 is offline
Registered User
Location: ny
 
Join Date: Mar 2010
Posts: 31
Mein Auto: 740i
thnx ima check them out, n no it doesnt sputter, like u said its just like sumone turned the key off n yes the lights in the dash stay on. btw i changed the fuel pump n that filter you mentioned this morning. i let the car run for a while started to drive n got about a block away before it shut off......wat about the relay? i was told it could have a short or sumthing
Reply With Quote
  #38  
Old 08-08-2010, 11:08 AM
balance balance is offline
Officially Welcomed to the 'Fest
Location: NC
 
Join Date: Feb 2009
Posts: 758
Mein Auto: 97 740iL
I guess it could be the relay but it's strange that the car doesn't sputter at all. Even if the pump shuts off there should still be enough fuel pressure to make the car sputter for a second before shutting off.

The lights are still on in the dashboard so that's telling me that it isn't a loose ground, and if the lights stay on without dimming you're probably getting enough power for spark. Did the problem just start on its own, or did it happen after someone did work on the car? If the relay isn't expensive, you could give it a try just to rule out the fuel system. If it isn't the fuel system then it's weird that changing the fuel filter actually helped. Did you ever change the crank sensor?

I'm trying man, but I wish I could check your car out in person. It's hard to do this over the internet, but I'll keep giving help if I can. If you do take it to another shop, make sure you tell them everything that you changed and everything that you tried to make it easier for them to pinpoint. I'd really like to find out what's wrong with it.
Reply With Quote
  #39  
Old 08-08-2010, 12:02 PM
poohbear15 poohbear15 is offline
Registered User
Location: ny
 
Join Date: Mar 2010
Posts: 31
Mein Auto: 740i
i did the cam position sensor but not the crank position sensor cause i was told the car wouldnt start if the crank sensor was bad. one day i was divin home and the car just shut off, nobody worked on it before hand so idk, but ima try the relay next and then the maf again. btw i really appreciate your and everybody elses help i cudnt do this alone
Reply With Quote
  #40  
Old 08-10-2010, 06:39 AM
poohbear15 poohbear15 is offline
Registered User
Location: ny
 
Join Date: Mar 2010
Posts: 31
Mein Auto: 740i
i change the fuel pump relay didnt help, now ima check/clean the idle air control valve
Reply With Quote
  #41  
Old 08-10-2010, 10:16 AM
poohbear15 poohbear15 is offline
Registered User
Location: ny
 
Join Date: Mar 2010
Posts: 31
Mein Auto: 740i
i took off the idle air control valve. it was dirty so i cleaned it n re-installed it. could this have been causing my problems?
Reply With Quote
  #42  
Old 08-10-2010, 03:03 PM
balance balance is offline
Officially Welcomed to the 'Fest
Location: NC
 
Join Date: Feb 2009
Posts: 758
Mein Auto: 97 740iL
If the IAC was bad, the car should have been running rough at idle. Usually even if the IAC goes bad, the car will still run at higher RPMs.

You should scan the computer again and see if any codes popped up, even if the check engine light isn't on. You should also call some local shops and see if you have one near you that will only charge you if they find the problem. Tell them that a few people already looked at it and you don't want to spend more money without a guarantee.
Reply With Quote
  #43  
Old 08-10-2010, 07:17 PM
poohbear15 poohbear15 is offline
Registered User
Location: ny
 
Join Date: Mar 2010
Posts: 31
Mein Auto: 740i
so i was test drivin the car n it shut off on me, anywho im supposed to bring it to a mechanic but he charges 90 n hr im just tryna exhaust all my options before i bring it to him. the only thing left i cud think of is maybe a clogged fuel line or like alternator or batt or sumthin idk anymore
Reply With Quote
  #44  
Old 08-11-2010, 08:27 AM
balance balance is offline
Officially Welcomed to the 'Fest
Location: NC
 
Join Date: Feb 2009
Posts: 758
Mein Auto: 97 740iL
It is possible that the fuel line got kinked if the car bottomed out somewhere hard. The designers usually put the lines next to frame rails and other well protected areas, but it does happen on occasion. I don't think that it is a charging issue (battery,alternator), as there would be symptoms before the car shut off.

You should scan for error codes one more time before sending it to the tech. I wish I could provide more options but if this was my car, I wouldn't know what to check for next.
Reply With Quote
  #45  
Old 08-11-2010, 02:17 PM
poohbear15 poohbear15 is offline
Registered User
Location: ny
 
Join Date: Mar 2010
Posts: 31
Mein Auto: 740i
yeah ima just have the mechanic check it out, but one more thing yesterday like 3 mins before it shu off i felt a quick loss of power that lasted like a sec
Reply With Quote
  #46  
Old 08-11-2010, 02:27 PM
balance balance is offline
Officially Welcomed to the 'Fest
Location: NC
 
Join Date: Feb 2009
Posts: 758
Mein Auto: 97 740iL
Well, you can be sure that it isn't the fuel system, since the you've replaced every part that would cause the issue, and it probably isn't a sensor since no codes are popping up. I'm wondering if maybe you have a loose connection somewhere, a failing ECU, or a security system that is going crazy and shutting the car off. Come to think of it, what happens when the battery in the key goes bad?

Those were all guesses. If you take it to a tech, make sure you tell them about everything you've tested, and everything you've changed, so that they get a better idea about the issue and so that they don't charge extra for the time to check everything again.
Reply With Quote
  #47  
Old 08-11-2010, 05:30 PM
poohbear15 poohbear15 is offline
Registered User
Location: ny
 
Join Date: Mar 2010
Posts: 31
Mein Auto: 740i
i was thinkin a loose connection also or maybe a bad ground sumwhere. my bro was telling me maybe it was the security since the main key doesnt start the car cause the chip is bad i use the spare key but the main key unlocks the door, trunk, lowers the windows etc. i dont think its that tho cause i been using the same key since i got the car for last fall and it just started shutting off a few months ago
Reply With Quote
  #48  
Old 08-12-2010, 12:28 PM
poohbear15 poohbear15 is offline
Registered User
Location: ny
 
Join Date: Mar 2010
Posts: 31
Mein Auto: 740i
can u explain how to check the maf again? i wanna make sure its not that again
Reply With Quote
  #49  
Old 08-12-2010, 01:33 PM
balance balance is offline
Officially Welcomed to the 'Fest
Location: NC
 
Join Date: Feb 2009
Posts: 758
Mein Auto: 97 740iL
If the Mass Air Flow meter is going bad, it will usually cause the car to sputter, misfire, and run rough. What the MAF does is meter how much air goes into the motor, and it adjusts fuel to match it, to get the best air/fuel mixture for the RPM range. If you disconnect the MAF while the car is at idle, the computer will go to a set air/fuel mixture that should make the car idle smoothly.

One way to find out if the MAF is bad, is to turn the car on, and if the car is running rough, disconnect it. If the car runs smoother, then the MAF is probably bad, if it runs the same, then the MAF is probably good.
Reply With Quote
  #50  
Old 08-13-2010, 05:36 AM
poohbear15 poohbear15 is offline
Registered User
Location: ny
 
Join Date: Mar 2010
Posts: 31
Mein Auto: 740i
ok cool, i do remember doin that but i did it again anyway, car sounded fine wen i took it off so i guess its good, bout to take the car to the mechanic
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E38 (1995 - 2001)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Forum Jump


All times are GMT -7. The time now is 01:19 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms