Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E38 (1995 - 2001)

7 Series - E38 (1995 - 2001)

Reply
 
Thread Tools Display Modes
  #1  
Old 08-11-2010, 07:56 PM
wojg wojg is offline
Registered User
Location: Canada
 
Join Date: Aug 2010
Posts: 9
Mein Auto: 2001 BMW 740i Sport
01 740iL - Dash error lights all on

Hello all BMW owners! I signed up to this forum because I am in need of assistance and advice. I am fixing up a 2001 BMW 740i for my uncle. The car was in an accident that had the whole front end busted up but no air bags were deployed. Just the other day I put it back together enough to fire it up (minus body panels, hood, bumper, and headlights.) It started fine, like it was running just yesterday. The only problem is I have all the possible lights eluminated on the dash, it's like a christmas tree. SES, ABS, ASC+T/DSC, DBC, battery and Airbag. Yes, this is my worst nightmare. Please if any one can help lead me in the right direction in any of these problems I will be happy to listen or read for that matter. If anyone needs more information I can provide that as soon as I can so I can troubleshoot this. Once again any advice will be greatly appreciated.
Reply With Quote
Ads by Google
  #2  
Old 08-12-2010, 08:07 AM
Adi's Avatar
Adi Adi is offline
Officially Welcomed to the 'Fest
Location: Hamburg, Germany
 
Join Date: Jun 2006
Posts: 333
Mein Auto: E38 750iL, A6 (4f) Avant
Low battery charge or dead cell often gives these kind of issues.
__________________
*
Audi A6 Quattro Avant (2007) - Oyster Gray Met.
E38 750iL (1995) - Cosmos Schwarz
*

Sign by Danasoft - Get Your Free Sign

Reply With Quote
  #3  
Old 08-12-2010, 08:16 AM
wojg wojg is offline
Registered User
Location: Canada
 
Join Date: Aug 2010
Posts: 9
Mein Auto: 2001 BMW 740i Sport
Quote:
Originally Posted by Adi View Post
Low battery charge or dead cell often gives these kind of issues.
Thanks for the reply. I did a test of my charging system using a multimeter I noticed the Voltage before the car is started is 12.2V - 12.3V. Once I start the car the battery voltage DROPS to 11.6 - 11.93V. This is an alternator from an autowrecker I bought because the old one was smashed up. Do you think this could be the problem?

Thanks again..
Reply With Quote
  #4  
Old 08-13-2010, 12:57 AM
Adi's Avatar
Adi Adi is offline
Officially Welcomed to the 'Fest
Location: Hamburg, Germany
 
Join Date: Jun 2006
Posts: 333
Mein Auto: E38 750iL, A6 (4f) Avant
Under charge from your alternator, your battery should be getting up around 14V or higher but those at-rest figures look ok.

I'd take your battery to a shop to get it checked out because that would be the easiest first step.

If that's ok, then I guess you can be pretty sure it is the alternator - by process of elimination.
__________________
*
Audi A6 Quattro Avant (2007) - Oyster Gray Met.
E38 750iL (1995) - Cosmos Schwarz
*

Sign by Danasoft - Get Your Free Sign


Last edited by Adi; 08-13-2010 at 12:59 AM.
Reply With Quote
  #5  
Old 08-13-2010, 08:42 AM
wojg wojg is offline
Registered User
Location: Canada
 
Join Date: Aug 2010
Posts: 9
Mein Auto: 2001 BMW 740i Sport
Quote:
Originally Posted by Adi View Post
Under charge from your alternator, your battery should be getting up around 14V or higher but those at-rest figures look ok.

I'd take your battery to a shop to get it checked out because that would be the easiest first step.

If that's ok, then I guess you can be pretty sure it is the alternator - by process of elimination.
Thanks for writing back Adi. The battery is brand new but I went and tested it to make sure. It passed! So now I must replace the alternator. Do you think I can just replace the voltage regulator on this alternator? I've read on one of the forums that someone did do that and it fixed the problem. I did take apart my old busted up alternator and it is quite easy to get to the voltage regulator, just remove the pulley, 4 screws, and a nut. In my opinion that would be a $75 (with shipping) fix than spending 400+ on an entire complete unit? I also did the cluster unlock and did a voltage test just to see how the voltage was behaving and the voltage before starting was 12.9V and after I started it it dropped to about 11.9 -12 V and stayed there. I'm hoping if I fix the charging all the other warning lights will disappear. Thanks again for writing back.
Reply With Quote
  #6  
Old 08-15-2010, 10:07 AM
wojg wojg is offline
Registered User
Location: Canada
 
Join Date: Aug 2010
Posts: 9
Mein Auto: 2001 BMW 740i Sport
I took the alternator apart and am debating whether it is the voltage regulator or diodes. I did try to check the diodes using a multimeter by checking the resistance on each but don't know what good diodes produce as resistance. Any one know what I should be looking for in bad diodes? Any help is greatly appreciated. Thanks
Reply With Quote
  #7  
Old 08-17-2010, 02:41 PM
wojg wojg is offline
Registered User
Location: Canada
 
Join Date: Aug 2010
Posts: 9
Mein Auto: 2001 BMW 740i Sport
I've replaced my alternator for a rebuilt one. It is now charging as it should but the rest of my lights are on except for the charging lamp which is off. Any help where to look would be greatly appreciated. Thank you
Reply With Quote
  #8  
Old 05-02-2012, 05:38 PM
YoungDonM60 YoungDonM60 is offline
Registered User
Location: New York
 
Join Date: Mar 2012
Posts: 1
Mein Auto: BMW 740il
Low voltage

I am experiencing similar problems.. when I rev the car, the interior lights gets brighter... Another thing is, the alarm keeps going off by itself... car feels a little sluggish. I have a bran new alternator (140amp) bran new battery (110v).. dont know how to stop the alarm from going off by it self.. one of the key is damaged, remote dont work...
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E38 (1995 - 2001)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Forum Jump


All times are GMT -7. The time now is 01:10 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms