Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E89 Z4 (2009 - current)

E89 Z4 (2009 - current)

Thread Tools Display Modes
Old 08-27-2010, 08:10 AM
hartwick hartwick is offline
Registered User
Location: Ocala, Florida
Join Date: Dec 2009
Posts: 24
Mein Auto: BMW Z4
2003 Z4 + passenger airbag light won't reset

Original owner of a 2003 Z4, 2.5, 5 speed, with just under 27,000 miles. Car is pristine: all maintenance performed; no accidents, no abuse. All performance is up to BMW standards, but:

The airbag indicator light came on recently. Took car to reputatable independent foreign car repair place that has state-of-the-art diagnostics( and is owned and operated "hands on" by a former electrical engineer/ auto enthusiast). Found two codes:

1) 93CA deactivation: satellite, door, front right; and,
2) 93AF no message from satellite, door, front right.

Indy shop owner advised to replace the passenger side airbag and the satellite unit which we did. Following that, the shop computer was cleared, rebooted, and the same codes reappeared. His computer indicated the airbag and satellite were getting all electrical power within normal limits. However, despite numerous attempts to reset the dashboard light, the car's computer allegedly would not allow his computer to proceed to that step. So, the repair shop agreed to eat the price of the parts installed and no charge for the labor!! He recommended taking the car to the dealer to see if they can reset the warning light.

Any ideas what's going on? Any recommendations? I don't particularly wish to just ignore the warning light, but I don't know, or trust this new in town BMW dealer. Don't want to be taken advantage of and be told to buy a new ECU, but I really don't know enough about what is going on...that's why I looking for help here.

Thanks for your thoughts on this problem.
Reply With Quote
Old 08-27-2010, 10:32 AM
craig01b craig01b is offline
Registered User
Location: Guelph Ontario
Join Date: Apr 2010
Posts: 73
Mein Auto: 2003 z4
Yikes, a tough one. The only other thing i could think of is the developer of his software for his diagnostic tool may have some info. Not that familiar with bmw's, but I know with my vdub, there have been issues with communications and certain modules and the aftermarket tool I use gets regular updates for *buggy* modules.

Good luck
Reply With Quote

See More Related BMW Stories

Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E89 Z4 (2009 - current)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT -7. The time now is 01:06 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
© 2001-2015 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms