Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > F10 / F11 (2011 - Current)

F10 / F11 (2011 - Current)
The new chapter in the highly successful story of the BMW 5 Series Sedan (F10) and wagon (F11)

Reply
 
Thread Tools Display Modes
  #1  
Old 09-13-2010, 02:29 PM
sbron sbron is offline
Registered User
Location: Houston
 
Join Date: Jun 2010
Posts: 18
Mein Auto: USA
Sending address from Google Maps?

I have a F10 535i with the Nav system. I have previously been able to send addresses using google maps but now it no longer works. This becomes really important because the ability to input addresses is often hampered by the systems "intuitive" responses that choose an address that is not what I want and leave me with no way to get around what it has decided I want. BMW Assist says they are aware of the problem to send maps and they do not have a fix yet. This has been going on for awhile, not sure how long but at least weeks. Anyone else have a problem with this?

Beyond this I find the accuracy and functionality of the BMW Nav system to be far inferior to a cheap Garmin. I have a garmin and have now taken to using it in the car. It's more accurate, gives more information, is easy to update with new map updates available every three or four months. I does have a smaller screen and a more annoying voice but it cost way less.
Reply With Quote
Advertisement
  #2  
Old 09-13-2010, 03:23 PM
tadtaggert tadtaggert is offline
Officially Welcomed to the 'Fest
Location: Ohio
 
Join Date: Aug 2010
Posts: 476
Mein Auto: M6 F12
I've not had any problems with the new Nav in the F10, I do have friends that have and it seems to be location dependent for some reason. Ran across this the other day, so I guess it just depends.
Reply With Quote
  #3  
Old 09-13-2010, 03:45 PM
AlexK AlexK is offline
Account closed at users request
Location: .
 
Join Date: Jul 2009
Posts: 650
Mein Auto: .
Quote:
Originally Posted by sbron View Post
I have a F10 535i with the Nav system. I have previously been able to send addresses using google maps but now it no longer works. This becomes really important because the ability to input addresses is often hampered by the systems "intuitive" responses that choose an address that is not what I want and leave me with no way to get around what it has decided I want. BMW Assist says they are aware of the problem to send maps and they do not have a fix yet. This has been going on for awhile, not sure how long but at least weeks. Anyone else have a problem with this?

Beyond this I find the accuracy and functionality of the BMW Nav system to be far inferior to a cheap Garmin. I have a garmin and have now taken to using it in the car. It's more accurate, gives more information, is easy to update with new map updates available every three or four months. I does have a smaller screen and a more annoying voice but it cost way less.


Contact BMW Assist again, tell them to re-check (ask them to spell it) your e-mail address which is on their records, it sometimes changes for some reason. And it's not really correct to compare F10's navi accuracy to Garmin units, as Garmin uses Navteq as a source of map data, not TeleAtlas.

Last edited by AlexK; 09-13-2010 at 03:46 PM.
Reply With Quote
  #4  
Old 09-13-2010, 07:34 PM
mlai mlai is online now
Officially Welcomed to the 'Fest
Location: Hong Kong
 
Join Date: Jun 2010
Posts: 138
Mein Auto: F06 650i/E93 M3
Quote:
Originally Posted by sbron View Post
I have a F10 535i with the Nav system. I have previously been able to send addresses using google maps but now it no longer works. This becomes really important because the ability to input addresses is often hampered by the systems "intuitive" responses that choose an address that is not what I want and leave me with no way to get around what it has decided I want. BMW Assist says they are aware of the problem to send maps and they do not have a fix yet. This has been going on for awhile, not sure how long but at least weeks. Anyone else have a problem with this?

Beyond this I find the accuracy and functionality of the BMW Nav system to be far inferior to a cheap Garmin. I have a garmin and have now taken to using it in the car. It's more accurate, gives more information, is easy to update with new map updates available every three or four months. I does have a smaller screen and a more annoying voice but it cost way less.
I did without NAV on my F10 partly for those reasons. GPS are very cheap (if not free with phone) nowadays. And I can take them when I change cars......
__________________
2011 E93 M3 Convertible AW/CR DCT/Brembo GT BBK/Michellin PSS/Morr VS52 19"
2013 F06 650i GranCoupe Ruby Black/Dakota Cinnamon/IAS/DHP/Comfort Seat/Soft Close doors/Surround View/Full LED
Reply With Quote
  #5  
Old 09-14-2010, 06:56 AM
tim-atl tim-atl is offline
Officially Welcomed to the 'Fest
Location: Atlanta
 
Join Date: Jul 2007
Posts: 203
Mein Auto: 2010 X5 35d + 2011 528i
Quote:
Originally Posted by AlexK View Post
Contact BMW Assist again, tell them to re-check (ask them to spell it) your e-mail address which is on their records, it sometimes changes for some reason.

FWIW, This is exactly what happened to me a few months ago (in an E70). Mystery email address removal from my account, which led me to have a WTF moment with BMWAssist.

Tim
Reply With Quote
  #6  
Old 09-14-2010, 07:19 AM
lindros2 lindros2 is offline
Officially Welcomed to the 'Fest
Location: The Ghetto Hood
 
Join Date: Jun 2010
Posts: 492
Mein Auto: BMW
No problems here. I'll try again today and report back.
Reply With Quote
  #7  
Old 09-14-2010, 07:43 AM
sbron sbron is offline
Registered User
Location: Houston
 
Join Date: Jun 2010
Posts: 18
Mein Auto: USA
I did call BMW assist and they told me it was a known problem with no fix at this point? That just relates to the current problem of not being able to send an address via Google Maps.

The other short comings I am dealing with have occurred in the Houston area. It has lost guidance and failed to find addresses in areas that are not new. It could not figure out how to transition from hwy 290 North onto the Sam Houston Tollway South, not a new or a minor intersection. Wanted me to make a U-turn at the top of a fly over. Maybe since Houston is only the 4th largest city in the country the map quality can't be as important or up to date as some others?
Reply With Quote
  #8  
Old 09-14-2010, 11:32 AM
rdlm rdlm is offline
Registered User
Location: California
 
Join Date: May 2010
Posts: 58
Mein Auto: 2011 535
My 535 is in the shop right now due to the BMW Assist being flaky. The SOS call wasn't working reliably even to get it registered, and sending addresses from Google Maps only worked for 3 out of 9 addresses (the three were all in a row, while the others were over several days).

My SA called me to tell me that the SOS problem is because the computer was still partially in "transport" mode, and is now fixed.

Both the SA and foreman were adamant that the Google Maps integration shouldn't work unless I pay the extra $199/year for the BMW Assist "Convenience" package. I think/hope I've convinced them that there are two Google Maps integration features, one that's free (sending addresses) and one that's extra cost (integration of Google Maps searches into iDrive). I'm now waiting to hear more later today. But if the cell link was flaky due to the 'transport" mode issue, perhaps it caused this issue to? Note that before bringing it into the shop, I called BMW Assist and had them attempt to triage this issue. They confirmed my email address was fine, tried to send an address themselves, and then suggested I make a service appointment. They did not mention any "known problem".
Reply With Quote
  #9  
Old 09-14-2010, 04:30 PM
bklyn550 bklyn550 is offline
Officially Welcomed to the 'Fest
Location: NYC
 
Join Date: Oct 2006
Posts: 207
Mein Auto: 2011 550i sport
I think u need the concierge package....I have done it without problems...the navigation is a little off in NYC sometimes but not that bad plus the 3d buildings look awesome. I am sure a software update will fix all the issues we are having. I am always going to get navigation in my cars because the systems make the car function so much more efficient ie changing radio etc...no navigation in a 50k plus car is lame. Garmin is good for bikes and hikes.

Sent from my Nexus One using BimmerApp
Reply With Quote
  #10  
Old 09-14-2010, 07:45 PM
Hoss NY Hoss NY is offline
Registered User
Location: NYC
 
Join Date: Apr 2010
Posts: 80
Mein Auto: F10 535i
Yes, I've experienced the same google maps issue. It worked a while ago. But when I tried it this weekend, no email showed up in the car.
Reply With Quote
  #11  
Old 09-15-2010, 12:12 AM
rdlm rdlm is offline
Registered User
Location: California
 
Join Date: May 2010
Posts: 58
Mein Auto: 2011 535
No, you definitely don't need the "convenience plan" to send an address to the car from Google Maps. However, there is a thicker-richer-and-better-tasting Google Maps integration that does require the $199/year subscription. The brochure attached at the bottom of this linked page does a reasonable job of explaining both: http://www.bmwusa.com/Standard/Conte...t/Default.aspx

I got the car back tonight, and BMW couldn't find anything wrong beyond the computer still being partially in "transport" mode. Once they cleared that, they tried both SOS and sending addresses from Google Maps, and both worked fine. Whether that was the root issue, or whether there is a broader intermittent issue (as implied by others having a similar issue) is to be determined over the next several days.
Reply With Quote
  #12  
Old 09-15-2010, 01:05 AM
wisbimmer20 wisbimmer20 is offline
Officially Welcomed to the 'Fest
Location: Wisconsin, USA
 
Join Date: Nov 2009
Posts: 1,112
Send a message via AIM to wisbimmer20
Mein Auto: 1998 BMW 328I
The new 5er is terrible. Too big, too much emphasis on technology and luxury than driving experience and performance. BMW has lost its way.
__________________


Previous BMWs:

1995 BMW 530i
1995 BMW 525i
Reply With Quote
  #13  
Old 09-19-2010, 09:16 PM
shortcut3d shortcut3d is offline
Registered User
Location: San Francisco, CA
 
Join Date: Aug 2007
Posts: 71
Mein Auto: '11 535i F10
My CA setup BMW Assist, but said I had to call to get an account name to use the google feature. I looked at the BMW Assist enrollment print out and did not see an account name. What is it by default?
__________________
Current:
535i F10 - Dark Graphite / Oyster Black / Dark Wood - Premium Package, Premium Package 2, Convenience Package, Sport Package, Sport Auto

Previous:
6MT 335i E92 - Sapphire Black Metallic / Saddle Brown / Gray Poplar - ZPP, ZSP, Active Cruise, Navigation, CA, PDC, Heated Seats, HD Radio, iPod
Delivered: 11/03/07
Reply With Quote
  #14  
Old 09-19-2010, 09:36 PM
rdlm rdlm is offline
Registered User
Location: California
 
Join Date: May 2010
Posts: 58
Mein Auto: 2011 535
There are two parts to getting BMW Assist set up. After the dealership does it's part, wait a day or two and press the SOS button. When the agent comes on the line, tell them you want to register your subscrption. Other than try to up-sell you, they will confirm that your car correctly sent it's location, that your car is correctly identified, etc. They will also ask you for an email address for your account. It is this this email address (eg: "johndoe@yahoo.com") that you enter into Google Maps as the "BMW Assist account name".

If you haven't done the registration by SOS, you should! In other threads, I've read that your account isn't fully activated until you do this. And in my case, I found it wasn't working correctly due to the computer still wrongly being in "transport". You definitely want to get this all working now, just in case you actually need it in the future.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > F10 / F11 (2011 - Current)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 08:10 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms