Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)

E34 (1989 - 1995)

Reply
 
Thread Tools Display Modes
  #1  
Old 09-29-2010, 07:41 AM
ahults ahults is offline
Registered User
Location: beardstown, IL
 
Join Date: Sep 2010
Posts: 57
Mein Auto: 1995 BMW 540i
engine running rich

My 95 540i is running rich there is fuel smell coming from the exhaust. The check engine light comes on and goes off its intermittent. I am wondering if an O2 sensor would cause this? I am new to bmw is there a way to check the computer codes?
Reply With Quote
Advertisement
  #2  
Old 09-29-2010, 07:47 AM
BMR_LVR's Avatar
BMR_LVR BMR_LVR is offline
Humble E34 lover
Location: Asheboro, NC
 
Join Date: Dec 2008
Posts: 5,264
Mein Auto: 1992 525i
Sounds like you are on the right track. You can do a procedure called the stomp test. Either search here or google it as it is a little long winded to explain it here. Basically it is a way to trigger the on board diagnostic computer to display any error codes using a series of flashes of the CEL light on the dash.

Let us know what you find.

Steve
__________________
Most problems are usually something simple !

Quote:
Originally Posted by noego View Post
It's Deja Poo - as in, I've heard this **** before.
Steve

Calypso Red 1992 525i with 200K miles

1991 735i - Sold
1992 525i - Sold
1995 325is - Sold
2000 528i - Sold

Reply With Quote
  #3  
Old 09-30-2010, 08:45 PM
ahults ahults is offline
Registered User
Location: beardstown, IL
 
Join Date: Sep 2010
Posts: 57
Mein Auto: 1995 BMW 540i
I did the stomp test and it cane up with code 1213 O2 sensor lean/rich c/s anyone know what this means? the cars exhaust smells like fuel. Should I replace the secondary O2 sensor? where is located? 95 540i

Thanks
Reply With Quote
  #4  
Old 09-30-2010, 09:17 PM
robertobaggio20 robertobaggio20 is offline
Banned
Location: earth
 
Join Date: Oct 2009
Posts: 3,403
Mein Auto: car
Have you downloaded the bentley manual? It has all the troubleshooting, diagnosis and fixup steps that you need to follow in this situation. Search these forums for the download link. Good luck and let us know how it goes.
Reply With Quote
  #5  
Old 09-30-2010, 09:45 PM
ahults ahults is offline
Registered User
Location: beardstown, IL
 
Join Date: Sep 2010
Posts: 57
Mein Auto: 1995 BMW 540i
I have the bentley manual it really doesn't say much about rich fuel mixture. I looked for vacum leaks but I couldn't find any. the engine has 193,000 I dought any O2 sensors have been replaced. would a faulty O2 sensor cause a rich mixture or could it be a bad mass air flow sensor?
Reply With Quote
  #6  
Old 10-01-2010, 06:10 AM
BMR_LVR's Avatar
BMR_LVR BMR_LVR is offline
Humble E34 lover
Location: Asheboro, NC
 
Join Date: Dec 2008
Posts: 5,264
Mein Auto: 1992 525i
BMW recommends replacing the O2 sensors about every 50-100K miles (I can't remember which). Anyway, you should replace both O2 sensors, especially since you have an error code for it and you have so many miles. Bad O2 sensors will definitely screw with how your engine runs. The E34 only has a pre-cat, two in your case since it is a V8. It's an easy DIY on the 6 cylinders, probably not too bad on the V8. I would not look at the MAF (unknown if it is a problem) until you replace the O@ sensors (known problem). Plus, if the MAF was bad, you would likely get an error code for that as well.

Good luck.

Steve
__________________
Most problems are usually something simple !

Quote:
Originally Posted by noego View Post
It's Deja Poo - as in, I've heard this **** before.
Steve

Calypso Red 1992 525i with 200K miles

1991 735i - Sold
1992 525i - Sold
1995 325is - Sold
2000 528i - Sold

Reply With Quote
  #7  
Old 10-01-2010, 07:17 AM
ahults ahults is offline
Registered User
Location: beardstown, IL
 
Join Date: Sep 2010
Posts: 57
Mein Auto: 1995 BMW 540i
are there just two O2 sensors on the m60? one before cat and one after?
Reply With Quote
  #8  
Old 10-01-2010, 01:20 PM
ahults ahults is offline
Registered User
Location: beardstown, IL
 
Join Date: Sep 2010
Posts: 57
Mein Auto: 1995 BMW 540i
I just ordered both O2 sensors I will let you guys know if that takes care of the problem
Reply With Quote
  #9  
Old 10-01-2010, 07:11 PM
BMR_LVR's Avatar
BMR_LVR BMR_LVR is offline
Humble E34 lover
Location: Asheboro, NC
 
Join Date: Dec 2008
Posts: 5,264
Mein Auto: 1992 525i
Eagerly awaiting results

And yes, there are a total of only 2 O2 sensors on your car, one on each exhaust prior to the catalytic converter.
__________________
Most problems are usually something simple !

Quote:
Originally Posted by noego View Post
It's Deja Poo - as in, I've heard this **** before.
Steve

Calypso Red 1992 525i with 200K miles

1991 735i - Sold
1992 525i - Sold
1995 325is - Sold
2000 528i - Sold

Reply With Quote
  #10  
Old 10-02-2010, 01:50 PM
ahults ahults is offline
Registered User
Location: beardstown, IL
 
Join Date: Sep 2010
Posts: 57
Mein Auto: 1995 BMW 540i
O2 sensors

I got to looking and I think I might have ordered the wrong O2 sensors the part numbers I ordered are bosch 13523 and bosch 13522. I only see two sensors located on each of the exhaust down pipes? I don't see any after the catalytic converter anyone know if these are the correct sensors? it looks like the wiring connector on bosch 13522 is different than 13523. its a 95 540i I am wanting to replace all O2 sensors on the car
Reply With Quote
  #11  
Old 10-03-2010, 09:06 AM
goosefoot33's Avatar
goosefoot33 goosefoot33 is online now
Manualaholic
Location: Hudson, MA
 
Join Date: Mar 2008
Posts: 1,810
Mein Auto: 01 330Ci/94 530i
Where did you order your sensors from? According to autohausaz, those are the correct sensors for your car.
__________________
BMWCCA Member# 451235
(Summer) 2001 330Ci - ZSP
(Winter) 1994 530i "Greenie" - PARTING OUT! (PM for details)

(Grocery Getter) 2002 525iT
Reply With Quote
  #12  
Old 10-03-2010, 09:15 AM
BMR_LVR's Avatar
BMR_LVR BMR_LVR is offline
Humble E34 lover
Location: Asheboro, NC
 
Join Date: Dec 2008
Posts: 5,264
Mein Auto: 1992 525i
Quote:
Originally Posted by ahults View Post
I got to looking and I think I might have ordered the wrong O2 sensors the part numbers I ordered are bosch 13523 and bosch 13522. I only see two sensors located on each of the exhaust down pipes? I don't see any after the catalytic converter anyone know if these are the correct sensors? it looks like the wiring connector on bosch 13522 is different than 13523. its a 95 540i I am wanting to replace all O2 sensors on the car
ahults, as said before, there are only 2 sensors on your car. One on each downpipe as you stated. It is an OBDI car that does not use post cat sensors.
__________________
Most problems are usually something simple !

Quote:
Originally Posted by noego View Post
It's Deja Poo - as in, I've heard this **** before.
Steve

Calypso Red 1992 525i with 200K miles

1991 735i - Sold
1992 525i - Sold
1995 325is - Sold
2000 528i - Sold

Reply With Quote
  #13  
Old 10-03-2010, 10:48 AM
robertobaggio20 robertobaggio20 is offline
Banned
Location: earth
 
Join Date: Oct 2009
Posts: 3,403
Mein Auto: car
Dude, just had an idea. Disconnect the existing o2 sensors...just unplug the sockets from the wiring harness. The car will switch immediately to stored factory values....a backup typical map. This will not be as perfect as working o2 sensors, but will also not lead to running rich condition and you can drive your car comfortably. When you get the new sensors, you can fix them in and reconnect the sockets.
Reply With Quote
  #14  
Old 10-03-2010, 01:12 PM
ahults ahults is offline
Registered User
Location: beardstown, IL
 
Join Date: Sep 2010
Posts: 57
Mein Auto: 1995 BMW 540i
I ordered them from autozone but one says it is located after the cat but the only two I see are on each side of the exhaust down pipes before the cat. I thought there was only two O2 sensors located before the cat
Reply With Quote
  #15  
Old 10-03-2010, 04:31 PM
robertobaggio20 robertobaggio20 is offline
Banned
Location: earth
 
Join Date: Oct 2009
Posts: 3,403
Mein Auto: car
Quote:
Originally Posted by ahults View Post
I ordered them from autozone but one says it is located after the cat but the only two I see are on each side of the exhaust down pipes before the cat. I thought there was only two O2 sensors located before the cat
Call them up and talk to a human, they are usually quite knowledgeable and always very helpful.
Reply With Quote
  #16  
Old 10-04-2010, 02:11 PM
ahults ahults is offline
Registered User
Location: beardstown, IL
 
Join Date: Sep 2010
Posts: 57
Mein Auto: 1995 BMW 540i
I got the right sensors I should have them installed by this weekend I'll let you guys know if it helps the rich fuel mixture
Reply With Quote
  #17  
Old 10-10-2010, 03:17 PM
ahults ahults is offline
Registered User
Location: beardstown, IL
 
Join Date: Sep 2010
Posts: 57
Mein Auto: 1995 BMW 540i
I wanted to let you guys know the O2 sensors fixed my rich fuel mixture, runs like a champ now, thanks for all your help
Reply With Quote
  #18  
Old 10-10-2010, 05:05 PM
robertobaggio20 robertobaggio20 is offline
Banned
Location: earth
 
Join Date: Oct 2009
Posts: 3,403
Mein Auto: car
That's great champ. Now go for that WOT
Reply With Quote
  #19  
Old 10-10-2010, 06:48 PM
BMR_LVR's Avatar
BMR_LVR BMR_LVR is offline
Humble E34 lover
Location: Asheboro, NC
 
Join Date: Dec 2008
Posts: 5,264
Mein Auto: 1992 525i
Great Thanks for letting us know the results.
__________________
Most problems are usually something simple !

Quote:
Originally Posted by noego View Post
It's Deja Poo - as in, I've heard this **** before.
Steve

Calypso Red 1992 525i with 200K miles

1991 735i - Sold
1992 525i - Sold
1995 325is - Sold
2000 528i - Sold

Reply With Quote
  #20  
Old 03-03-2014, 10:08 PM
Bossyeeee Bossyeeee is offline
Registered User
Location: California
 
Join Date: Mar 2014
Posts: 6
Mein Auto: 1995 540i
Hey quick question I know. This is an old forum .. But before u changed o2sensors .. Did u experience rough idling n abnormal (rediculously low) gas mileage I have same exact model and year and am expire wincing very rich emissions
Reply With Quote
  #21  
Old 03-03-2014, 10:11 PM
Bossyeeee Bossyeeee is offline
Registered User
Location: California
 
Join Date: Mar 2014
Posts: 6
Mein Auto: 1995 540i
Quote:
Originally Posted by ahults View Post
I wanted to let you guys know the O2 sensors fixed my rich fuel mixture, runs like a champ now, thanks for all your help
Any info would be much appreciated
Reply With Quote
  #22  
Old 03-04-2014, 10:40 PM
Dionte's Avatar
Dionte Dionte is online now
Drive her like an ///M
Location: Douglasville, GA
 
Join Date: Oct 2012
Posts: 422
Send a message via Skype™ to Dionte
Mein Auto: 1992 BMW 535i (manual)
Quote:
Originally Posted by Bossyeeee View Post
Hey quick question I know. This is an old forum .. But before u changed o2sensors .. Did u experience rough idling n abnormal (rediculously low) gas mileage I have same exact model and year and am expire wincing very rich emissions
I wouldn't doubt it. Had the same issue on my 535i. Used to idle up and down and get terrible gas milage and it also had a bad fuel smell. After I got a new o2 sensor, gas mileage increased, fuel smell went away, idled normal and steady and it restored my throttle response.

Did you pull any codes?

Sent from BimmerApp mobile app
__________________
1992 535i 5-Speed
Miles: 217k
Area: Douglasville, Georgia



Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 03:53 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms