Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)

E34 (1989 - 1995)

Reply
 
Thread Tools Display Modes
  #1  
Old 10-12-2010, 07:59 PM
traiconghoa traiconghoa is offline
Registered User
Location: FL
 
Join Date: Oct 2010
Posts: 3
Mein Auto: 540i
95 540i auto transmission problem. Please HELP!!

Just replaced new motor, and driving good for couple weeks. However, this morning the car start but won't go anywhere when I put in drive (none of the gears are working) except reverse. Please help to figure out the problem and how to fix it. Thanks
Reply With Quote
Advertisement
  #2  
Old 10-12-2010, 08:11 PM
robertobaggio20 robertobaggio20 is offline
Banned
Location: earth
 
Join Date: Oct 2009
Posts: 3,403
Mein Auto: car
Disconnect the battery and unplug the ecu for 1 hour, then plug everything back in again and try. Before that, use the stomp test (search for it on bimmerfest) and pull out the error codes on your vehicle. You can use it to clear the error codes as well after you've pulled them out. Oh, you're driving a 95 vehicle, so there should be no need to disconnect the battery and ecu to reset the computers, but maybe its a good idea anyway as I'm not sure if the transmission computer can be reset via the stomp test's code clearing mechanism.

After all this, fix everything back again, start the car and see if the gears work.

Last edited by robertobaggio20; 10-12-2010 at 08:48 PM.
Reply With Quote
  #3  
Old 10-15-2010, 11:15 AM
traiconghoa traiconghoa is offline
Registered User
Location: FL
 
Join Date: Oct 2010
Posts: 3
Mein Auto: 540i
Is there a obd on a 95 540i, and where it located? Thanks
Reply With Quote
  #4  
Old 10-16-2010, 05:11 PM
fabi fabi is offline
mama toto
Location: elizabeth
 
Join Date: Apr 2010
Posts: 21
Mein Auto: 5series
there is no obd on it...it take a cirlce plug from a scan tool under the hood like the newer ones
Reply With Quote
  #5  
Old 10-17-2010, 04:55 AM
mikes95540i mikes95540i is offline
Officially Welcomed to the 'Fest
Location: Columbia SC
 
Join Date: Sep 2008
Posts: 118
Mein Auto: 1995 540i V8 Auto Trans.
My 95 540i auto trans has an obd plug. WRONG!
As I started righting my comment I questioned myself and went out to look. Fabi is correct, it does take the circle scan tool. The location is on the right side next to the negative terminal located at the firewall. Right side meaning the passenger side on US cars.
Damn... that's another tool I need. :-)
__________________

1995 E34 BMW 540iA M60 V8 Auto Trans.
668 Schwartz II Black II Standard Black 51 91 1 052 171
Reply With Quote
  #6  
Old 10-18-2010, 10:34 AM
traiconghoa traiconghoa is offline
Registered User
Location: FL
 
Join Date: Oct 2010
Posts: 3
Mein Auto: 540i
Thanks for the useful informations. Just wonder if I can purchase a BMW circle 16 pins adapter to use it with my Actron OBD II to reset the transmission code?
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 05:24 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms